Delen via


Scripts aan clientzijde werken niet meer in Microsoft Dynamics CRM Online na de service-update van december 2012

Dit artikel helpt u bij het oplossen van scriptfouten nadat uw Microsoft Dynamics CRM Online organisatie is bijgewerkt naar de service-update van december 2012.

Van toepassing op: Microsoft Dynamics CRM Online
Origineel KB-nummer: 2804561

Symptomen

Als uw formulieren gebruikmaken van de V4.0-client-API (crmForm), kunnen er scriptfouten optreden nadat uw Microsoft Dynamics CRM Online organisatie is bijgewerkt naar de service-update van december 2012. Mogelijk ziet u een dialoogvenster met de tekst 'Undefined', of ziet u een fout in de linkerbenedenhoek van het formulier met de tekst 'Fout op pagina'. Andere verschillende scriptfouten kunnen worden weergegeven.

Oorzaak

De service-update van december 2012 voor Microsoft Dynamics CRM een nieuwe systeeminstelling geïntroduceerd waarmee wordt bepaald of HTML-onderdelen (HTC) al dan niet worden opgenomen in Microsoft Dynamics CRM formulieren. Deze instelling is standaard uitgeschakeld in Microsoft Dynamics CRM Online.

Voor de volgende crmForm-eigenschappen is HTC vereist:

CrmForm-eigenschappen
. Opslaan(
. SaveAndClose(
. FormType
. ObjectTypeCode
. ObjectId
. ObjectTypeName
. RequiredLevel
. SetFocus(
. FireOnChange
. Min
. Max
. DataValue
.Isdirty
. Handicap
. SelectedOption
. SelectedText
. SortEnum
. Sorteren
. SelectedIndex
. InnerText
. OptionsXml
. Precisie
. DataXml
. Tekst
. Waarde
. DisplayValue
. WillSubmit
. DataChangeHandler
. BypassValidation
. AllowFormFocus
._bSaving
._htcInitCompleted
. SubmitFormId
.NO_DATA
. RefreshOnSave
. Zichtbaar
. ForceSubmit
. Formulier
. TimeControl
.isInitialized
.allowblankdate
. IsMoney
. IsBaseCurrency
. CurrencySymbol
. CurrencyPrecision
. IgnoreCurrencySymbol
. IgnoreRange
. PrecisionChangeHandler
. TrimValue
. Maxlength
Enumerator

Oplossing

  1. Meld u als systeembeheerder aan bij de Microsoft Dynamics CRM webtoepassing.
  2. Klik op Instellingen, klik op Beheer en klik vervolgens op Systeeminstellingen.
  3. Klik op het tabblad Aanpassen .
  4. Klik op het selectievakje naast de instelling Inclusief HTC-ondersteuning in Microsoft Dynamics CRM formulieren.
  5. Klik op OK.

Meer informatie

De crmForm-API is afgeschaft met de release Microsoft Dynamics CRM 2011. Zie de volgende blogberichten voor meer informatie over dit onderwerp en andere mogelijke oorzaken van scriptfouten na de service-update van december 2012: