Delen via


Financiële rapporten van Management Reporter komen niet overeen met de evaluatierapporten van het grootboek in Microsoft Dynamics GP

Van toepassing op: Microsoft Dynamics GP
Origineel KB-nummer: 2910626

Symptomen

Er kunnen veel verschillende rapportageprogramma's worden gebruikt om financiële rapporten voor te bereiden die worden gebruikt om te balanceren naar het GL-evaluatiebalansrapport in Microsoft Dynamics GP. U moet dus bepalen of uw financiële rapporten alleen uit GL-gegevens worden gelezen of dat AA-gegevens ook worden gebruikt. Als AA-gegevens worden gebruikt om de financiële rapporten voor te bereiden, kunnen deze scheef zijn als de gegevens in de AA-tabellen niet overeenkomen met de gegevens in de GL-tabellen.

  • Management Reporter met Data Mart leest uit AA-tabellen als AA is geactiveerd. Dit is standaard in versies tot CU9.
  • Met Management Reporter met verouderde provider kunt u kiezen of u een AA-bedrijf of een GL-bedrijf wilt ophalen.

Oorzaak

Financiële rapportage kan onjuist zijn als AA-gegevens zijn gebruikt om het rapport samen te stellen en uw AA-gegevens niet overeenkomen met GL-gegevens. Records ontbreken mogelijk in AA-tabellen of worden overgeslagen als ze afwijken van de bijbehorende record in GL.

Er zijn verschillende redenen waarom de AA-gegevens mogelijk niet overeenkomen met de GL-gegevens of problemen hebben, waaronder:

  • De module Analytische boekhouding is niet op alle werkstations geïnstalleerd, waar gebruikers transacties sleutelen/boeken. Daarom bestaat de record in GL, maar niet in AA.
  • Gebruikers schakelen de module Analytische boekhouding uit als ze een fout hebben ontvangen die verwijst naar 'aa', zodat AA-tabellen niet worden bijgewerkt.
  • Records worden rechtstreeks geïmporteerd in GL-tabellen en niet in AA-tabellen. Of gebruikers schakelen AA uit als ze aa-fouten ontvangen tijdens het importproces.
  • Gebruikers sluiten het GL-jaar af op een werkstation waarop AA niet is geïnstalleerd. Als gevolg hiervan worden de AA-records niet verplaatst naar de geschiedenis en wordt er geen logboekvermelding Met saldo naar voren gebracht gemaakt in de AA-tabellen.
  • Management Reporter kan de AA-record mogelijk niet lezen als de valuta-id verschilt tussen de AA-record en de bijbehorende record in GL, wat kan worden veroorzaakt door het importeren van records, het activeren van multicurrency of kwaliteitsproblemen met valuta-id's die sindsdien zijn opgelost.
  • De Dynamics-database is over zichzelf hersteld, waardoor het volgende beschikbare getal (in de tabel AAG00102) is teruggezet op een waarde die al is gebruikt. Dit systeem neemt deze waarde af voor de volgende waarde voor de header-id terwijl nieuwe records in de tabel worden ingevoegd. Dit systeem kan dus worden gedupliceerd als het wordt ingevoegd in een waarde voor een gehoorde id die al is gebruikt.
  • Als u een upgrade uitvoert naar Microsoft Dynamics GP 2013 en een functionele valuta-id instelt, maar niet bent geregistreerd voor Multicurrency, of als u geen koppelingen uitvoert zoals aangegeven na het instellen van de functionele valuta.
  • Boekingsonderbrekingen

Oplossing

Als u hulp nodig hebt bij het corrigeren van de resultaten van de onderstaande scripts, opent u een ondersteuningsincident met behulp van de onderstaande categorieën om het juiste ondersteuningsteam te bereiken. Neem de informatie op zoals vermeld in elke stap.

  • Gebruik deze koppeling om online een ondersteuningsincident te openen: https://serviceshub.microsoft.com/supportforbusiness.
  • Gebruik het ondersteuningsonderwerp Financieel - Analytische boekhouding en het subonderwerp: Problemen met gegevensconsistentie.
  • Als u het berichtencentrum wilt bereiken om een ondersteuningsincident te openen, belt u 1-888-477-7877. En geef zoveel mogelijk details op.
  • Houd er rekening mee dat het ondersteuningsincident tijdrovend kan zijn, dus neem voldoende tijd om met de technicus te werken.
  • Het ondersteuningsincident wordt in rekening gebracht, tenzij de enige oorzaak een bekend kwaliteitsprobleem in Microsoft Dynamics GP is. Als meerdere problemen zijn opgelost, blijft de aanvraag in rekening gebracht.
  • Het bereik van het ondersteuningsincident omvat het herstellen van alle gegevens die worden geretourneerd door de onderstaande SQL-scripts, binnen de richtlijnen voor wat we kunnen doen in een reguliere ondersteuningscase. Als er extra hulp nodig is om de hoofdoorzaak te vinden, moet er een nieuw ondersteuningsincident worden geopend. Sommige van de oorzaken komen vaak voor, zoals uitgelegd in de sectie Oorzaak hierboven. Als u bijvoorbeeld vaststelt dat er een verschil in valuta-id's bestaat voor records die zijn geïmporteerd in Microsoft Dynamics GP, moet hiervoor een nieuw ondersteuningsincident worden geopend om met het ondersteuningsteam van eConnect/Integration Manager te kunnen werken. De technicus behoudt de discretie om te adviseren wanneer een nieuw ondersteuningsincident nodig is of wanneer het een adviesbetrokkenheid kan worden.
  • Er kan in eerste instantie één ondersteuningsaanvraag worden geopend, met de resultaten van alle scripts uit stap 1-10 hieronder. De technicus werkt met u in ÉÉN bedrijf en van u wordt verwacht dat u de andere bedrijven zelf corrigeert, met behulp van dezelfde stappen die de technicus u heeft gegeven voor het eerste bedrijf. Aanvullende hulp bij meerdere bedrijven kan een nieuwe case vereisen en is naar eigen goeddunken van de technicus.

Stappen

Opmerking

Als u de resultaten van elk script in Tekst wilt weergeven, drukt u op Alt - T (of selecteer Query in de bovenste menubalk, wijs Resultaten naar aan en selecteert u Resultaten naar tekst) en voert u het script vervolgens opnieuw uit. Dit biedt meer details voor elke sectie met resultaten die worden geretourneerd.

Het KB_AllAAFindScripts.zip-bestand bevat alle scripts voor stap 2, 3, 4, 6 en 9, dus u hoeft het maar één keer te downloaden, maar dezelfde koppeling wordt weergegeven in al deze stappen.

Stap 1: afzonderlijke jaren

Voer de onderstaande scripts uit om te controleren of de jaren in elke tabel verschillend zijn, elkaar niet overlappen en ook consistent zijn met de jaren in de GL-tabellen. Dezelfde jaren moeten in de AAG30000 staan als de GL20000 tabel en de AAG40000 tabel met de GL30000 tabel. Er mogen geen jaren overlappen tussen de AA-tabellen of tussen de GL-tabellen. Als u hetzelfde jaar vindt dat wordt vermeld in zowel open- als geschiedenistabellen of tussen de tabellen is gekrabbeld, of niet consistent is met de jaren in de GL-tabellen, opent u een ondersteuningsaanvraag voor verdere hulp en neemt u de resultaten van alle scripts op.

select distinct(YEAR1) from AAG30000 order by YEAR1
select distinct(YEAR1) from AAG40000 order by YEAR1
select distinct(OPENYEAR) from GL20000 order by OPENYEAR
select distinct(HSTYEAR) from GL30000 order by HSTYEAR

Stap 2: valuta-id-discrepanties zoeken

Download KB_AllAAFindScripts.zip*-bestand en gebruik het AA_FindCurrencyDiscrepancy.sql script voor stap 2 om transacties te identificeren waarbij de valuta-id niet overeenkomt tussen GL- en AA-tabellen in zowel open als geschiedenis:

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

(*Het zip-bestand bevat de scripts voor stap 2, 3, 4, 6 en 9.)

  • Als u niet multicurrency gebruikt of slechts één valuta-id gebruikt, kunt u de velden CURNCYID en CURRNIDX rechtstreeks in de tabellen AA (AAG30001/AAG40002) of GL (GL20000/GL30000) bijwerken. Test om te controleren of de valuta-id overeenkomt met onlangs gesleutelde transacties om ervoor te zorgen dat er geen doorlopend probleem is. Open een ondersteuningsincident als u hulp nodig hebt om de CURNCYID rechtstreeks in de SQL-tabel bij te werken of als u dit opnieuw kunt maken op een huidige transactie.

  • Als multicurrency wordt gebruikt, opent u een ondersteuningsincident en neemt u het volgende op:

    • Geef de resultaten van het script in tekstindeling op. We moeten weten welke tabel de valuta-id had en welke tabel niet. En zijn dit oudere of nieuwere transacties? Als oudere transacties en u zojuist Multicurrency Management hebt geïnstalleerd, hebt u controlekoppelingen uitgevoerd op Multicurrency Setup? Controleer koppelingen moeten teruggaan en de valuta-id bijwerken voor alle bestaande transacties.

    • Welke versie van Microsoft Dynamics GP gebruikt u?

    • Waar zijn de transacties vandaan gekomen? Test om te zien of dit een doorlopend probleem is. Controleer of Multicurrency Management is gemarkeerd in het registratievenster (ga onder Microsoft Dynamics GP naar Hulpprogramma's>instellen>systeemregistratie>.)

    • Wat is uw functionele valuta? Hoeveel valuta-id's gebruikt u?

Stap 3: niet-overeenkomende distributies zoeken

Download het bestand KB_AllAAFindScripts.zip* en gebruik AA_FindUnmatchedDists.sql script voor stap 3 om te bepalen of gedetailleerde gegevens niet overeenkomen tussen de AA- en GL-tabellen. Als er resultaten worden geretourneerd, opent u een ondersteuningsaanvraag voor verdere hulp. En voeg het bestand met resultaten toe in tekstindeling. Deze probleemrecords worden meestal veroorzaakt door importproblemen of gebruikers die werken op een werkstation waarop AA is uitgeschakeld of niet is geïnstalleerd.

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

(*Het zip-bestand bevat de scripts voor stap 2, 3, 4, 6 en 9.)

Opmerking

Dit script mag niet worden gebruikt voor versies die lager zijn dan Microsoft Dynamics GP 10.0 SP2, of wanneer u nog geen gl-eindejaar hebt voltooid op een versie die hoger is dan die versie (bijvoorbeeld wanneer pre-SP2 AA-gegevens nog helemaal niet naar de geschiedenis zijn verplaatst).

Houd er rekening mee dat 'resultaattotalen' tussen de secties kunnen worden weergegeven en misleidend zijn. Deze resultaattotalen zijn een factor van hoe het script is geschreven en kunnen worden genegeerd. U hoeft zich alleen bezig te houden met 'resultaattotalen' die direct na een 'sectie' staan en werkelijke gegevens hebben geretourneerd.

Stap 4: dubbele AA-code-id's zoeken

Download het bestand KB_AllAAFindScripts.zip* en zoek het AA_FindDupaaTrxDimCodeID_AAG00401.sql script voor stap 4 om te zien of er AA-code-id's zijn gedupliceerd (omdat ze worden geïmporteerd). Als er resultaten worden geretourneerd, opent u een ondersteuningsaanvraag voor verdere hulp. Voeg de resultaten van het script toe in tekstindeling en ook de inhoud van de AAG00401 tabel. We kunnen u de stappen bieden om dit op te lossen, maar het kan een kostenpost zijn om microsoft dit voor u te laten doen. Dit probleem wordt veroorzaakt door het importeren of herstellen van een oudere kopie van de Dynamics-database via zichzelf.

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

(*Het zip-bestand bevat de scripts voor stap 2, 3, 4, 6 en 9.)

Stap 5: dubbele AA-header-id's zoeken

Voer het onderstaande script uit om te bepalen of er header-id's zijn gedupliceerd tussen de open en historische AA-tabellen. We kunnen de stappen bieden om dit op te lossen, maar het kan een advieskostenpost zijn om dit voor u te laten doen door Microsoft. Dit probleem wordt veroorzaakt door het importeren of herstellen van een oudere kopie van de Dynamics-database via zichzelf, of door een onderbreking van het posten.

select aaGLHdrID from AAG30000 where aaGLHdrId in (select aagLHDrId from AAG40000)

of

select a.aaGLHdrID, a.JRNENTRY as OPEN_JE#,a.YEAR1 as 'OPEN_YEAR1',
b.JRNENTRY as 'HIST_JE#', b.YEAR1 as 'HIST_YEAR1' From AAG30000 a (nolock)
join AAG40000 b (nolock) on a.aaGLHdrID = b.aaGLHdrID
where a.JRNENTRY <> b.JRNENTRY

Als er resultaten worden geretourneerd, opent u een ondersteuningsaanvraag en voegt u de volgende informatie toe:

  • Resultaten van het script in tekstindeling.
  • Onderzoek de records en geef aan of ze exact dezelfde record zijn of dat ze verschillende records zijn, maar alleen dezelfde header-id hebben.

Stap 6: niet-overeenkomende reeksnummers zoeken (voor P&L-vermeldingen)

Download het bestand KB_AllAAFindScripts.zip* en voer het AA_FindYEC_RetainedEarnings.sql-script uit om te zoeken naar records waarvan de reeksnummers niet overeenkomen tussen AA en GL tussen open en geschiedenistabellen voor de logboekvermelding Met behoud van inkomsten (SOURCDOC ='P&L'). Als er resultaten worden geretourneerd, opent u een ondersteuningsaanvraag en neemt u de resultaten van het script op in tekstindeling. (Als u resultaten hebt gevonden in stap 3 hierboven voor de secties 'GLSEQNMBR', wilt u deze eerst laten oplossen en vervolgens dit script opnieuw uitvoeren voor stap 6, zodat we uw resultaten nu niet nodig hebben voor stap 6 als u resultaten had in stap 3.)

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

(*Het zip-bestand bevat de scripts voor stap 2, 3, 4, 6 en 9.)

Opmerking

Het is mogelijk om resultaten te krijgen met dit bovenstaande script als u momenteel P&L-vermeldingen hebt met meerdere distributielijnen met dezelfde ACTINDX en de gegevens daadwerkelijk geldig zijn. U moet de SEQNUMBR vergelijken tussen de AAG30001 en GL20000 (of AAG40001 en GL30000) voor de geretourneerde resultaten. Als de SEQNUMBR overeenkomt, kunt u de MR-validatiefouten voor de SEQNUMBR negeren en doorgaan.

Stap 7: ontbrekende BBF-vermeldingen zoeken

Als u merkt dat uw financiële rapporten zijn uitgeschakeld op basis van het bedrag van de beginsaldi, ontbreken de BBF-vermeldingen (Balance Brought Forward) mogelijk in de AA-tabellen. Voer de onderstaande scripts uit om te bepalen of de BBF-vermeldingen in GL ontbreken in AA-tabellen. Dit wordt veroorzaakt doordat de gebruiker het GL-jaar afsluit op een werkstation waarop AA is uitgeschakeld of niet is geïnstalleerd. Voor Microsoft Dynamics GP 2013 SP2 en eerdere versies moet u een adviesservice hebben geopend om het GL-jaar opnieuw te openen. Als u Microsoft Dynamics GP 2013 R2 of latere versies hebt, kunt u het selectievakje Reverse Historical Year gebruiken in de eindejaarsafsluitingsroutine van de GL om het jaar opnieuw te openen en het vervolgens opnieuw te openen op een computer waarop de AA-code is geïnstalleerd, zodat de vermeldingen van de BBF worden gemaakt in zowel de AA- als GL-tabellen.

PRINT 'OPEN year missing BBF'
Select distinct (JRNENTRY) from GL20000
where JRNENTRY not in (select JRNENTRY from AAG30000)
and SOURCDOC in ('BBF','P/L')
PRINT 'HISTORY year missing BBF'
Select distinct (JRNENTRY) from GL30000
where JRNENTRY not in (select JRNENTRY from AAG40000)
and SOURCDOC in ('BBF','P/L')

Stap 8: bekend probleem voor AA-budgetten (alleen in Microsoft Dynamics GP 2010 en Microsoft Dynamics GP2013)

In Microsoft Dynamics GP 2013 en Microsoft Dynamics GP 2010 was er een bekend kwaliteitsprobleem (#69354 TFS/69692 PS) waarbij het hoogste niveau van de gebudgetteerde structuur een onjuiste waarde heeft in de tabel AAG00902 (aaLvlCodeString veld) als u doorgaat met het wijzigen van het budget. Management Reporter zoekt naar een lege waarde in dit veld om de hoofdrecord voor de budgetstructuur te identificeren. Deze onjuiste waarde zorgt er dus voor dat MR-rapporten mislukken en er geen AA-budgetgegevens worden geretourneerd. Dit probleem is opgelost in Microsoft Dynamics GP 2013 R2 (12.00.1745). Sql-scripts worden hieronder weergegeven om uit te voeren op de bedrijfsdatabase om dit probleem op te zoeken en ook op te lossen.

Select * from AAG00902 where aaLvlCodeString <> '' and aaLevel = 0

Als het bovenstaande script resultaten retourneert, kunt u het probleem oplossen door dit script uit te voeren op de bedrijfsdatabase:

update AAG00902 set aaLvlCodeString = '' where aaLevel = 0

Stap 9: totalen van AAG30002/AAG40002 komen niet overeen met AAG30001/AAG40001

De som van de toegewezen records in de AAG30002/AAG40002-tabellen moet overeenkomen met de som van de bedragen in de AAG30001/AAG40001 distributietabellen per transactie. Als de bedragen zijn toegewezen aan verschillende AA-codes, kunt u een ander aantal records tussen deze tabellen hebben, maar het belangrijkste is dat ze overeenkomen in totaal 'som' per transactie. MR-rapporten lezen de records niet als de somtotalen niet overeenkomen tussen deze tabellen voor elke transactie. Download de scripts 'zoeken en vergelijken' voor de open en historische jaren hieronder en voer uit op de bedrijfsdatabase.

Opmerking

Als u resultaten hebt gevonden in stap 3 hierboven voor de secties 'AAG30002/AAG40002', wilt u deze eerst laten oplossen en vervolgens dit script opnieuw uitvoeren voor stap 9, zodat we uw resultaten nu niet nodig hebben voor stap 9 als u resultaten had in stap 3.

Download het bestand KB_AllAAFindScripts.zip* via de onderstaande koppeling en gebruik de AA_CompareAAG30001AndAAG30002SummaryValues.sql voor het huidige geopende AA-jaar voor stap 9 en het AA_CompareAAG40001AndAAG40002SummaryValues.sql script voor het historische jaar voor stap 9.

https://mbs2.microsoft.com/fileexchange/?fileID=622816f0-ae1d-4768-a914-e710ec50f411

(*Het zip-bestand bevat de scripts voor stap 2, 3, 4, 6 en 9.)

Als er resultaten worden geretourneerd van een van beide scripts, slaat u de resultaten op in een .rpt bestand en opent u een ondersteuningsaanvraag voor verdere hulp. Voeg de resultaten toe voor beoordeling.

Stap 10: debeten/tegoeden op dezelfde distributielijn

MR kan geen records lezen waarbij zowel de debet- als creditvelden op dezelfde distributieregel zijn ingevuld. Bekende oorzaken kunnen zijn het 'importeren' in de records in die voorwaarde of het gebruik van het hulpprogramma Standaardkosten in Inventaris met een onderdrukking. U kunt de onderstaande SQL-queryscripts uitvoeren op de bedrijfsdatabase om deze records te identificeren. Als u de records wilt herstellen, moet u de record rechtstreeks in de GL/AA SQL-tabellen bijwerken om het bedrag op het debet- of tegoedveld te 'netton', omdat slechts één van deze velden moet worden ingevuld. Het wordt aangeraden om elke record handmatig één voor één te herstellen met behulp van de Dex_Row_Id. (Als u scripts nodig hebt om dit massaal te doen, neemt u contact op met uw Microsoft-partner voor hulp.) Gebruik de onderstaande scripts om de probleemrecords te vinden:

select JRNENTRY,CRDTAMNT,DEBITAMT,ORCRDAMT,ORDBTAMT,* from GL10001 where (CRDTAMNT<>0 and DEBITAMT<>0) or (ORCRDAMT<>0 and ORDBTAMT<>0) 
select JRNENTRY,CRDTAMNT,DEBITAMT,ORCRDAMT,ORDBTAMT,* from GL20000 where (CRDTAMNT<>0 and DEBITAMT<>0) or (ORCRDAMT<>0 and ORDBTAMT<>0) 
select JRNENTRY,CRDTAMNT,DEBITAMT,ORCRDAMT,ORDBTAMT,* from GL30000 where (CRDTAMNT<>0 and DEBITAMT<>0) or (ORCRDAMT<>0 and ORDBTAMT<>0) 
--if using AA, also compare the AA tables:

select AAG0.JRNENTRY  from AAG30001 AAG1
join AAG30000 AAG0 on AAG0.aaGLHdrID = AAG1.aaGLHdrID
where ((AAG1.DEBITAMT <> 0 and AAG1.CRDTAMNT <> 0) or (AAG1.ORDBTAMT <> 0 and AAG1.ORCRDAMT <> 0)) and AAG1.SOURCDOC not in ('BBF','P/L')

select AAG0.JRNENTRY  from AAG40001 AAG1 join AAG40000 AAG0 on AAG0.aaGLHdrID = AAG1.aaGLHdrID 
where ((AAG1.DEBITAMT <> 0 and AAG1.CRDTAMNT <> 0) 
or (AAG1.ORDBTAMT <> 0 and AAG1.ORCRDAMT <> 0)) 
and AAG1.SOURCDOC not in ('BBF','P/L')

Stap 11: de datamart opnieuw opbouwen

Nadat alle resultaten hierboven zijn opgelost, voert u elk script opnieuw uit om ervoor te zorgen dat er geen resultaten meer worden geretourneerd.

Herbouw vervolgens de Data Mart in Management Reporter en genereer uw financiële rapporten opnieuw. (Met SQL Wijzigingen bijhouden kunnen sommige wijzigingen automatisch worden bijgewerkt, maar niet allemaal, en daarom beschouwen we het als best practice om de Data Mart opnieuw te bouwen als er wijzigingen rechtstreeks in SQL zijn aangebracht om ervoor te zorgen dat alle wijzigingen worden herkend.) Hier volgen de stappen om dit te doen (als voorzorgsmaatregel kunt u een back-up maken van de DDM-database, omdat deze wordt verwijderd en opnieuw wordt gemaakt):

  1. Open de configuratieconsole op de server vanuit het menu Start .
  2. Selecteer ERP-integraties in het navigatiedeelvenster aan de linkerkant.
  3. Selecteer de integratie die wordt gebruikt (noteer de servernaam en de databasenamen) en schakel de integratie uit met de knop Integratie uitschakelen.
  4. Selecteer Verwijderen om de ERP-integratie te verwijderen.
  5. Selecteer de Management Reporter Services in het linkernavigatievenster en stop beide Management Reporter Services.
  6. Verwijder de DDM-database in SQL (u kunt eerst een back-up maken, indien nodig).
  7. Start de Management Reporter Services.
  8. Configureer de ERP-integratie opnieuw door naar Bestand>configureren te gaan.
  9. Zodra de installatie is voltooid, schakelt u de ERP-integraties in.

Als de AA-gegevens zijn gecorrigeerd en de bijgewerkte MR van DDM de juiste waarden moet ophalen.

Stap 12: rapportsaldi controleren

Bepaal of het rapport wordt gesaldod naar het GL Trial Balance-rapport of niet. Zo niet, kijk dan of u kunt bepalen wat het verschil is. Is het verschil nog steeds gerelateerd aan het saldo dat naar voren gebrachte posten niet juist is? Als dat het zo is, opent u een ondersteuningsincident voor verdere hulp.

Meer informatie

Zie De procedures voor het einde van het jaar voor analytische boekhouding in Microsoft Dynamics GP voor meer informatie.