Delen via


AADSTS500011 - Resource-principal niet gevonden

In dit artikel wordt een probleem beschreven waarbij gebruikers een 'AADSTS500011'-fout ondervinden wanneer ze zich proberen aan te melden bij Microsoft Entra-id.

Symptomen

Wanneer gebruikers zich proberen aan te melden bij een toepassing die gebruikmaakt van Microsoft Entra ID-verificatie, krijgen ze het volgende foutbericht:

AADSTS500011 - The resource principal named [resource URL] was not found in the tenant named [tenant ID]

Oorzaak

Dit probleem treedt op als de resource-principal (de toepassing of service) niet wordt gevonden in de tenant. Dit probleem treedt op als:

  • De resourcetoepassing wordt niet ingericht door de beheerder in de tenant.
  • De resourcetoepassing wordt niet toegestaan door een gebruiker in de tenant.
  • De resource-URL is niet juist geconfigureerd.
  • De tenant-id is niet juist.

Oplossing

Ga als volgt te werk om dit probleem op te lossen:

  1. Inrichting van resourcetoepassingen controleren:

    • Zorg ervoor dat de toepassing (resource-principal) correct is geregistreerd in uw Microsoft Entra ID-tenant.
    • Ga naar Azure Portal en navigeer naar Microsoft Entra ID > Enterprise-toepassingen.
    • Controleer of de toepassing wordt vermeld en juist is geconfigureerd.
  2. Toestemming voor de toepassing:

    • Zorg ervoor dat de resourcetoepassing is toegestaan door een beheerder of een gebruiker in de tenant.
    • Ga naar Azure Portal en navigeer naar Microsoft Entra > Enterprise-toepassingen.
    • Zoek de toepassing en zorg ervoor dat deze over de benodigde machtigingen en toestemming beschikt.
  3. Resource-URL controleren:

    • Controleer of de resource-URL die wordt weergegeven in het foutbericht overeenkomt met de resourcetoepassing die u hebt ingericht in uw tenant-id.
    • Zorg ervoor dat de verificatieaanvraag wordt verzonden met behulp van de juiste resource-URL.
  4. Tenant-id controleren:

    • Controleer of de tenant-id die wordt weergegeven in het foutbericht hetzelfde is als uw tenant-id.
    • Zorg ervoor dat de verificatieaanvraag wordt verzonden naar de juiste Microsoft Entra ID-tenant.

Meer informatie

Zie Microsoft Entra-verificatie- en autorisatiefoutcodes voor een volledige lijst met verificatie- en autorisatiefoutcodes.

Als u afzonderlijke fouten wilt onderzoeken, gaat u naar https://login.microsoftonline.com/error.