Delen via


U kunt een federatief domein niet toewijzen aan een gebruiker in het Microsoft 365-beheercentrum

Probleem

U maakt een nieuwe gebruiker in het Microsoft 365-beheercentrum. Wanneer u echter probeert een federatief domein toe te wijzen aan de nieuwe gebruiker, wordt het federatieve domein niet vermeld in de lijst met domeinen van de gebruiker.

Hier volgt een voorbeeldscenario van wat er gebeurt wanneer u dit probleem ondervindt:

  • In de Microsoft 365-portal zijn eenmalige aanmelding (SSO) en Active Directory-synchronisatie ingeschakeld.
  • Wanneer u de eigenschappen van het domein op de pagina domeineigenschappen bekijkt, wordt het domeintype vermeld als Federatief of Eenmalige aanmelding. Adatum.com is bijvoorbeeld het federatieve domein.
  • Wanneer u een nieuwe gebruiker maakt, ziet u dat het standaarddomein van Microsoft 365 wordt vermeld als de eerste optie in de vervolgkeuzelijst. Het standaarddomein is bijvoorbeeld contoso.onmicrosoft.com.
  • Wanneer u op de vervolgkeuzelijst klikt om de lijst met domeinen weer te geven, wordt het federatieve domein niet weergegeven. Adatum.com wordt bijvoorbeeld niet weergegeven.

Oorzaak

Dit gedrag is standaard in Microsoft 365. U kunt geen federatieve gebruikers maken via de portal. Alle federatieve gebruikers moeten on-premises worden gemaakt en moeten worden gesynchroniseerd met het Microsoft Azure Active Directory-synchronisatieprogramma.

Opmerking

U kunt ook geen federatief domein instellen als het standaarddomein in Microsoft 365.

Solution

Als u dit gedrag wilt omzeilen, maakt u een overeenkomend gebruikersaccount in de on-premises AD DS-omgeving (Active Directory Domain Services), stelt u de UPN (User Principal Name) op de juiste manier in en synchroniseert u het account en de Microsoft Entra-id met behulp van adreslijstsynchronisatie. Voer hiervoor de volgende stappen uit:

  1. Haal het primaire SMTP-adres van het Microsoft 365-gebruikersaccount op door de volgende stappen uit te voeren:

    1. Meld u als globale beheerder aan bij de Microsoft 365-portal .
    2. Selecteer AdminExchange om het > te openen.
    3. Zoek het gebruikersaccount en dubbelklik erop.
    4. Selecteer in het linkernavigatiedeelvenster het e-mailadres en noteer vervolgens het primaire SMTP-adres van het gebruikersaccount.
  2. Start Active Directory: gebruikers en computers en maak vervolgens een gebruikersaccount in het on-premises domein dat overeenkomt met het Microsoft 365-gebruikersaccount. Zie voor meer informatie maken van een gebruikersaccount in Active Directory: gebruikers en Computers.

  3. Zorg ervoor dat de UPN van het gebruikersaccount is bijgewerkt naar de federatieve domeinnaam. Zie Problemen met Active Directory-gebruikersaccounts oplossen die zijn aangewezen als SSO-geschikte gebruikers-id's van Microsoft 365.

  4. Gebruik ADSI Edit (Active Directory Service Interfaces) om het kenmerk proxyAddresses van het gebruikersobject te bewerken, zodat het overeenkomt met het primaire SMTP-adres dat u in stap 1D hebt genoteerd. Voer hiervoor de volgende stappen uit:

    Opmerking

    Zie ADSI Edit installeren voor meer informatie over het installeren van ADSI Edit.

    1. Selecteer Uitvoeren starten>, typ ADSIEdit.msc en selecteer vervolgens OK.

    2. Klik met de rechtermuisknop op ADSI Bewerken, selecteer Verbinding maken met en selecteer vervolgens OK om de domeinpartitie te laden.

    3. Zoek in het navigatiedeelvenster het gebruikersobject dat u wilt wijzigen, klik er met de rechtermuisknop op en selecteer Vervolgens Eigenschappen.

    4. Selecteer in de lijst Kenmerken het kenmerk proxyAddresses en selecteer vervolgens Bewerken.

    5. Voer in het veld Waarde die u wilt toevoegen het juiste SMTP-adres in en selecteer Vervolgens Toevoegen.

      Opmerking

      De primaire SMTP-adreswaarde voor het gebruikersobject moet worden voorafgegaan door een hoofdletter SMTP: designator, zodat de adreswaarde correct kan worden opgemaakt voor het proxyAddresses-kenmerk. 'SMTP:username@contoso.com' is bijvoorbeeld een acceptabele waarde en 'username@contoso.com' is geen acceptabele waarde.

    6. Selecteer TWEE keer OK en sluit ADSI Edit af.

    Zie ADSI Bewerken gebruiken voor meer informatie over het gebruik van ADSI Edit om Active Directory-kenmerken te bewerken

  5. Adreslijstsynchronisatie afdwingen.

Meer informatie

Zie Problemen met de gebruikersnaam oplossen die zich voordoen voor federatieve gebruikers wanneer ze zich aanmelden bij Microsoft 365, Azure of Intune voor meer informatie.

Heb je nog steeds hulp nodig? Ga naar Microsoft Community.