Delen via


Er is een interne Microsoft Dynamics 365-fout opgetreden tijdens het synchroniseren van afspraken, contactpersonen en taken

Dit artikel bevat een oplossing voor userPrivilegeError die optreedt wanneer u Test & Enable Mailbox selecteert in een postvakrecord in Microsoft Dynamics 365.

Van toepassing op: Microsoft Dynamics 365
Oorspronkelijk KB-nummer: 4346733

Symptomen

Wanneer u Test & Enable Mailbox selecteert in een postvakrecord in Dynamics 365, wordt het veld Afspraken, Contactpersonen en Status van taken weergegeven als Mislukt. Het volgende bericht wordt vastgelegd in de sectie Waarschuwingen :

Er is een interne Microsoft Dynamics 365-fout opgetreden tijdens het synchroniseren van afspraken, contactpersonen en taken voor de postvaknaam<>. Het postvak is niet gesynchroniseerd. De eigenaar van het gekoppelde e-mailserverprofiel <Naam e-mailserverprofiel> is geïnformeerd.
Foutcode van e-mailserver: UserPrivilegeError

Oorzaak

Het foutbericht met de foutcode UserPrivilegeError geeft aan dat de gebruiker die eigenaar is van dit postvak niet voldoende bevoegdheden heeft. Raadpleeg de fout PrivilegeDenied wanneer u synchronisatie aan de serverzijde gebruikt voor een lijst met vereiste bevoegdheden.

Belangrijk

Controleer of de eigenaar van de postvakrecord overeenkomt met de gebruiker. Als het postvak bijvoorbeeld deel uitmaakt van Paul Cannon, moet u ervoor zorgen dat de waarde van de eigenaar in de record ook Paul Cannon is. Als er een andere gebruiker wordt weergegeven, heeft die gebruiker mogelijk geen toegang tot het postvak van Paul Cannon.

Oplossing

Volg deze stappen om dit probleem op te lossen:

  1. Open de postvakrecord in Dynamics 365 als gebruiker met de rol Systeembeheerder.

    Tip

    De waarschuwing bevat een koppeling naar de postvakrecord.

  2. Controleer of het veld Eigenaar in het postvakformulier is ingevuld met de naam van de gebruiker. Als een andere gebruiker wordt vermeld, wijzigt u deze in de naam van de gebruiker.

  3. Selecteer de koppeling in het veld Eigenaar om de gebruikersrecord voor die eigenaar te openen.

  4. Selecteer Rollen beheren om te zien welke beveiligingsrollen aan deze gebruiker zijn toegewezen.

  5. Navigeer naar Instellingen>Beveiliging>Beveiligingsrollen.

  6. Open de rollen in stap 4. Zie De fout PrivilegeDenied treedt op wanneer u synchronisatie aan de serverzijde gebruikt voor een lijst met vereiste bevoegdheden en controleer vervolgens of de beveiligingsrol van de gebruiker deze bevoegdheden bevat.

  7. Nadat u hebt gecontroleerd of de gebruiker de eigenaar van de postvakrecord is en of de beveiligingsrol de vereiste bevoegdheden bevat, selecteert u Test & Enable Mailbox in de postvakrecord opnieuw. Als de test niet resulteert in Geslaagd, bekijkt u het bericht dat wordt weergegeven in de sectie Waarschuwingen voor meer informatie.