Delen via


UnknownIncomingEmailIntegrationError -2147220891 of 80040265 wordt weergegeven in postvakwaarschuwingen in Microsoft Dynamics 365

Dit artikel bevat een oplossing voor een fout die optreedt in postvakwaarschuwingen in Microsoft Dynamics 365.

Van toepassing op: Microsoft Dynamics 365
Oorspronkelijk KB-nummer: 4466423

Symptomen

Wanneer u de sectie Waarschuwingen in een postvakrecord in Dynamics 365 bekijkt, ziet u een van de volgende berichten:

  • 'Er is een onbekende fout opgetreden tijdens het ontvangen van e-mail via het postvak '<Postvaknaam>'. De eigenaar van de profielnaam> van het e-mailserverprofiel <is op de hoogte gesteld. Het systeem probeert later opnieuw e-mail te ontvangen.

    Foutcode van e-mailserver: Exchange-server heeft UnknownIncomingEmailIntegrationError -2147220891 uitzondering geretourneerd."

  • 'Er is een interne Microsoft Dynamics 365-fout opgetreden tijdens het synchroniseren van afspraken, contactpersonen en taken voor het postvak '<Postvaknaam>'. De eigenaar van de profielnaam> van het e-mailserverprofiel <is op de hoogte gesteld. Het systeem probeert het later opnieuw.

    Foutcode van e-mailserver: Crm.80040265.ISV-code heeft de bewerking afgebroken."

Oorzaak

Foutcode 80040265 of -2147220891 geeft een isvAborted-fout aan.

Als u het eerste bericht in de sectie Symptomen ziet, wordt dit meestal veroorzaakt door een werkstroom of aangepaste invoegtoepassing die wordt uitgevoerd wanneer een e-mailrecord wordt gemaakt.

Als u het tweede bericht in de sectie Symptomen ziet, wordt dit meestal veroorzaakt door een werkstroom of aangepaste invoegtoepassing die wordt uitgevoerd wanneer een afspraak, contactpersoon of taakrecord wordt gemaakt.

Oplossing

Controleer of aangepaste invoegtoepassingen of werkstromen synchroon worden uitgevoerd bij het maken van het recordtype (e-mail, afspraak, contactpersoon of taak) vermeld in de fout. Als een invoegtoepassing of werkstroom een fout veroorzaakt tijdens het maken van records, kan synchronisatie aan de serverzijde de record niet maken. Met de volgende stappen kunt u bepalen of er werkstromen of invoegtoepassingen in uw organisatie zijn die worden uitgevoerd tijdens het maken van een e-mailbericht. Gebruik dezelfde stappen voor andere entiteiten, zoals afspraken en taken, door de entiteit te vervangen door het juiste recordtype.

Workflow

  1. Navigeer in de Dynamics 365-webtoepassing naar Instellingen en selecteer vervolgens Processen.

  2. Wijzig de weergave in Geactiveerde processen.

  3. Sorteer op de kolom Primaire entiteit en zoek naar rijen met e-mail als de primaire entiteit en werkstroom als categorie.

    In plaats daarvan kunt u de filteropties in het raster gebruiken om te filteren op Categorie = Werkstroom en Primaire entiteit = E-mail.

  4. Open elke werkstroom die voldoet aan de voorgaande criteria (indien van toepassing).

  5. Als de optie Start wanneer de optie Record is gemaakt is geselecteerd en de optie Deze werkstroom uitvoeren op de achtergrond (aanbevolen) niet is geselecteerd, is deze werkstroom mogelijk de oorzaak.

  6. Selecteer de sectie Processessies aan de linkerkant van de pagina en zoek naar fouten met betrekking tot het e-mailbericht dat niet is gemaakt.

Invoegtoepassing

  1. Navigeer in de Dynamics 365-webtoepassing naar Instellingenaanpassingen> en selecteer vervolgens Het systeem aanpassen.
  2. Selecteer de stappen voor het verwerken van SDK-berichten.
  3. Sorteer op de kolom Primary Object Type Code (SdkMessage Filter) en zoek naar rijen voor de e-mailentiteit .
  4. Als de uitvoeringsmodus in deze rijen is ingesteld op Synchroon, kan dit het maken van e-mail verstoren.

Als u het probleem consistent kunt reproduceren, kunt u proberen de werkstroom of invoegtoepassing tijdelijk uit te schakelen om te bepalen of de werkstroom of invoegtoepassing de oorzaak van het probleem is.