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Your machine doesn't appear when creating a desktop flow connection

This article helps you troubleshoot and resolve the issue of your machine not being listed in the Machine or machine group drop-down when creating a desktop flow connection in Microsoft Power Automate for desktop.

Applies to:   Power Automate
Original KB number:   5003787, 5003788

Symptoms

When you create a connection to run a desktop flow from the cloud, your machine isn't listed in the Machine or machine group drop-down.

Cause

This issue might occur due to the following reasons:

  • The machine is shared by another user, who either deleted or renamed the machine.
  • The machine is part of a machine group. In this case, you can only create a connection with the machine group.

Resolution

Follow these steps to troubleshoot and resolve the issue:

  1. Open the Power Automate machine runtime app and verify that your machine is registered.

    Screenshot that shows your machine is registered in the Power Automate machine runtime app.

  2. Go to the Power Automate portal and verify that you're using the same environment as your machine in Power Automate for desktop.

    Screenshot of the environment shown in the Power Automate portal.

  3. In Power Automate portal, check if your machine appears in the Machines list, and if it's part of a machine group.

    Screenshot of the Machines and the Group lists shown in the Power Automate portal.

    If the machine doesn't appear in the Machines list in the targeted environment, try registering the machine again in this environment.

    If the machine is part of a machine group, you can do one of the followings:

    • Select the machine group instead of an individual machine when you create the desktop flow connection.
    • Remove the machine from its group and select only that specific machine for the desktop flow connection.