Delen via


Toepassingen kunnen een nieuw scanapparaat niet vinden nadat de verbinding met een ander apparaat is verbroken

Dit artikel helpt u de fout te omzeilen die optreedt wanneer een toepassing geen scanapparaat vindt als die scanner is verbonden nadat de verbinding met een andere scanner is verbroken.

Oorspronkelijke productversie: Windows 10, Windows 8.1
Origineel KB-nummer: 4537086

Symptomen

Neem het volgende scenario:

  1. U verbindt een WSD-scanapparaat (Web Services on Devices) met een Windows-computer.
  2. U verbreekt de verbinding met de WSD-scanner.
  3. U sluit een ander scanapparaat, zoals een USB-scanner, aan op de computer.
  4. U start een toepassing die gebruikmaakt van de nieuwe scanner. In dit scenario werkt de toepassing mogelijk niet correct. De toepassing kan bijvoorbeeld de nieuwe scanner niet vinden. Wanneer dit probleem zich voordoet, kan het scannerstuurprogramma een WIA_ERROR_OFFLINE-fout ervaren wanneer de IStiDevice::LockDevice methode wordt aangeroepen.

Opmerking

Dit probleem is van toepassing op Windows 10 versies tot 19H2 (namelijk Windows 10 versie 1909). Het probleem is opgelost in 20H1 (Windows 10 versie 2004)

Oorzaak

Dit probleem treedt op als er een fout optreedt in de service 'Windows Image Acquisition (WIA)' wanneer de service de WSD-scanner initialiseert. Als het initialisatieproces zonder fouten slaagt, treedt dit probleem niet op.

Tijdelijke oplossing

Probeer een van de volgende methoden om dit probleem te omzeilen:

  • Verwijder het verbonden scannerapparaat (bijvoorbeeld met behulp van Apparaatbeheer) en sluit de scanner opnieuw aan.
  • Stop de service Windows Image Acquisition (WIA) en start de service opnieuw.
  • Start de computer opnieuw op terwijl de scanner is aangesloten.

Meer informatie

Zie Foutcodes voor meer informatie over fouten die een WIA-scannertoepassing of -stuurprogramma kan ondervinden.