Udostępnij za pośrednictwem


Podczas przekazywania załączników z Outlook w sieci Web są wyświetlane dwa konta usługi OneDrive

Symptomy

Podczas próby przekazania załączników z Outlook w sieci Web menu Przekaż wyświetla dwa konta usługi OneDrive zamiast jednego.

Zrzut ekranu przedstawiający dwa konta usługi OneDrive w menu Przekazywanie.

Przyczyna

Ten problem występuje, jeśli korzystasz ze środowiska hybrydowego programu Exchange, które ma skrzynkę pocztową Microsoft Exchange Server lokalnie i konto OneDrive dla Firm na platformie Microsoft 365 oraz jeśli konto usługi OneDrive zostało przeniesione do innej lokalizacji geograficznej. Po przeniesieniu usługi OneDrive wewnętrzne i zewnętrzne adresy URL hosta witryny Moja witryna nie zostaną zaktualizowane w tym ustawieniu OwaMailboxPolicy .

Rozwiązanie

Aby rozwiązać ten problem, użyj jednej z następujących metod.

Metoda 1. Aktualizowanie adresów URL hosta witryny Moja witryna

Uruchom następujące polecenie cmdlet, aby zaktualizować wewnętrzne i zewnętrzne adresy URL hosta witryny Moja witryna w OwaMailboxPolicy ustawieniu do wartości dla nowej lokalizacji geograficznej usługi OneDrive:

Set-OwaMailboxPolicy Default -InternalSPMySiteHostURL <new_OneDrive_URL> -ExternalSPMySiteHostURL <new_OneDrive_URL>

Metoda 2. Ustawianie wartości na null

Uruchom następujące polecenie cmdlet, aby ustawić wewnętrzne i zewnętrzne adresy URL hosta witryny Moja witryna w ustawieniu OwaMailboxPolicynull:

Set-OwaMailboxPolicy Default -InternalSPMySiteHostURL $Null -ExternalSPMySiteHostURL $Null

Po zaktualizowaniu OwaMailboxPolicy ustawienia przy użyciu jednej z metod utwórz nowy profil programu Outlook, aby używać zaktualizowanych wartości. Jest to konieczne, ponieważ poprzednie OwaMailboxPolicy ustawienia są buforowane w bieżącym profilu programu Outlook i nie można ich zaktualizować.

Aby uzyskać więcej informacji na temat tego OwaMailboxPolicy ustawienia, zobacz Konfigurowanie współpracy dokumentów z OneDrive dla Firm i lokalnym programem Exchange 2016.