Podczas próby nawiązania połączenia z programem Microsoft Dynamics CRM dla programu Microsoft Dynamics CRM z usługą CRM Online nie można nawiązać połączenia z programem Microsoft Dynamics CRM 2013 for Microsoft Office Outlook
Ten artykuł zawiera rozwiązanie błędu występującego podczas próby połączenia programu Microsoft Dynamics CRM 2013 dla programu Microsoft Office Outlook z usługą CRM Online.
Dotyczy: Microsoft Dynamics CRM Online
Oryginalny numer KB: 3089686
Symptomy
Podczas próby połączenia programu Microsoft Dynamics CRM 2013 dla programu Microsoft Office Outlook (klienta Outlook) z organizacją usługi CRM Online jest wyświetlany następujący błąd:
"Nie można nawiązać połączenia z serwerem Microsoft Dynamics CRM, ponieważ nie możemy uwierzytelnić Twoich poświadczeń. Sprawdź połączenie lub skontaktuj się z administratorem, aby uzyskać więcej pomocy".
Po wybraniu pozycji Szczegóły zostaną wyświetlone następujące dodatkowe szczegóły:
wartość nie może być równa null.
Nazwa parametru: path1
w pliku System.IO.Path.Combine(ścieżka ciągu1, ścieżka ciągu2)
w: Microsoft.Crm.Passport.IdCrl.FederationLogOnManager.. ctor(środowisko ciągów)
w: Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider'1.GetLogonManager()
w: Microsoft.Crm.Outlook.ClientAuth.PassportAuthProvider'1.SignIn()
at Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory'1.SignIn(Uri endPoint, Credentials, AuthUIMode uiMode, IClientOrganizationContext context, Form parentWindow, Boolean retryOnError)
at Microsoft.Crm.Application.Outlook.Config.DeploymentsInfo.DeploymentInfo.LoadOrganizations(AuthUIMode uiMode, Form parentWindow, Credentials)
w: Microsoft.Crm.Application.Outlook.Config.DeploymentsInfo.InternalLoadOrganizations(OrganizationDetailCollection orgs, AuthUIMode uiMode, Form parentWindow)
Przyczyna
Asystent logowania usług online firmy Microsoft nie jest zainstalowany lub nie podano poprawnej nazwy użytkownika i hasła. Jeśli problem jest spowodowany nieprawidłową nazwą użytkownika lub hasłem, może to być poświadczenia buforowane w Menedżerze poświadczeń systemu Windows.
Rozwiązanie
Jeśli asystent logowania usług online firmy Microsoft nie jest zainstalowany, zainstaluj go przy użyciu odpowiedniego linku poniżej. Po zainstalowaniu zamknij i otwórz ponownie Kreatora konfiguracji Microsoft Dynamics CRM dla programu Microsoft Office Outlook.
Jeśli asystent logowania usług online firmy Microsoft jest już zainstalowany i nadal występuje ten błąd, wybierz przycisk OK i powinien zostać wyświetlony monit o podanie nazwy użytkownika i hasła. Jeśli nazwa użytkownika i hasło zostały już wypełnione, oznacza to, że poświadczenia zostały zapisane w pamięci podręcznej. Wprowadź poprawną nazwę użytkownika i hasło, aby upewnić się, że nie są używane nieprawidłowe poświadczenia.
Uwaga 16.
Aby wyświetlić, czy poświadczenia są przechowywane w Menedżerze poświadczeń systemu Windows, wybierz menu Start w systemie Windows i wpisz Menedżer poświadczeń. W obszarze Poświadczenia ogólne mogą zostać wyświetlone poświadczenia rozpoczynające się od Microsoft_CRM. Jeśli hasło zostało zmienione lub używasz innego konta użytkownika, te przechowywane poświadczenia mogą nie być poprawne. Te poświadczenia można usunąć, co uniemożliwi użycie Microsoft Dynamics CRM dla programu Microsoft Office Outlook podczas próby nawiązania połączenia.
Jeśli twoja organizacja CRM Online została już zaktualizowana do aktualizacji 2015 (7.0 lub nowszej), możesz użyć programu Microsoft Dynamics CRM 2015 dla programu Microsoft Office Outlook , który nie korzysta z Asystenta logowania do usług Microsoft Online Services.
Więcej informacji
Jeśli asystent logowania usług online firmy Microsoft nie jest zainstalowany, plik dziennika zawiera następujący błąd:
19:23:00| Błąd| Błąd podczas nawiązywania połączenia z adresem URL:
https://disco.crm.dynamics.com/XRMServices/2011/Discovery.svc
Wyjątek: System.DllNotFoundException: Asystent logowania usług online firmy Microsoft nie jest zainstalowany. 32-bitowy:https://g.microsoftonline.com/0BX00en/500
64-bitowy:https://g.microsoftonline.com/0BX00en/501