Błąd "Problem podczas dodawania do programu Outlook" występuje podczas wdrażania aplikacji Microsoft Dynamics 365 dla programu Outlook
Ten artykuł zawiera rozwiązanie problemu z błędem podczas dodawania do programu Outlook , który może wystąpić podczas wdrażania aplikacji Microsoft Dynamics 365 dla programu Outlook.
Dotyczy: Microsoft Dynamics 365
Oryginalny numer KB: 4528578
Symptomy
Podczas wdrażania aplikacji dla programu Outlook z programu Microsoft Dynamics CE zobaczysz błąd na czerwono przed skrzynką pocztową użytkowników Problem podczas dodawania do programu Outlook. Jeśli wybierzesz więcej szczegółów, zostanie wyświetlony komunikat Nieprawidłowa operacja źródła danych.
Jeśli przejdziesz do obszaru Zarządzaj dodatkami ze skrzynki pocztowej użytkownika, zostanie wyświetlony następujący błąd:
Nie można zlokalizować obiektu katalogu wirtualnego dostępu klienta z elementem InternalURl sygnaturą ecP, usługą.
Uwaga 16.
Aby dodatek pakietu Office został wdrożony w skrzynce pocztowej użytkownika w programie Microsoft Exchange Server, AppsForOfficeEnabled
powinien mieć wartość true. Następujące polecenie umożliwia sprawdzenie ustawień konfiguracji za pomocą powłoki zarządzania programem Exchange (EMS).
Get-OrganizationConfig | Format-List AppsForOfficeEnabled
Przyczyna
Jest to spowodowane wyszukiwaniem odnajdywania z Centrum administracyjnego programu Exchange (EAC). Za każdym razem, gdy wyszukiwanie odnajdywania jest wykonywane po raz pierwszy przy użyciu kontroli eAC w programie Exchange Server 2013, będzie sprawdzać następujące 6 wewnętrznych adresów URL w tle i będzie buforować je lokalnie.
- Znaleziony adres URL:
https://e15-cas.contoso.com/owa
- Znaleziony adres URL:
https://e15-cas.contoso.com/ecp
- Znaleziony adres URL:
https://e15-cas.contoso.com/EWS/Exchange.asmx
- Znaleziony adres URL:
https://e15-cas.contoso.com/Microsoft-Server-ActiveSync
- Znaleziony adres URL:
https://e15-cas.contoso.com/OAB
- Znaleziony adres URL:
https://e15-cas.contoso.com/mapi
[GlobalServiceUrls.DiscoverUrlsIfNeeded] Pomyślnie znaleziono wszystkie potrzebne dyski VDir
Rozwiązanie
Upewnij się, że wszystkie wymagane katalogi wirtualne są obecne, a wewnętrzne adresy URL są publikowane w tych katalogach wirtualnych.
Aby uzyskać więcej informacji na temat konfigurowania katalogów wirtualnych programu Exchange, zobacz Konfigurowanie przepływu poczty i dostępu klienta na serwerach programu Exchange Krok 4: Konfigurowanie zewnętrznych adresów URL.