Udostępnij za pośrednictwem


Błąd PrivilegeDenied występuje podczas korzystania z synchronizacji Server-Side

Ten artykuł zawiera rozwiązanie błędu PrivilegeDenied występującego podczas korzystania z synchronizacji Server-Side w usłudze Microsoft Dynamics 365.

Dotyczy: Microsoft Dynamics CRM
Oryginalny numer KB: 4015092

Symptomy

Podczas korzystania z synchronizacji Server-Side w Dynamics 365 po wybraniu pozycji Testuj & Włącz skrzynkę pocztową występuje następujący błąd:

"Nie można synchronizować terminów, kontaktów i zadań dla nazwy> skrzynki pocztowej, <ponieważ użytkownik skrzynki pocztowej nie ma wystarczających uprawnień w tej skrzynce pocztowej.
kod błędu serwera Email: Crm.80040220.PrivilegeDenied"

Przyczyna

Ten błąd zostanie wyświetlony, jeśli użytkownik skojarzony z rekordem skrzynki pocztowej nie ma wystarczających uprawnień do korzystania z synchronizacji Server-Side.

Rozwiązanie

Zmodyfikuj rolę zabezpieczeń użytkownika, aby uwzględnić brakujące uprawnienia. Po wybraniu sekcji Szczegóły powinna ona zawierać nazwę brakującego uprawnienia. W poniższym przykładzie użytkownik nie ma uprawnienia do odczytu dla jednostki profilu serwera Email.

T:331ActivityId: <Wyjątek identyfikatora GUID>>: Nieobsługiwany wyjątek: Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncException: Nie można zaktualizować stanu synchronizacji: Nieobsługiwany wyjątek: System.ServiceModel.FaultException'1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: Brak uprawnień użytkownika głównego (Id=<GUID>, type=8) prvReadEmailServerProfile (Id=<ID>)Detail: ID: <ID> -2147220960 główny użytkownik (Id=<GUID>, type=8) nie ma uprawnień prvReadEmailServerProfile (Id=edebe6f6-cf2e-45...

Aby uzyskać listę uprawnień, które mogą być wymagane do korzystania z usługi Server-Side Sync, zobacz sekcję Więcej informacji .

Więcej informacji

W poniższej tabeli wymieniono uprawnienia wymagane do korzystania z funkcji synchronizacji Server-Side oraz kartę w roli zabezpieczeń, na której można znaleźć uprawnienie. Użytkownik z rolą Administrator systemu może zlokalizować i zmodyfikować rolę zabezpieczeń, przechodząc do pozycji Ustawienia, Zabezpieczenia, Role zabezpieczeń. Aby wyświetlić role przypisane do określonego użytkownika, przejdź do pozycji Ustawienia, wybierz pozycję Zabezpieczenia, wybierz pozycję Użytkownicy, wybierz określony rekord Użytkownika, a następnie wybierz pozycję Zarządzaj rolami.

Nazwa uprawnień Jednostki Lokalizacja (karta) w roli zabezpieczeń
prvReadEmailServerProfile EmailServerProfile Zarządzanie firmą
prvWriteMailbox Skrzynki pocztowej Zarządzanie firmą
prvReadMailbox Skrzynki pocztowej Zarządzanie firmą
prvReadOrganization Organizacji Zarządzanie firmą
prvSyncToOutlook (exchangesyncidmapping) Outlook Zarządzanie firmą —> uprawnienia związane z prywatnością
prvReadActionCard ActionCard Rekordy podstawowe
prvDeleteActivity Działanie Rekordy podstawowe
prvAppendActivity Działanie Rekordy podstawowe
prvWriteActivity Działanie Rekordy podstawowe
prvCreateActivity Działanie Rekordy podstawowe
prvReadActivity Działanie Rekordy podstawowe
prvAppendToActivity Działanie Rekordy podstawowe
prvReadConnection Połączenie Rekordy podstawowe
prvAssignContact Kontakt Rekordy podstawowe
prvReadContact Kontakt Rekordy podstawowe
prvWriteContact Kontakt Rekordy podstawowe
prvCreateContact Kontakt Rekordy podstawowe
prvDeleteContact Kontakt Rekordy podstawowe
prvReadUserQuery Zapisany widok Rekordy podstawowe
prvReadQueue Kolejki Rekordy podstawowe
prvReadQuery Widok Dostosowywania
prvReadIncident Przypadku Usługa
prvSearchAvailability Zarządzanie usługami —> różne uprawnienia
prvOverrideCreatedOnCreatedBy Zarządzanie usługami —> różne uprawnienia