System ulega awarii podczas dodawania konta z uruchomioną pulą CRM Jako użytkownik programu Microsoft Dynamics CRM
Ten artykuł zawiera rozwiązanie problemu z awarią systemu występującego podczas dodawania konta, na którym jest uruchomiona pula CRMAppPool jako użytkownik programu Microsoft Dynamics CRM.
Dotyczy: Microsoft Dynamics CRM 2011
Oryginalny numer KB: 2500917
Symptomy
Po dodaniu konta, na którym działa pula CRMAppPool jako użytkownik programu Microsoft Dynamics CRM, system ulega awarii. Ponadto mogą wystąpić błędy podobne do następujących:
SecLib::RetrievePrivilegeForUser nie powiodło się — żadne role nie są przypisane do użytkownika. Zwrócona hr = -2147209463, użytkownik: [userid]
Przyczyna
Domyślnie po utworzeniu użytkownika programu Microsoft Dynamics CRM w usłudze Microsoft Dynamics CRM użytkownik nie ma ról zabezpieczeń. Ponieważ konto usługi Microsoft Dynamics CRM jest mapowane na nowo utworzonego użytkownika, konto usługi Microsoft Dynamics CRM nie może działać niczego. W związku z tym system ulega awarii.
Wynika to z ustawienia fabrycznego. Tworzenie konta, na którym uruchomiono pulę CRMAppPool w użytkowniku programu Microsoft Dynamics CRM, nie jest obsługiwane.
Rozwiązanie
Zachowaj konto usługi Microsoft Dynamics CRM jako dedykowane konto usługi.
Więcej informacji
Więcej informacji znajduje się w sekcji Services and CRMAppPool iis application pool identity permissions (Usługi i CRMAppPool tożsamości puli aplikacji usług IIS) przewodnika implementacji programu Microsoft Dynamics CRM 2011.
Aby pobrać przewodnik, zobacz Przewodnik implementacji programu Microsoft Dynamics CRM 2011.