Skrzynka pocztowa nie może synchronizować przychodzących wiadomości e-mail, ponieważ kanał połączenia poczty e-mail jest skonfigurowany do synchronizacji przy użyciu routera Email
Ten artykuł zawiera rozwiązanie błędu występującego podczas próby przetestowania i włączenia skrzynki pocztowej w Dynamics 365.
Dotyczy: Microsoft Dynamics CRM
Oryginalny numer KB: 4053588
Symptomy
Podczas próby przetestowania i włączenia skrzynki pocztowej w Dynamics 365 jest rejestrowany jeden z następujących alertów:
-
"Nazwa> skrzynki pocztowej <nie może synchronizować przychodzących wiadomości e-mail, ponieważ kanał połączenia poczty e-mail jest skonfigurowany do synchronizacji przy użyciu routera Email. Skontaktuj się z administratorem, aby zmienić domyślny kanał połączenia na Server-Side Synchronizacja.
kod błędu serwera Email: IncomingEmailConnectionChannelError" -
"Nazwa> skrzynki pocztowej <nie może synchronizować wychodzących wiadomości e-mail, ponieważ kanał połączenia poczty e-mail jest skonfigurowany do synchronizacji przy użyciu routera Email. Skontaktuj się z administratorem, aby zmienić domyślny kanał połączenia na Server-Side Synchronizacja.
kod błędu serwera Email: OutgoingEmailConnectionChannelError" -
"Nazwa> skrzynki pocztowej skrzynki pocztowej <nie może synchronizować terminów, kontaktów i zadań, ponieważ kanał połączenia poczty e-mail jest skonfigurowany do synchronizacji przy użyciu routera Email. Skontaktuj się z administratorem, aby zmienić domyślny kanał połączenia na Server-Side Synchronizacja.
kod błędu serwera Email: ExchangeSyncACTEmailConnectionChannelError"
Przyczyna
Te alerty są rejestrowane, jeśli opcja Process Email Using w obszarze Ustawienia systemu jest skonfigurowana do używania routera Dynamics 365 Email firmy Microsoft zamiast synchronizacji po stronie serwera.
Rozwiązanie
Aby użyć synchronizacji Server-Side zamiast routera Email, upewnij się, że opcja Proces Email Używanie w ustawieniach systemu jest skonfigurowana do korzystania z synchronizacji po stronie serwera:
- Uzyskaj dostęp do wystąpienia Dynamics 365 jako użytkownik z rolą administratora systemu.
- Przejdź do pozycji Ustawienia , a następnie wybierz pozycję Administracja.
- Wybierz kartę Email.
- Znajdź opcję Email Proces przy użyciu i upewnij się, że jest ona ustawiona na synchronizację po stronie serwera.
- Wybierz przycisk OK.
- Przejdź do pozycji Ustawienia, a następnie wybierz pozycję Email Konfiguracja.
- Wybierz pozycję Skrzynki pocztowe.
- Zmień wybrany widok z Moje aktywne skrzynki pocztowe na Aktywne skrzynki pocztowe.
- Wybierz skrzynki pocztowe, które chcesz włączyć dla synchronizacji Server-Side, a następnie wybierz przycisk Testuj & Włącz skrzynki pocztowe . Upewnij się, że zaznacz pole wyboru w wyświetlonym oknie dialogowym, a następnie wybierz przycisk OK.
- Zaczekaj na ukończenie procesu & testowego włączania. Jeśli wyniki testu nie są pomyślne, przejrzyj obszar Alerty w rekordzie skrzynki pocztowej.
Więcej informacji
Do wysyłania i odbierania wiadomości e-mail w Dynamics 365 można używać tylko routera Email lub synchronizacji Server-Side (zalecane). Obie opcje nie mogą być używane w tym samym wystąpieniu Dynamics 365. Opcja Proces Email Przy użyciu określa, które z tych opcji są włączone. Przycisk Testuj & Włącz skrzynkę pocztową jest używany z funkcją synchronizacji Server-Side. Jeśli używasz routera Email, nie musisz testować & Włączanie skrzynki pocztowej.