Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
W tym artykule opisano problem, w którym występuje błąd podczas wykonywania operacji dołączania w miejscu pracy.
Oryginalna wersja produktu: Windows 8.1 Enterprise, Windows Server 2012 R2 Datacenter, Windows Server 2012 R2 Standard, Microsoft Entra ID
Oryginalny numer KB: 3045386
Symptomy
Podczas próby wykonania operacji dołączania w miejscu pracy zostanie wyświetlony następujący komunikat o błędzie:
Upewnij się, że używasz bieżących informacji logowania i że w miejscu pracy jest używana ta funkcja. Ponadto połączenie z miejscem pracy może nie działać teraz. Poczekaj i spróbuj ponownie.
Ponadto administrator może zobaczyć następujące szczegóły zdarzenia w Podgląd zdarzeń:
Identyfikator zdarzenia: 103
Nazwa dziennika: Microsoft-Windows-Workplace Join/Admin
Źródło: Microsoft-Windows-Workplace Join
Poziom: Błąd
Opis: Odnajdywanie dołączania w miejscu pracy nie powiodło się. Serwer zwrócił stan http 404.
https://EnterpriseRegistration.domain.com:443/EnrollmentServer/contract?api-version=1.0
Przyczyna
Przyczyny występowania tego problemu mogą być następujące:
- Klient jest przekierowywany do wewnętrznego wystąpienia usługi rejestracji urządzeń (DRS), w którym punkt końcowy usługi DRS jest wyłączony lub zatrzymany.
- Brak rekordów DNS dla usługi EnterpriseRegistration lub jest on nieprawidłowo skonfigurowany.
- Sufiks domeny aktualnie zalogowanego użytkownika nie jest uwzględniany w certyfikacie SSL usługi DRS.
- Sieć lub zapora blokuje ruch lub przejściowe problemy z siecią powodują utratę pakietów.
Rozwiązanie
Weryfikowanie usługi DNS
Sprawdź konfigurację DNS przy użyciu NSlookup
narzędzia i sprawdź, czy odpowiedzi są poprawne.
W tym celu otwórz okno wiersza polecenia, a następnie uruchom następujące polecenie:
Nslookup enterpriseregistration.domain.com
- Jeśli używasz dołączania microsoft Entra
- Powinno to zwrócić wynik
EnterpriseRegistration.windows.net
CNAME jako docelowy.
- Powinno to zwrócić wynik
- Jeśli używasz dołączania do miejsca pracy systemu Windows Server
- Host wewnętrzny powinien zwrócić wewnętrzny węzeł usług AD FS.
- Host zewnętrzny powinien zwrócić zewnętrzny adres serwera proxy usług AD FS.
Sprawdź, czy rejestracja urządzenia jest włączona
Jeśli spróbujesz wykonać dołączanie w miejscu pracy do identyfikatora Entra firmy Microsoft, wykonaj następujące kroki:
- Zaloguj się do witryny Azure Portal lub uruchom konsolę Microsoft Entra ID z centrum administracyjnego usługi M365 jako administrator firmy.
- Znajdź katalog, w którym użytkownik próbuje wykonać operację sprzężenia.
- Przejdź do pozycji Konfiguruj.
- Przewiń w dół do sekcji Rejestracja urządzenia.
- Upewnij się, że ustawienie z etykietą ENABLE WORKPLACE JOIN (WŁĄCZ DOŁĄCZANIE W MIEJSCU PRACY) jest przełączone na Tak (Tak będzie niebieski).
Jeśli spróbujesz wykonać dołączanie w miejscu pracy do lokalnej domeny usługi Active Directory, wykonaj następujące kroki:
- Uruchom konsolę zarządzania usługAMI AD FS, a następnie wybierz pozycję Zaufania jednostki uzależnionej, aby określić, czy zaufanie usługi rejestracji urządzeń jest włączone w każdym węźle farmy usług AD FS.
- Jeśli usługa rejestracji urządzeń jest włączona, sprawdź konsolę usług, aby upewnić się, że usługa rejestracji urządzeń została uruchomiona.
Sprawdzanie powiązań SSLCertificate
Jeśli spróbujesz wykonać dołączanie w miejscu pracy do lokalnej domeny usługi Active Directory, wykonaj następujące kroki:
Otwórz okno wiersza polecenia jako administrator, wpisz następujące polecenia i naciśnij Enter po każdym poleceniu, aby wyświetlić powiązania na serwerze proxy usług AD FS lub serwerze usług ADFS:
Netsh
Http Show SSLCert
Ustal, czy powiązanie portu IP (nie powiązanie nazwy) jest obecne.
Jeśli powiązanie portu IP nie jest obecne, zapoznaj się z artykułem, aby określić, czy powiązanie nazwy przedsiębiorstwaRegistration jest obecne.
Więcej informacji
Aby uzyskać więcej informacji na temat rozwiązywania problemów, zobacz następujący artykuł w bazie wiedzy Microsoft Knowledge Base:
Rejestrowanie diagnostyczne na potrzeby rozwiązywania problemów z dołączaniem w miejscu pracy.
Skontaktuj się z nami, aby uzyskać pomoc
Jeśli masz pytania lub potrzebujesz pomocy, utwórz wniosek o pomoc techniczną lub zadaj pytanie w społeczności wsparcia dla platformy Azure. Możesz również przesłać opinię o produkcie do społeczności opinii na temat platformy Azure.