Nuta
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Oryginalny numer KB: 3099532
Objawy
Pomyślnie zainstalowano program Microsoft Exchange Server 2016 lub Exchange Server 2013. Proces instalacji mógł zakończyć się niepowodzeniem lub został przerwany na pewnym etapie, a następnie wznowiony i zakończony pomyślnie. Jednak podczas próby uzyskania dostępu do panelu sterowania programu Exchange (ECP) lub aplikacji Outlook Web App (OWA) zostanie wyświetlony następujący komunikat o błędzie:
wystąpił problem
Niestety, nie można teraz uzyskać tych informacji. Spróbuj ponownie później. Jeśli problem będzie nadal występować, skontaktuj się z pomocą techniczną.
Ponadto w dzienniku aplikacji może zostać zarejestrowane następujące zdarzenie:
Log Name: Application
Source: ASP.NET 4.0.30319.0
Event ID: 1309
Task Category: Web Event
Level: Warning
Keywords: Classic
User: N/A
Computer: Exch2.contoso.com
Description:
Event code: 3005
Event message: An unhandled exception has occurred.
Event ID: f23d9d455f3145068c57286262ac517f
Event sequence: 1
Event occurrence: 1
Event detail code: 0
Application information:
Application domain: /LM/W3SVC/2/ROOT/owa-5-130879214460462920
Trust level: Full
Application Virtual Path: /owa
Application Path: C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\owa\
Machine name: EXCH2
Process information:
Process ID: 4348
Process name: w3wp.exe
Account name: NT AUTHORITY\SYSTEM
Exception information:
Exception type: TargetInvocationException
Exception message: Exception has been thrown by the target of an invocation.
at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck,
Boolean&canBeCached, RuntimeMethodHandleInternal&ctor, Boolean&bNeedSecurityCheck)
* SharedWebConfig.config is missing from either of these locations:
C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy
C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess
Przyczyna
Ten problem występuje, jeśli w jednej z następujących lokalizacji brakuje SharedWebConfig.config:
- C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy
- C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess
Rezolucja
Aby rozwiązać ten problem, wykonaj poniższe czynności:
Na serwerze, na którym występuje problem, zidentyfikuj lokalizację, z którego brakuje pliku.
Wygeneruj brakujący plik:
Uruchom polecenie
cd %ExchangeInstallPath%\bin, aby zmienić bieżący katalog na folder bin, który znajduje się w ścieżce instalacji programu Exchange.Użyj narzędzia DependentAssemblyGenerator.exe, aby wygenerować plik:
- Jeśli brakuje pliku w folderze C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess, uruchom następujące polecenie:
DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\ClientAccess" -configFile "%ExchangeInstallPath%\ClientAccess\SharedWebConfig.config"- Jeśli brakuje pliku w folderze C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy, uruchom następujące polecenie:
DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\FrontEnd\HttpProxy" -configFile "%ExchangeInstallPath%\FrontEnd\HttpProxy\SharedWebConfig.config"
Uruchom usługę IISRESET lub uruchom ponownie serwer.
Więcej informacji
Plik SharedWebConfig.config jest generowany w fazie post-instalacyjnej. Jeśli Instalator zostanie wznowiony po przerwie, nie wykona kroków po instalacji dla ról, które zostały pomyślnie zainstalowane przed przerwą.