Nuta
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Oryginalny numer KB: 291615
Objawy
Klienci programu Outlook nie mogą łączyć się za pośrednictwem zapory lub serwera proxy, który wykonuje zacisk NAT między sieciami publicznymi i prywatnymi.
Przyczyna
Gdy pakiety IP zawierające informacje o zdalnym wywołaniu procedury (RPC) są edytowane podczas tłumaczenia, pakiety IP tracą informacje o łączności RPC. Powoduje to, że klient nie nawiązuje połączenia z serwerem. Ponadto program Outlook może mieć problemy z rozwiązaniem nazwy komputera z Microsoft Exchange Server znajdującego się za zaporą lub serwerem proxy.
Rozwiązanie
Obejście dla zapór lub serwerów proxy, które nie są oparte na systemie Microsoft Windows NT, polega na wykonaniu translacji jeden do jednego między dwiema sieciami. Jest to również nazywane otwarciem potoku lub tunelu między sieciami publicznymi i prywatnymi. Pobiera to wszystkie żądania dotyczące określonego adresu w sieci publicznej i przekazuje je bezpośrednio do sieci prywatnej. Aby uzyskać dodatkowe informacje na temat konfigurowania tłumaczenia jeden do jednego, zapoznaj się z dokumentacją producenta.
Translacja jeden do jednego lub potok nie działa w przypadku zapór i serwerów proxy opartych na systemie Windows NT, ponieważ klient programu Outlook próbuje połączyć się z portem mapera punktów końcowych (EPM), portem 135 w zaporze. Ten serwer nie zwraca prawidłowych informacji o łączności programu Exchange Server z klientem programu Outlook.
Innym możliwym obejściem jest użycie aplikacji Outlook Web App. Wymaga to tylko zezwolenia na ruch HTTP przez zaporę lub serwer proxy.
Więcej informacji
Aby uzyskać więcej informacji, zobacz następujące żądania dotyczące komentarzy (RFC):
- RFC 1631 — translator adresów sieciowych IP (NAT)
- RFC 1918 — alokacja adresów dla prywatnego Internetu
Te RFC można znaleźć tutaj.