Udostępnij za pomocą


Wystąpił błąd połączenia z serwerem zdalnym podczas migracji z lokalnego Exchange do usługi Exchange Online.

Oryginalny numer KB: 2903050

Objawy

Podczas próby przeprowadzenia migracji jednorazowej z lokalnej organizacji programu Exchange, która korzysta z programu Outlook Anywhere (znanego również jako RPC za pośrednictwem protokołu HTTP) do usługi Exchange Online, aparat migracji nie tworzy punktu końcowego migracji. Ponadto zostanie wyświetlony komunikat o błędzie podobny do następującego:

Microsoft.Exchange.Data.Storage.Management.MigrationTransientException: Nie można nawiązać połączenia z serwerem zdalnym. Sprawdź, czy ustawienia punktu końcowego migracji są poprawne, a certyfikat jest prawidłowy, a następnie spróbuj ponownie. Rozważ użycie analizatora łączności zdalnej programu Exchange , aby zdiagnozować problemy z łącznością. >--- Microsoft.Exchange.Rpc.ServerUnavailableException: Błąd 0x6ba (serwer RPC jest niedostępny) z cli_NspiBind

Przyczyna

Ten problem może wystąpić, jeśli co najmniej jeden z następujących warunków dotyczy programu Outlook Anywhere:

  • Ustawienia uwierzytelniania dla programu Outlook Anywhere są nieprawidłowe.
  • Ustawienia konfiguracji serwera proxy RPC dla programu Outlook Anywhere są nieprawidłowe.

Rezolucja

Aby rozwiązać ten problem, wykonaj poniższe czynności:

  1. Upewnij się, że lokalna metoda uwierzytelniania klienta programu Outlook Anywhere jest ustawiona na wartość Uwierzytelnianie podstawowe. Aby uzyskać więcej informacji, zobacz jeden z następujących artykułów w zależności od używanej wersji programu Exchange Server:

  2. Upewnij się, że serwer proxy RPC jest poprawnie skonfigurowany do używania określonych portów do komunikowania się z programem Outlook Anywhere i że lokalne kontrolery domeny nasłuchują na porcie 6004. Aby uzyskać więcej informacji, zobacz Jak działa program Outlook Anywhere (i nie działa)?

  3. Zweryfikuj łączność programu Outlook Anywhere z lokalnym serwerem Exchange. Aby to zrobić, wykonaj następujące kroki:

    1. Połącz się z usługą Exchange Online przy użyciu zdalnej obsługi programu PowerShell. Aby uzyskać więcej informacji o tym, jak to zrobić, zobacz Connect to Exchange Online PowerShell (Nawiązywanie połączenia z programem PowerShell w usłudze Exchange Online).

    2. Uruchom następujące polecenia programu PowerShell:

      $pscred=Get-Credential
      
      Test-MigrationServerAvailability -Credentials $pscred -ExchangeOutlookAnywhere -ExchangeServer <Internal FQDN of the Exchange server> -RPCProxyServer <FQDN of the proxyserver> -Authentication Basic -EmailAddress <AdminEmail>
      

      Jeśli weryfikacja zakończy się pomyślnie, możesz utworzyć punkt końcowy migracji na platformie Microsoft 365.

Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community.