Nuta
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Ten artykuł zawiera rozwiązanie problemu, który łącznik usługi Intune dla usługi Active Directory nie jest wyświetlany po zainstalowaniu go w usłudze Microsoft Intune.
Symptomy
Po zainstalowaniu łącznika usługi Intune dla usługi Active Directory nie jest on wyświetlany w usłudze Intune. Ponadto następujący wpis błędu jest rejestrowany w dzienniku zdarzeń usługi łącznika ODJ na serwerze, który hostuje łącznik:
"DiagnosticText": "Nie możemy ukończyć żądania, ponieważ wystąpił błąd po stronie serwera. Spróbuj ponownie. [Komunikat o wyjątku: \"DiagnosticException: 0x0FFFFFFF. Nie można ukończyć żądania, ponieważ wystąpił błąd po stronie serwera. Spróbuj ponownie.\"] [Komunikat wyjątku: \"Nie można pobrać wartości dla klucza: OdjServiceBaseUrl\"] [Komunikat wyjątku: \"Podany klucz nie był obecny w słowniku.\"]"
Uwaga 16.
Dzienniki zdarzeń usługi łącznika ODJ znajdują się w obszarze dzienników usługi Podgląd zdarzeń> Application i usług>Microsoft>Intune>ODJConnectorService. Wybierz pozycję Microsoft-Intune-ODJConnectorService/Admin lub Microsoft-Intune-ODJConnectorService/Operational.
Przyczyna
Ten problem występuje zwykle w przypadku korzystania z serwera proxy w środowisku. Dodatkowe ustawienia konfiguracji są wymagane na serwerze proxy, aby łącznik usługi Intune mógł komunikować się z usługą Intune.
Rozwiązanie
Aby rozwiązać ten problem, dodaj wymaganą konfigurację serwera proxy do następującego pliku:
%ProgramFiles%\Microsoft Intune\ODJConnector\ODJConnectorSvc\ODJConnectorSvc.exe.config
W tym celu wykonaj następujące kroki:
Otwórz plik config. W górnej części pliku można zobaczyć następujące wiersze:
<?xml version="1.0" encoding="utf-8" ?> <configuration>Dodaj następujące wiersze po
<configuration>pliku , a następnie zapisz plik.<system.net> <defaultProxy> <proxy usesystemdefault="false" proxyaddress="http://<proxy server address>:<port>" /> </defaultProxy> </system.net>Uruchom ponownie usługę Intune ODJConnector.