Nuta
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Problem
Gdy użytkownik federacyjny próbuje zalogować się do usługi w chmurze firmy Microsoft, takiej jak Microsoft 365, Microsoft Azure lub Microsoft Intune, użytkownik otrzymuje następujący komunikat o błędzie z usług Active Directory Federation Services (AD FS):
There was a problem accessing the site. Try to browse to the site again.
If the problem persists, contact the administrator of this site and provide the reference number to identify the problem.
Reference number: <GUID>
W przypadku wystąpienia tego błędu pasek adresu przeglądarki internetowej wskazuje lokalny punkt końcowy usług AD FS pod adresem podobnym do następującego:
"https://sts.domain.com/adfs/ls/?cbcxt=& vv=&username=username%40domain.com&mkt=&lc=1033&wa=wsignin1.0&wtrealm=urn:federation:MicrosoftOnline&wctx=MEST%3D0%26LoginOptions%3D2%26wa%3Dwsignin1.0%26rpsnv%3D2%26ct%3D1299115248%26rver%3D6.1.6206.0%26wp%3DMCMBI%26wreply%3Dhttps:%252F%252Fportal.office.com%252FDefault.aspx%26lc%3D1033%26id%3D271346%26bk%3D1299115248"
Przyczyna
Ten problem może wystąpić z jednego z następujących powodów:
- Konfiguracja logowania jednokrotnego (SSO) za pośrednictwem usług AD FS nie została ukończona.
- Certyfikat podpisywania tokenów usług AD FS wygasł.
- Roszczenia zasad dostępu klienta usług AD FS są niepoprawnie skonfigurowane.
- Brakuje zaufania strony polegającej z Microsoft Entra ID lub jest ono niepoprawnie skonfigurowane.
- Serwer proxy federacyjnego usług AD FS jest niepoprawnie skonfigurowany lub uwidoczniony niepoprawnie.
- Konto IUSR usług AD FS nie ma uprawnienia użytkownika "Podszywanie się pod klienta po uwierzytelnieniu".
Rozwiązanie
Aby rozwiązać ten problem, użyj metody odpowiedniej dla danej sytuacji.
Scenariusz 1. Certyfikat podpisywania tokenów usług AD FS wygasł
Sprawdzanie, czy certyfikat podpisywania tokenu wygasł
Aby sprawdzić, czy certyfikat podpisywania tokenu wygasł, wykonaj następujące kroki:
- Kliknij przycisk Start, kliknij pozycję Wszystkie programy, kliknij pozycję Narzędzia administracyjne, a następnie kliknij pozycję Zarządzanie usługami AD FS (2.0).
- W konsoli zarządzania usług AD FS kliknij pozycję Usługa, kliknij pozycję Certyfikaty, a następnie sprawdź daty obowiązywania i wygaśnięcia certyfikatu podpisywania tokenów usług AD FS.
Jeśli certyfikat wygasł, należy go odnowić w celu przywrócenia funkcji uwierzytelniania logowania jednokrotnego.
Odnów certyfikat podpisywania tokenu (jeśli wygasł)
Aby odnowić certyfikat podpisywania tokenu na podstawowym serwerze usług AD FS przy użyciu certyfikatu z podpisem własnym, wykonaj następujące kroki:
- W tej samej konsoli zarządzania usług AD FS kliknij pozycję Usługa, kliknij pozycję Certyfikaty, a następnie w obszarze **Certyfikaty **w okienku Akcje kliknij przycisk Dodaj certyfikat Token-Signing.
- Jeśli zostanie wyświetlone ostrzeżenie "Nie można zmodyfikować certyfikatów, gdy funkcja automatycznego przerzucania certyfikatów usług AD FS jest włączona", przejdź do kroku 3. W przeciwnym razie sprawdź daty obowiązywania i wygaśnięcia certyfikatu. Jeśli certyfikat zostanie pomyślnie odnowiony, nie musisz wykonywać kroków 3 i 4.
- Jeśli certyfikat nie został odnowiony, kliknij przycisk Start, wskaż polecenie Wszystkie programy, kliknij pozycję Akcesoria, kliknij folder programu Windows PowerShell , kliknij prawym przyciskiem myszy program Windows PowerShell, a następnie kliknij polecenie Uruchom jako administrator.
- W wierszu polecenia programu Windows PowerShell wprowadź następujące polecenia. Naciśnij Enter po wprowadzeniu każdego polecenia:
- Add-PSSnapin Microsoft.Adfs.Powershell
- Update-ADFSCertificate -CertificateType: Token-Signing
Aby odnowić certyfikat podpisywania tokenu na podstawowym serwerze usług AD FS przy użyciu certyfikatu z podpisem urzędu certyfikacji, wykonaj następujące kroki:
Utwórz plik WebServerTemplate.inf. Aby to zrobić, wykonaj następujące kroki:
Uruchom Notatnik i otwórz nowy, pusty dokument.
Wklej następujące elementy do pliku:
[Version] Signature=$Windows NT$[NewRequest] ;EncipherOnly=False Exportable=True KeyLength=2048 KeySpec=1 KeyUsage=0xa0MachineKeySet=True ProviderName="Microsoft RSA SChannel Cryptographic Provider" ProviderType=12 RequestType=CMC subject="CN=adfs.contoso.com"[EnhancedKeyUsageExtension] OID=1.3.6.1.5.5.7.3.1 [RequestAttributes]W pliku zmień subject="CN=adfs.contoso.com" na następujące:
subject="CN=your-federation-service-name"
W menu File (Plik) kliknij pozycję Save As (Zapisz jako).
W oknie dialogowym** Zapisz jako kliknij pozycję Wszystkie pliki (.)** w polu Zapisz jako typ .
Wpisz WebServerTemplate.inf w polu Nazwa pliku , a następnie kliknij przycisk Zapisz.
Skopiuj plik WebServerTemplate.inf do jednego z serwerów federacyjnych usług AD FS.
Na serwerze usług AD FS otwórz okno wiersza polecenia administracyjnego.
Użyj polecenia cd(change directory), aby zmienić katalog na katalog, w którym skopiowano plik inf.
Wpisz następujące polecenie, a następnie naciśnij klawisz Enter:
CertReq.exe -New WebServerTemplate.inf AdfsSSL.req
Wyślij plik wyjściowy AdfsSSL.req do urzędu certyfikacji w celu podpisania.
Urząd certyfikacji zwróci podpisaną część klucza publicznego w formacie p7b lub .cer. Skopiuj ten plik na serwer usług AD FS, na którym wygenerowano żądanie.
Na serwerze usług AD FS otwórz okno wiersza polecenia administracyjnego.
Użyj polecenia cd(change directory), aby zmienić katalog na katalog, w którym skopiowano plik p7b lub .cer.
Wpisz następujące polecenie, a następnie naciśnij klawisz Enter:
CertReq.exe -Accept "file-from-your-CA-p7b-or-cer"
Zakończenie przywracania funkcji SSO
Niezależnie od tego, czy używany jest certyfikat podpisany własnoręcznie, czy przez urząd certyfikacji, należy ukończyć proces przywracania funkcjonalności uwierzytelniania jednokrotnego logowania. Aby to zrobić, wykonaj następujące kroki:
- Dodaj dostęp do odczytu do klucza prywatnego dla konta usługi AD FS na podstawowym serwerze usług AD FS. Aby to zrobić, wykonaj następujące kroki:
- Kliknij przycisk Start, kliknij przycisk Uruchom, wpisz mmc.exe, a następnie naciśnij Enter.
- Kliknij polecenie Dodaj/Usuń przystawkę na menu Plik.
- Kliknij dwukrotnie Certyfikaty, wybierz Konto komputera, a następnie kliknij przycisk Dalej.
- Wybierz pozycję Komputer lokalny, kliknij przycisk Zakończ, a następnie kliknij przycisk OK.
- Rozwiń węzeł Certyfikaty (komputer lokalny), rozwiń węzeł Osobiste, a następnie kliknij pozycję Certyfikaty.
- Kliknij prawym przyciskiem myszy nowy certyfikat podpisywania tokenu, wskaż pozycję Wszystkie zadania, a następnie kliknij pozycję Zarządzaj kluczami prywatnymi.
- Dodaj dostęp do odczytu do konta usługi AD FS, a następnie kliknij przycisk OK.
- Zamknij przystawkę Certyfikaty.
- Zaktualizuj odcisk palca nowego certyfikatu i datę zaufania jednostki uzależnionej za pomocą identyfikatora Entra firmy Microsoft. Aby to zrobić, zobacz sekcję "Jak zaktualizować konfigurację domeny federacyjnej platformy Microsoft 365" w temacie Jak zaktualizować lub naprawić ustawienia domeny federacyjnej na platformie Microsoft 365, na platformie Azure lub w usłudze Intune.
- Odtwórz konfigurację zaufania serwera proxy AD FS. Aby to zrobić, wykonaj następujące kroki:
- Uruchom ponownie usługę AD FS systemu Windows na podstawowym serwerze usług AD FS.
- Poczekaj 10 minut na replikowanie certyfikatu do wszystkich członków farmy serwerów federacyjnych, a następnie uruchom ponownie usługę AD FS systemu Windows na pozostałych serwerach usług AD FS.
- Uruchom ponownie Kreatora konfiguracji serwera proxy na każdym serwerze proxy AD FS. Aby uzyskać więcej informacji, zobacz Konfigurowanie komputera dla roli serwera proxy usługi federacyjnej.
Scenariusz 2. Ostatnio zaktualizowano zasady dostępu klienta za pomocą oświadczeń, a teraz logowanie nie działa
Sprawdź, czy zasady dostępu klienta zostały zastosowane poprawnie. Aby uzyskać więcej informacji, zobacz Ograniczanie dostępu do usług Platformy Microsoft 365 na podstawie lokalizacji klienta.
Scenariusz 3. Punkt końcowy metadanych federacyjnych lub zaufanie jednostki może być wyłączone
Włącz punkt końcowy metadanych federacyjnych i zaufanie partnera zależnego z Microsoft Entra ID na głównym serwerze AD FS. Aby to zrobić, wykonaj następujące kroki:
- Otwórz konsolę zarządzania usług AD FS 2.0.
- Upewnij się, że punkt końcowy metadanych federacji jest włączony. Aby to zrobić, wykonaj następujące kroki:
- W okienku nawigacji po lewej stronie przejdź do AD FS (2.0), serwis, punkty końcowe.
- W środkowym okienku kliknij prawym przyciskiem myszy wpis /Federation Metadata/2007-06/FederationMetadata.xml , a następnie kliknij, aby wybrać pozycję Włącz i Włącz na serwerze proxy.
- Upewnij się, że zaufanie jednostki zależnej do Microsoft Entra ID jest włączone. Aby to zrobić, wykonaj następujące kroki:
- W okienku nawigacji po lewej stronie przejdź do AD FS (2.0), a następnie Relacje Zaufania, a następnie Zaufania Jednostki Uzależnionej.
- Jeśli platforma tożsamości Microsoft Office 365 jest obecna, kliknij prawym przyciskiem myszy ten wpis, a następnie kliknij Włącz.
- Napraw relację zaufania jednostki uzależnionej z identyfikatorem Entra firmy Microsoft, wyświetlając sekcję "Aktualizuj właściwości zaufania" w temacie Weryfikowanie logowania jednokrotnego i zarządzanie nim za pomocą usług AD FS.
Scenariusz 4. Brak zaufania jednostki uzależnionej lub jego uszkodzenie
Usuń i ponownie dodaj zaufanie jednostki uzależnionej. Aby to zrobić, wykonaj następujące kroki:
- Zaloguj się do podstawowego serwera usług AD FS.
- Kliknij przycisk Start, wskaż pozycję Wszystkie programy, kliknij pozycję Narzędzia administracyjne, a następnie kliknij pozycję Zarządzanie usługami AD FS (2.0).
- W konsoli zarządzania rozwiń węzeł AD FS (2.0), rozwiń węzeł Relacje zaufania, a następnie rozwiń węzeł Relacje zaufania stron trzecich.
- Jeśli platforma tożsamości Microsoft Office 365 jest obecna, kliknij prawym przyciskiem myszy ten wpis, a następnie kliknij Usuń.
- Ponownie dodaj zaufanie partnera zaufanego, przechodząc do sekcji "Aktualizuj właściwości zaufania" w temacie Weryfikowanie logowania jednokrotnego i zarządzanie nim za pomocą usług AD FS.
Scenariusz 5. Konto usługi AD FS nie ma uprawnienia użytkownika "Personifikuj klienta po uwierzytelnieniu"
Aby udzielić użytkownikowi uprawnienia "Personifikuj klienta po uwierzytelnieniu" do konta usługi IUSR usług AD FS, zobacz Identyfikator zdarzenia 128 — Konfiguracja aplikacji opartej na tokenach systemu Windows NT.
Źródła
Aby uzyskać więcej informacji na temat rozwiązywania problemów z logowaniem dla użytkowników federacyjnych, zobacz następujące artykuły z bazy wiedzy Microsoft Knowledge Base:
- 2530569 Rozwiązywanie problemów z konfiguracją logowania jednokrotnego na platformie Microsoft 365, Intune lub Azure
- 2712961 Jak rozwiązywać problemy z połączeniem punktu końcowego usług AD FS podczas logowania użytkowników do platformy Microsoft 365, usługi Intune lub platformy Azure
Nadal potrzebujesz pomocy? Przejdź do witryny Microsoft Community lub witryny forów Microsoft Entra .