Udostępnij za pośrednictwem


Błąd "Wystąpił ogólny błąd dostępu do skrzynki pocztowej podczas odbierania wiadomości e-mail" podczas testowania i włączania skrzynki pocztowej

Ten artykuł zawiera rozwiązanie błędu występującego podczas testowania i włączania skrzynki pocztowej w usłudze Microsoft Dynamics 365.

Dotyczy: Microsoft Dynamics 365
Oryginalny numer KB: 4092736

Symptomy

Podczas próby przetestowania i włączenia skrzynki pocztowej w usłudze Dynamics 365 zostanie wyświetlony następujący komunikat o błędzie:

Wystąpił ogólny błąd dostępu do skrzynki pocztowej podczas odbierania wiadomości e-mail. Skrzynka <Nazwa skrzynki pocztowej> nie została zsynchronizowana. Otrzymano powiadomienie o właścicielu skojarzonego profilu> profilu <serwera poczty e-mail.
Kod błędu serwera poczty e-mail: gniazdo zwróciło wyjątek Limit czasu.

Jeśli wybierzesz sekcję Szczegóły , możesz również zobaczyć więcej szczegółów przypominających następujący tekst:

Błąd: System.Net.Sockets.SocketException (0x80004005): Próba połączenia nie powiodła się, ponieważ połączona strona nie odpowiedziała prawidłowo po upływie określonego czasu lub nawiązała połączenie nie powiodło się, ponieważ połączony host nie odpowiedział <na port adresu><IP>
at System.Net.Sockets.TcpClient.Connect(Nazwa hosta ciągu, port Int32)
w: Microsoft.Crm.Asynchronous.EmailConnector.Pop3Client.Connect()

Przyczyna

Ten błąd może wystąpić, jeśli wartości portów w sekcji Zaawansowane profilu serwera poczty e-mail nie są poprawne.

Rozwiązanie

  1. Zaloguj się do aplikacji internetowej usługi Dynamics 365 jako użytkownik z rolą "Administrator systemu".

  2. Przejdź do pozycji Ustawienia>Konfiguracja poczty e-mail, a następnie wybierz pozycję Profile serwera poczty e-mail.

  3. Otwórz profil serwera poczty e-mail używany przez skrzynkę pocztową, która otrzymała błąd.

    Uwaga 16.

    Możesz również wybrać nazwę profilu serwera poczty e-mail w komunikacie o błędzie. Zostanie wyświetlony jako hiperlink, który otworzy prawidłowy rekord profilu serwera poczty e-mail.

  4. Wybierz opcję Zaawansowane.

  5. Sprawdź, czy wartości Port przychodzący i Port wychodzący są poprawne zgodnie z dokumentacją dostawcy poczty e-mail, a następnie wybierz pozycję Zapisz.

    Uwaga 16.

    Na przykład w przypadku gmaila przychodzący port POP3 to 995, a wychodzący port SMTP to 587.

  6. Wybierz pozycję Skrzynki pocztowe, a następnie wybierz skrzynkę pocztową, która otrzymała błąd.

  7. Wybierz przycisk Testuj i włącz skrzynki pocztowe .

  8. Po zakończeniu testu sprawdź, czy wyniki są wyświetlane jako Powodzenie. W przeciwnym razie przejrzyj sekcję Alerty rekordu skrzynki pocztowej dla wszystkich alertów.

Zastrzeżenie dotyczące innych firm

Produkty innych firm omówione w tym artykule są wytwarzane przez producentów niezależnych od firmy Microsoft. Firma Microsoft nie udziela żadnych gwarancji, dorozumianych ani żadnego innego rodzaju, w odniesieniu do wydajności lub niezawodności tych produktów.