System file checker (SFC) niepoprawnie flagi Windows Defender plików modułu programu PowerShell jako uszkodzony
W tym artykule opisano problem polegający na tym, że systemowe sprawdzanie plików niepoprawnie oznacza Windows Defender plików modułu programu PowerShell jako uszkodzone.
Dotyczy: Klient systemu Windows
Oryginalny numer KB: 4513240
Symptomy
Narzędzie systemowego sprawdzania plików (SFC) flaguje pliki znajdujące się w folderze %windir%\System32\WindowsPowerShell\v1.0\Modules\Defender jako uszkodzone lub uszkodzone. W przypadku wystąpienia tego problemu zostaną wyświetlone wpisy błędów podobne do następujących:
Skróty dla elementu członkowskiego pliku nie są zgodne.
Przyczyna
Jest to znany problem w wersji Windows 10, wersji 1607 i nowszych oraz Windows Defender wersji 4.18.1906.3 i nowszych do wersji 4.8.1908.
Pliki modułu Windows Defender programu PowerShell znajdujące się w folderze %windir%\System32\WindowsPowerShell\v1.0\Modules\Defender są dostarczane jako część obrazu systemu Windows. Te pliki są podpisane przez wykaz. Jednak składnik zarządzania Windows Defender ma nowy kanał aktualizacji poza pasmem (OOB). Ten kanał zastępuje oryginalne pliki zaktualizowanymi wersjami podpisanymi przy użyciu certyfikatu firmy Microsoft, któremu ufa system operacyjny Windows. Z powodu tej zmiany SFC sygnalizuje zaktualizowane pliki jako "Skróty dla elementu członkowskiego pliku nie są zgodne".
Przyszłe wersje systemu Windows będą używać zaktualizowanych plików na obrazie systemu Windows. Po zaimplementowaniu tej zmiany SFC nie będzie już flagować plików.
Rozwiązanie
Ten problem został rozwiązany w wersji 4.8.1908 aktualizacji Windows Defender. Po zastosowaniu tej aktualizacji pliki programu PowerShell, które są częścią obrazu systemu Windows, nie są zmieniane, a narzędzie SFC nie oznacza już flag tych plików. Komputery połączone z Internetem, które subskrybują kanał Windows Update, automatycznie pobierają i instalują tę aktualizację.
Aby naprawić pliki obrazów systemu Windows na komputerach, których dotyczy ten problem, użyj narzędzia DISM. W tym celu otwórz okno wiersza polecenia na komputerze, którego dotyczy problem, i uruchom następujące polecenia:
dism /online /cleanup-image /restorehealth
sfc /scannow
Jeśli te polecenia nie powiodą się i wygenerują komunikat o błędzie podobny do "Nie znaleziono pliku", upewnij się, że plik Install.wim jest dostępny, a następnie uruchom następujące polecenia:
DISM /Online /Cleanup-Image /RestoreHealth /Source:WIM:c:\install.wim:1 /LimitAccess
sfc /scannow
Aby uzyskać więcej informacji na temat poleceń naprawy, zobacz Naprawianie obrazu systemu Windows.
Zbieranie danych
Jeśli potrzebujesz pomocy ze strony pomocy technicznej firmy Microsoft, zalecamy zebranie informacji, wykonując kroki wymienione w artykule Zbieranie informacji przy użyciu zestawu narzędzi TSS w przypadku problemów związanych z wdrożeniem.