Observação
O acesso a essa página exige autorização. Você pode tentar entrar ou alterar diretórios.
O acesso a essa página exige autorização. Você pode tentar alterar os diretórios.
Aplica-se a: implantações hiperconvergadas do Azure Local
Este artigo descreve como reparar um nó em sua instância local do Azure. Neste artigo, cada servidor é conhecido como um nó.
Sobre nós de reparo
O Azure Local é um sistema hiperconvergente que permite reparar nós de sistemas existentes. Talvez seja necessário reparar um nó em um sistema se houver uma falha de hardware.
Antes de reparar um nó, verifique com seu provedor de soluções, quais componentes no nó são unidades de substituição de campo (FRUs) que você mesmo pode substituir e quais componentes exigiriam um técnico para substituir.
As partes que dão suporte à troca frequente normalmente não exigem que você visualize novamente o nó diferentemente dos componentes que não podem ser permutáveis, como a placa-mãe. Consulte o fabricante do seu hardware para determinar quais substituições de componentes exigiriam que você refizesse a imagem do nó. Para obter mais informações, consulte Substituição de componentes.
Reparar fluxo de trabalho do nó
O diagrama de fluxo a seguir mostra o processo geral para reparar um nó.
*O nó pode não estar em um estado em que o desligamento seja possível ou necessário*
Para reparar um nó existente, siga estas etapas de alto nível:
Se possível, desligue o nó que você deseja reparar. Dependendo do estado do nó, um desligamento pode não ser possível ou necessário.
Recrie a imagem do nó que precisa ser reparado.
Execute a operação de nó de reparo. O sistema operacional, os drivers e o firmware do Azure Stack HCI são atualizados como parte da operação de reparo.
O armazenamento é rebalanceado automaticamente no nó reimaginado. O rebalanceamento de armazenamento é uma tarefa de baixa prioridade que pode ser executada por vários dias, dependendo do número de nós e do armazenamento usado.
Cenários com suporte
Reparar um nó recria a imagem de um nó e o traz de volta ao sistema com o nome e a configuração anteriores.
Reparar um único nó resulta em uma reimplantação com a opção de persistir os volumes de dados. Somente o volume do sistema é excluído e provisionado novamente durante a implantação.
Importante
Verifique se você sempre tem backups para suas cargas de trabalho e não depende apenas da resiliência do sistema. Essa precaução é especialmente crítica em cenários de nó único.
Configurações de resiliência
Nesta versão, para uma operação de nó de reparo, tarefas específicas não são executadas nos volumes de carga de trabalho criados após a implantação. Para uma operação de nó de reparo, somente os volumes de infraestrutura necessários e os volumes de carga de trabalho são restaurados e exibidos como CSVs (volumes compartilhados de cluster).
Os outros volumes de carga de trabalho que você criou após a implantação ainda são retidos e você pode descobrir esses volumes executando o Get-VirtualDisk cmdlet. Você deve desbloquear manualmente o volume (se o volume tiver o BitLocker habilitado) e criar um CSV (se necessário).
Requisitos de hardware
Ao reparar um nó, o sistema valida o hardware do novo nó de entrada e garante que o nó atenda aos requisitos de hardware antes de ser adicionado ao sistema.
| Componente | Verificação de conformidade |
|---|---|
| CPU | Valide se o novo nó tem o mesmo número de ou mais núcleos de CPU. Se os núcleos da CPU no nó de entrada não atenderem a esse requisito, um aviso será apresentado. No entanto, a operação é permitida. |
| Memória | Valide se o novo nó tem a mesma quantidade ou mais memória instalada. Se a memória no nó de entrada não atender a esse requisito, um aviso será apresentado. No entanto, a operação é permitida. |
| Unidades | Valide se o novo nó tem o mesmo número de unidades de dados disponíveis para espaços de armazenamento diretos. Se o número de unidades no nó de entrada não atender a esse requisito, um erro será relatado e a operação será bloqueada. |
Substituição de nó
Você pode substituir o nó inteiro:
- Com um novo nó que tem um número de série diferente em comparação com o nó antigo.
- Com o nó atual depois de reimaginá-lo.
Há suporte para os seguintes cenários durante a substituição do nó:
| Nó | Disco | Suportado |
|---|---|---|
| Novo nó | Novos discos | Sim |
| Novo nó | Discos atuais | Sim |
| Nó atual (reimaginado) | Novos discos | Sim |
| Nó atual (reimaginado) | Discos atuais | Sim |
| Nó atual (reimaginado) | Discos de dados atuais reformatados | Não |
Importante
Se você substituir um componente durante o reparo do nó, não precisará substituir ou redefinir unidades de dados. Se você substituir um disco ou redefini-lo, o disco não será reconhecido quando o nó se juntar ao sistema.
Substituição de componentes
Em sua instância local do Azure, os componentes que não podem ser trocados incluem os seguintes itens:
- Placa-mãe/BMC (controlador BMC de gerenciamento da placa base)/placa de vídeo
- Controlador de disco/adaptador de barramento de host (HBA)/backplace
- Adaptador de rede
- Unidade de processamento gráfico
- Unidades de dados (unidades que não dão suporte à troca frequente, por exemplo, cartões de suplemento PCI-e)
As etapas reais de substituição para componentes não trocáveis a quente variam de acordo com o fornecedor de hardware OEM (fabricante de equipamento original). Consulte a documentação do fornecedor do OEM se um reparo de nó for necessário para componentes não frequentes.
Pré-requisitos
Antes de reparar um nó, você deve garantir que:
-
AzureStackLCMUserestá ativo no Active Directory. Para obter mais informações, consulte Preparar o Active Directory. - Conectado como
AzureStackLCMUserou outro usuário com permissões equivalentes. - As credenciais para o
AzureStackLCMUsernão mudaram.
Se necessário, leve o nó que você identificou para reparar offline. Siga as etapas em aqui:
Reparar um nó
Esta seção descreve como reparar um nó usando PowerShell, monitorar o status da operação Repair-Server e solucionar problemas caso ocorram.
Certifique-se de ter revisado os pré-requisitos.
Siga estas etapas no node que você está tentando reparar.
Entre no portal do Azure com permissões da função Administrador do Azure Stack HCI.
Vá para o grupo de recursos usado para implantar a instância Local do Azure. No grupo de recursos, identifique o recurso do computador com Azure Arc referente ao nó defeituoso que você deseja reparar.
No recurso de máquina do Azure Arc, acesse Configurações > Bloqueios. No painel direito, você verá um bloqueio de recurso.
Selecione o bloqueio e, depois, selecione o ícone de lixeira para excluir o bloqueio.
Na página Visão Geral do recurso de máquina do Azure Arc, no painel direito, selecione Excluir. Essa ação deve excluir o nó do computador com falha.
Instale o sistema operacional e os drivers necessários no nó que você deseja reparar. Siga as etapas em Instalar o sistema operacional Azure Stack HCI, versão 23H2.
Observação
- Para versões 2503 e posteriores, você deve usar a imagem do sistema operacional da mesma solução que a executada no cluster existente.
- Use o Get solution version para identificar a versão da solução que você está executando no cluster.
- Use a tabela de imagem do sistema operacional para identificar e baixar a versão apropriada da imagem do sistema operacional. Não use o portal Azure, pois ele não lista todas as versões de imagem do sistema operacional disponíveis e pode não incluir a versão correspondente necessária.
- Verifique se o nome do adaptador de rede de gerenciamento corresponde ao nome usado nos outros nós (geralmente Gerenciamento). Por exemplo,
Rename-NetAdapter -Name "<current-adapter-name>" -NewName "Management".
Registre o nó com Arc. Siga as etapas em Registrar com o Arc e configure as permissões.
Observação
Você deve usar os mesmos parâmetros que os nós existentes para se registrar no Arc. Por exemplo: nome do Grupo de Recursos, Região, Assinatura e Locatário.
Atribua as seguintes permissões ao nó reparado:
- Função de gerenciamento de dispositivo do Azure Stack HCI
- Usuário de Segredos do Key Vault Para obter mais informações, consulte Atribuir permissões ao nó.
Siga estas etapas em outro nó que seja membro da mesma instância local do Azure.
Entre no nó que já é membro do sistema, com as credenciais de usuário de domínio que você forneceu durante a implantação do sistema. Execute o seguinte comando para reparar o nó de entrada:
$Cred = Get-Credential Repair-Server -Name "<Name of the new node>" -LocalAdminCredential $CredObservação
O nome do nó deve ser o nome NetBIOS. O parâmetro
LocalAdminCredentialé, por padrão, a conta de Administrador interna criada pela instalação do sistema operacional Windows.Anote o ID da operação conforme saída pelo comando
Repair-Server. Você usa essa ID de operação posteriormente para monitorar o progresso daRepair-Serveroperação.
Monitore o progresso da operação
Para monitorar o progresso da operação adicionar nó, siga estas etapas:
Execute o cmdlet a seguir e forneça a ID da operação da etapa anterior.
$ID = "<Operation ID>" Start-MonitoringActionplanInstanceToComplete -actionPlanInstanceID $IDApós a conclusão da operação, o trabalho de rebalanceamento de armazenamento em segundo plano continuará a ser executado. Aguarde a conclusão do trabalho de rebalanceamento de armazenamento. Para verificar o progresso desse trabalho de rebalanceamento de armazenamento, use o seguinte cmdlet:
Get-VirtualDisk|Get-StorageJobSe o trabalho de rebalanceamento de armazenamento for concluído, o cmdlet não retornará uma saída.
Cenários de recuperação
Os seguintes cenários de recuperação e as etapas de mitigação recomendadas são tabulados para reparar um nó:
| Descrição do cenário | Mitigação | Com suporte? |
|---|---|---|
| Falha na operação de reparo do nó. | Para concluir a operação, investigue a falha. Execute novamente a operação com falha usando Repair-Server -Rerun. |
Sim |
| A operação de reparo do nó teve êxito parcialmente, mas teve que começar com uma nova instalação do sistema de operações. | Nesse cenário, o orquestrador (também conhecido como "Lifecycle Manager") já atualizou seu repositório de conhecimento com o novo nó. Use o cenário de nó de reparo. | Sim |
Solucionar problemas
A partir da versão 2508, a validação é executada depois que você executa o Repair-Server comando. Se um teste falhar, o validador retornará informações para ajudá-lo a resolver a falha.
Aqui está um exemplo de uma mensagem de falha de validação:
Se você tiver falhas ou erros ao reparar um nó, poderá capturar a saída das falhas em um arquivo de log.
Entre com as credenciais de usuário do domínio que você forneceu durante a implantação do sistema. Capture o problema nos arquivos de log.
Get-ActionPlanInstance -ActionPlanInstanceID $ID |out-file log.txtPara executar novamente a operação com falha, use o seguinte cmdlet:
Repair-Server -Rerun
Se você encontrar um problema durante a operação de nó de reparo e precisar de ajuda do Suporte da Microsoft, poderá seguir as etapas em Coletar logs de diagnóstico do Azure Local (versão prévia) para coletar e enviar logs de diagnóstico para a Microsoft.
Talvez seja necessário fornecer logs de diagnóstico do nó em reparo. Verifique se você executou o cmdlet Send-DiagnosticData nesse nó.
Próximas etapas
Saiba mais sobre como Adicionar um nó.