Cenário: Tempos limite com o comando 'hbase hbck' no Azure HDInsight

Este artigo descreve as etapas de solução de problemas e possíveis soluções para problemas durante a interação com clusters do Azure HDInsight.

Problema

Ocorrência de tempos limite com o comando hbase hbck ao corrigir atribuições de região.

Causa

Uma possível causa de problemas do tempo limite, quando você usa o comando hbck, é que várias regiões se encontram no estado "em transição" por um longo tempo. Você pode ver essas regiões como offline na interface do usuário do HBase Master. Devido ao grande número de regiões que estão tentando a transição, o HBase Master pode atingir o tempo limite e não conseguir recolocar essas regiões online.

Resolução

  1. Entre no cluster do HBase no HDInsight usando SSH.

  2. Execute o comando hbase zkcli para se conectar ao shell do Apache ZooKeeper.

  3. Execute o comando rmr /hbase/regions-in-transition ou rmr /hbase-unsecure/regions-in-transition.

  4. Saia do shell hbase zkcli usando o comando exit.

  5. Na interface do usuário do Apache Ambar, reinicie o serviço Active HBase Master.

  6. Execute o comando hbase hbck -fixAssignments.

  7. Monitore a "região em transição" da interface do usuário do HBase Master nessa seção para garantir que nenhuma região fique travada.

Próximas etapas

Se você não encontrou seu problema ou não conseguiu resolver seu problema, visite um dos seguintes canais para obter mais suporte:

  • Obtenha respostas de especialistas do Azure por meio do Suporte da Comunidade do Azure.

  • Conecte-se com @AzureSupport – a conta oficial do Microsoft Azure para aprimorar a experiência do cliente. Como se conectar à comunidade do Azure para os recursos certos: respostas, suporte e especialistas.

  • Se precisar de mais ajuda, poderá enviar uma solicitação de suporte do portal do Azure. Selecione Suporte na barra de menus ou abra o hub Ajuda + suporte. Para obter informações mais detalhadas, consulte Como criar uma solicitação de Suporte do Azure. O acesso ao Gerenciamento de assinaturas e ao suporte de cobrança está incluído na sua assinatura do Microsoft Azure, e o suporte técnico é fornecido por meio de um dos Planos de suporte do Azure.