Salas do Teams dispositivos não podem buscar calendário de Exchange Online

Sintomas

Depois de entrar em um Salas do Microsoft Teams, a seguinte mensagem de erro será exibida:

Não é possível buscar calendário

Captura de tela do erro Não é possível buscar calendário.

E o seguinte erro é registrado nos logs de entrada no Azure Active Directory:

“requestId": "<request ID>",
"userDisplayName": "Teamsroom@contoso.com
"userPrincipalName": " Teamsroom@contoso.com ",
"userId": "<user ID>",
"appId": "<app ID>",
"appDisplayName": "Office 365 Exchange Online",
"ipAddress": "<IP address>",
"clientAppUsed": "AutoDiscover",
"userAgent": "MicrosoftTeamsRoom/<version>",
"correlationId": <correlation ID>",
"conditionalAccessStatus": "failure",
status": {
    "errorCode": 53003,
    "failureReason": "Access has been blocked by Conditional Access policies. The access policy does not allow token issuance.",
    "additionalDetails": "If this is unexpected, see the conditional access policy that applied to this request in the Azure Portal."
}

Motivo

Esse problema ocorrerá se a autenticação moderna não estiver habilitada para Salas do Teams e sua organização usar uma política de Acesso Condicional para bloquear a autenticação básica.

Para descobrir qual política de Acesso Condicional é aplicada, examine os Azure AD de entrada.

Resolução

Para corrigir o problema, habilite a configuração do lado do cliente para autenticação moderna Salas do Teams:

  1. No Salas do Teams, selecione o botão Mais (...).
  2. Selecione Configurações e insira o nome de usuário e a senha do administrador do dispositivo.
  3. Na guia Conta , ative a opção Autenticação Moderna e, em seguida, selecione Salvar e sair.