Salvar separadamente os eventos do Perfil de Estatísticas do Showplan XML (SQL Server Profiler)

Aplica-se a:SQL Server

Este tópico descreve como salvar eventos Perfil de Estatísticas XML do Showplan capturados em rastreamentos em arquivos .SQLPlan separados usando o SQL Server Profiler. Você pode abrir os arquivos de evento Showplan XML Statistics Profile no SQL Server Management Studio para que possa visualizar o plano gráfico de execução de cada evento.

Salvar separadamente os eventos Statistics Profile do Showplan XML

  1. No menu Arquivo, selecione Novo Rastreamento e conecte-se a uma instância do SQL Server.

    É exibida a caixa de diálogo Propriedades do Rastreamento .

    Observação

    Se você selecionar Iniciar rastreamento imediatamente após estabelecer a conexão, a caixa de diálogo Propriedades do Rastreamento não será exibida e, em vez disso, o rastreamento será iniciado. Para desligar essa configuração, no menu Ferramentas, selecione Opções e desmarque a caixa de seleção Iniciar rastreamento imediatamente após estabelecer a conexão.

  2. Na caixa de diálogo Propriedades do Rastreamento , digite um nome para o rastreamento na caixa Nome do rastreamento .

  3. Na lista Usar o modelo, selecione um modelo de rastreamento no qual esse rastreamento deve ser baseado. Se você não quiser usar um modelo, selecione Em branco.

  4. Realize um dos seguintes procedimentos:

    • Selecione a caixa de seleção Salvar em arquivo para capturar o rastreamento em um arquivo. Especifique um valor para Definir tamanho máximo do arquivo.

      Opcionalmente, marque as caixas de seleção Habilitar sobreposição de arquivos e Dados de rastreamento de processos do servidor.

    • Marque a caixa de seleção Salvar em tabela para capturar o rastreamento em uma tabela de banco de dados.

      Opcionalmente, selecione Definir máximo de linhas e especifique um valor.

  5. Opcionalmente, marque a caixa de seleção Habilitar horário de parada do rastreamento e especifique uma data e hora de parada.

  6. Selecione a guia Seleção de Eventos.

  7. Na coluna de dados Eventos, expanda a categoria de eventos Desempenho e, em seguida, marque a caixa de seleção Perfil de Estatísticas XML do Showplan. Se a categoria de evento Performance não estiver disponível, marque Mostrar todos os eventos para exibi-la.

    A guia Configurações de Extração de Eventos é adicionada à caixa de diálogo Propriedades do Rastreamento.

  8. Na guia Configurações de Extração de Eventos, selecione Salvar eventos XML Showplan separadamente.

  9. Na caixa de diálogo Salvar como, digite o nome do arquivo para armazenar os eventos Showplan XML Statistics Profile.

  10. Selecione Todos os lotes em um único arquivo para salvar todos os eventos de perfil de estatísticas do Plano de Execução XML em um único arquivo XML. Ou selecione Cada lote de Plano de Execução XML em um arquivo distinto para criar um novo arquivo XML para cada evento de perfil de estatísticas do Plano de Execução XML.

  11. Para exibir o arquivo de evento Showplan XML Statistics Profile no SQL Server Management Studio, no menu Arquivo, aponte para Abrir e selecione Arquivo. Navegue até o diretório no qual você salvou o arquivo ou arquivos de evento Showplan XML Statistics Profile para selecionar um deles e abri-lo. Arquivos de eventoShowplan XML Statistics Profile têm a extensão .SQLPlan.