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Resolver erros de pesquisa na Descoberta Eletrônica

Se você tiver um problema ou erro relacionado a pesquisas na Descoberta Eletrônica do Microsoft Purview, repita a operação para descartar problemas transitórios. Para problemas que persistem, selecione a descrição aplicável na lista a seguir:

Se nenhuma dessas resoluções se aplicar ao seu problema de pesquisa, entre em contato com o Suporte da Microsoft. Dependendo do problema, colete a saída usando o cmdlet Get-ComplianceSearch ou Get-ComplianceSearchAction do PowerShell antes de criar um caso de suporte. Para obter informações sobre outras informações de diagnóstico que o Suporte da Microsoft pode precisar, consulte Coletar informações de diagnóstico de Descoberta Eletrônica.

Para problemas de retenção de Descoberta Eletrônica, consulte Resolver erros de retenção na Descoberta Eletrônica (Standard).

Problema de pesquisa: diferença entre os resultados de pesquisa estimados e baixados

Sintomas

Ao exibir as estatísticas de resultados da pesquisa no < Resumo >da Exportação na pasta de resultados da pesquisa de Descoberta Eletrônica baixada, você observa que as estatísticas de resultados de pesquisa estimadas e baixadas diferem. As estatísticas de resultados de pesquisa estimadas também são mostradas no painel de detalhes da pesquisa no portal de conformidade do Microsoft Purview e na ferramenta de exportação de Descoberta Eletrônica.

Motivo

Uma estimativa dos resultados da pesquisa é apenas isso: é uma estimativa e não uma contagem real de itens que atendem aos critérios de consulta de pesquisa. Para obter mais informações sobre por que os resultados de pesquisa estimados e baixados podem ser diferentes, consulte Diferenças entre os resultados de pesquisa de Descoberta Eletrônica estimados e reais.

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Erro de pesquisa: "A localização é ambígua"

Sintomas

Quando você executa uma pesquisa de Descoberta Eletrônica, a pesquisa falha e retorna a seguinte mensagem de erro:

A pesquisa de conformidade contém os seguintes locais inválidos: <identificador> de caixa de correio. O identificador< da caixa de correio de localização >é ambíguo.

Motivo

Os locais especificados na mensagem de erro são inválidos. O identificador de caixa de correio para cada local inválido é usado por objetos duplicados ou conflitantes no Exchange Online Protection (EOP).

Resolução

Para cada local inválido, siga estas etapas:

  1. Conectar-se a Segurança e Conformidade do PowerShell.

  2. Localize os objetos duplicados ou conflitantes que usam um identificador de caixa de correio. Para pesquisar, execute o seguinte comando Get-Recipient :

    Get-Recipient -Identity "<mailbox identifier from error message>"
    
  3. Remova o objeto duplicado ou conflitante.

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Erro de pesquisa: "Destinatário não encontrado"

Sintomas

Sua pesquisa de Descoberta Eletrônica falha e retorna a mensagem de erro "Destinatário não encontrado".

Motivo

O sistema não consegue encontrar um dos destinatários em sua pesquisa de Descoberta Eletrônica devido a atrasos de sincronização no Exchange Online Protection (EOP).

Resolução

  1. Conectar-se a Segurança e Conformidade do PowerShell.

  2. Verifique se os destinatários na consulta de pesquisa estão sincronizados no EOP usando o cmdlet Get-Recipient . Execute o comando a seguir:

    Get-Recipient -Identity "<user identifier>" | FL
    
  3. Se o comando não retornar um objeto de usuário para um destinatário, aguarde 30 minutos para que a sincronização seja concluída e verifique novamente.

  4. Depois de verificar se o destinatário está sincronizado no EOP, tente novamente sua pesquisa.

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Erro de pesquisa: CS007

Sintomas

Sua pesquisa de Descoberta Eletrônica falha e retorna um código de CS007 erro.

Motivo

Qualquer um dos seguintes problemas pode causar esse erro:

  • Um problema transitório

  • Uma consulta de pesquisa que retorna muitos resultados para o sistema processar. Por exemplo, uma consulta que usa vários curingas pode retornar um grande conjunto de resultados.

Resolução

Repita sua pesquisa. Se sua pesquisa ainda falhar, divida-a em pesquisas menores. Por exemplo, use intervalos de datas ou limite o número de locais de pesquisa para retornar conjuntos de resultados menores.

Erro de pesquisa: "Ocorreu um erro interno do servidor (500)"

Sintomas

Sua pesquisa de Descoberta Eletrônica falha e retorna a mensagem de erro "Ocorreu um erro interno do servidor (500)".

Motivo

  • Uma consulta de pesquisa que retorna muitos resultados para o sistema processar. Por exemplo, uma consulta que usa vários curingas pode retornar um grande conjunto de resultados.

Resolução

Repita sua pesquisa. Se sua pesquisa ainda falhar, divida-a em pesquisas menores. Por exemplo, use intervalos de datas ou limite o número de locais de pesquisa para retornar conjuntos de resultados menores.

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Erro de pesquisa ou exportação: "O número máximo de trabalhos da sua organização está em execução no momento"

Sintomas

Quando você tenta pesquisar ou exportar os resultados da pesquisa de Descoberta Eletrônica, a operação falha e você recebe a seguinte mensagem de erro:

Sua solicitação não pode ser iniciada porque o número máximo de trabalhos da sua organização está em execução no momento.

Motivo

Sua organização atingiu o limite máximo de 50 trabalhos simultâneos. Como os trabalhos de exportação normalmente demoram mais para serem concluídos do que os trabalhos de pesquisa, é mais provável que os trabalhos de exportação preencham a cota.

Resolução

Use o procedimento a seguir para ver quais trabalhos de exportação estão sendo executados no momento:

Observação

Para usar o procedimento a seguir, você deve ser membro do grupo de funções Gerenciador de Descoberta Eletrônica e ser um administrador de Descoberta Eletrônica nesse grupo. Para obter mais informações sobre como exibir ou atribuir Administradores de Descoberta Eletrônica em sua organização, consulte Atribuir permissões de Descoberta Eletrônica, Get-eDiscoveryCaseAdmin e Add-eDiscoveryCaseAdmin.

  1. Conectar-se a Segurança e Conformidade do PowerShell.

  2. Execute o seguinte script:

    $date = Get-Date
    $exports = @(Get-ComplianceSearchAction -Export -ResultSize Unlimited)
    $cases = Get-ComplianceCase | ?{$_.status -like "Active"}
    $i = 1
    foreach ($case in $cases) {
      $exports += Get-ComplianceSearchAction -Export -Case $case.Name
      Write-Host "Processing case $($i) of $($cases.Count)"
      $i++
    }
    $inProgressExports = $exports | ?{$_.Results -eq $null -or (!$_.Results.Contains("Export status: Completed") -and !$_.Results.Contains("Export status: none"))}
    $inProgressExportsSince = $inProgressExports | ?{$_.JobStartTime -ge $date.AddDays(-7)} | Sort-Object JobStartTime -Descending
    Write-Host "In-progress export jobs:"
    $inProgressExports | Format-Table Name,JobStartTime,JobEndTime,Status | More
    Write-Host "In-progress export jobs started in the last 7 days:"
    $inProgressExportsSince | Format-Table Name,JobStartTime,JobEndTime,Status | More
    

Para resolver o erro, use o seguinte procedimento:

  1. Reduza o número de trabalhos em execução. Use uma ou ambas as seguintes abordagens:

    • Aguarde a conclusão de um ou mais trabalhos em execução.

    • Remova um ou mais trabalhos em execução que você não precisa mais usando o cmdlet Remove-ComplianceSearchAction do PowerShell.

  2. Repita sua operação de pesquisa ou exportação.

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Erro de exportação: "O item foi movido ou excluído" ou "Não é possível recuperar o item devido ao tempo limite"

Sintomas

Depois de baixar os resultados da pesquisa de Descoberta Eletrônica, você verá os seguintes erros no arquivo Avisos de Exportação e Errors.csv na pasta de exportação baixada:

  • FailedToExportItem_Microsoft.Exchange.EDiscovery.Export.ExportException: Falha na exportação com o tipo de erro: 'FailedToExportItem'. Mensagem: O item foi movido ou excluído.

  • FailedToExportItem_Microsoft.Exchange.EDiscovery.Export.ExportException: Falha na exportação com o tipo de erro: 'FailedToExportItem'. Mensagem: Não é possível recuperar o item devido ao tempo limite após várias tentativas.

Motivo

Essas mensagens de erro "FailedToExportItem" indicam que o sistema não exportou todos os itens de resultado da pesquisa. Os itens não exportados são backups temporários que o sistema criou durante o arquivamento da caixa de correio. Embora a Descoberta Eletrônica possa pesquisar itens de backup temporários, esses itens não são exportáveis.

Resolução

Aguarde até que o sistema recupere e exporte os itens de caixa de correio originais associados aos backups temporários.

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Erro de exportação: "O arquivo não foi exportado porque não existe" ou "Arquivo não encontrado"

Sintomas

Depois de baixar os resultados da pesquisa de Descoberta Eletrônica, você verá uma das seguintes mensagens de erro nos Avisos de Exportação e Errors.csv, Items.csv ignorado ou arquivos trace.log na pasta de exportação baixada:

  • Este arquivo não foi exportado porque não existe mais. O arquivo foi incluído na contagem de resultados de pesquisa estimados porque ainda está listado no índice. O arquivo será eventualmente removido do índice e não causará um erro no futuro.

  • FailedToExportItem_Failed para baixar conteúdo. Informações adicionais de diagnóstico: Microsoft.Office.Compliance.EDiscovery.ExportWorker.Exceptions.ContentDownloadTemporaryFailure: Falha ao baixar da ID< do documento de conteúdo >do tipo Documento. ID de correlação: <ID de> correlação. ServerErrorCode: -2147024894 ---> Microsoft.SharePoint.Client.ServerException: Arquivo não encontrado. em Microsoft.SharePoint.Client.ClientRequest.ProcessResponseStream(Stream responseStream) em Microsoft.SharePoint.Client.ClientRequest.ProcessResponse() --- --- de rastreamento de pilha de exceção interna

Motivo

Você poderá ver essa mensagem de erro se a pesquisa de Descoberta Eletrônica incluir locais do Microsoft SharePoint Online ou do Microsoft OneDrive for Business. A Descoberta Eletrônica depende do índice do SharePoint Online para identificar arquivos em ambos os locais. O erro ocorre se um usuário renomear, mover ou excluir um arquivo nos resultados da pesquisa após a conclusão da pesquisa, mas antes que o sistema atualize o índice do SharePoint Online. Você pode verificar se um arquivo foi renomeado, movido ou excluído procurando o arquivo no local aplicável do SharePoint Online ou do OneDrive for Business.

Resolução

Para resolver o problema, reindexe o local do SharePoint Online ou do OneDrive for Business usando um dos procedimentos fornecidos em Solicitar manualmente o rastreamento e a reindexação de um site, uma biblioteca ou uma lista. Se você quiser que os resultados da pesquisa incluam os arquivos renomeados ou movidos, execute novamente a pesquisa de Descoberta Eletrônica.

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Problema de download de exportação: a exportação de Descoberta Eletrônica não baixa nenhum arquivo

Sintomas

Você executa a exportação do eDiscovery para baixar os resultados da pesquisa. No entanto, após a conclusão da operação, o campo Total Estimado na janela de ferramentas mostra que nenhum arquivo foi baixado.

Motivo

O problema pode ocorrer por qualquer um dos seguintes motivos:

  • Navegador não configurado para permitir pop-ups.

  • Alguns pontos de extremidade de rede não têm permissão para download em sua organização.

Resolução

Se você estiver enfrentando problemas que afetam o download, consulte As práticas recomendadas para baixar pacotes de exportação.

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Erro de download de exportação: "O resultado da pesquisa não foi baixado porque é uma pasta"

Sintomas

Depois de baixar os resultados da pesquisa de Descoberta Eletrônica, você verá a seguinte mensagem de erro no arquivo Items.csv ignorado na pasta de exportação baixada:

Este resultado da pesquisa não foi baixado, pois é uma pasta ou outro artefato que não pode ser baixado sozinho, todos os itens dentro da pasta ou biblioteca serão baixados.

Motivo

Você poderá ver essa mensagem de erro se sua pesquisa incluir locais do Microsoft SharePoint Online ou do Microsoft OneDrive for Business. O arquivo Items.csv ignorado lista todas as pastas e outros itens ignorados nos resultados da pesquisa. A mensagem de erro normalmente aparece ao lado dos caminhos de pasta porque eles não são itens para download.

Resolução

Nenhuma resolução é necessária. Você pode ignorar a mensagem de erro com segurança.

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