Erro ao aceder à aplicação Viva Connections a partir do cliente de ambiente de trabalho do Teams

Sintomas

A sua organização seguiu os passos para configurar e iniciar Viva Connections. No entanto, quando tenta aceder à aplicação Viva Connections a partir do cliente de ambiente de trabalho do Microsoft Teams, recebe a seguinte mensagem de erro:

Ocorreu um problema. Não conseguimos iniciar sessão. Se o erro persistir, contacte o administrador de sistema e forneça o código de erro CAA20004.

Quando seleciona Informações adicionais sobre problemas na mensagem de erro, verá os seguintes detalhes:

AADSTS650057: recurso inválido. O cliente pediu acesso a um recurso que não está listado nas permissões pedidas no registo de aplicação do cliente.

Captura de ecrã da mensagem de erro com informações adicionais.

Nota: Este problema ocorre apenas quando acede à aplicação Viva Connections a partir do cliente de ambiente de trabalho do Teams. Não verá este erro se aceder à aplicação Viva Connections a partir do cliente Web do Teams.

Causa

Este erro ocorre se uma peça Web SharePoint Framework (SPFx) for adicionada à Viva Connections. Devido à adição da peça Web, o objeto Principal de Aplicação Web de Extensibilidade de Cliente do SharePoint Online que está disponível emRegistos de Aplicações de ID> Microsoft Entra não está configurado corretamente para confiar no cliente de ambiente de trabalho do Teams.

Resolução

Para resolver este problema, navegue para a página Acesso à API a partir do centro de administração do SharePoint:

  1. Inicie sessão no centro de administração do SharePoint com as Credenciais de administrador global.
  2. Selecione Acesso avançado>à API.

Se não vir a opção asss da API , utilize os seguintes passos:

  1. Inicie sessão no centro de administração do SharePoint com as Credenciais de administrador global.
  2. Selecione Mais funcionalidades.
  3. Selecione o botão Abrir em Aplicações.
  4. Selecione Acesso à API.