Не удается открыть общую папку в Outlook в Интернете в Exchange Server
Симптомы
Рассмотрим следующие сценарии.
Сценарий 1
- Вы уже Microsoft Exchange Server 2016 или Exchange Server 2013 в среде Exchange Server 2010.
- У пользователя User1 есть почтовый ящик Exchange Server 2016 или Exchange Server 2013.
- У пользователя 2 есть почтовый ящик Exchange Server 2010.
- Пользователь User1 имеет полные разрешения на доступ к почтовому ящику пользователя User2.
Сценарий 2
- У вас гибридная среда Microsoft 365.
- У пользователя User1 есть почтовый ящик в облаке.
- У пользователя 2 есть локальный почтовый ящик.
- Пользователь User1 имеет полные разрешения на доступ к почтовому ящику пользователя User2.
В этих сценариях пользователь User1 не может развернуть почтовый ящик пользователя User2 после добавления почтового ящика User1 с помощью параметра "Добавить общую папку ". Кроме того, пользователь User1 получает следующее сообщение об ошибке:
Не удается выполнить запрос.
Возможно, у вас нет разрешения на выполнение этого действия.
Примечание В сценарии 2, если у пользователя User1 есть локальный почтовый ящик, а у пользователя User2 есть почтовый ящик в облаке (т. е. независимо от среды, в которой размещен этот почтовый ящик), пользователь User1 не может развернуть почтовый ящик пользователя User2.
Причина
Запрос AddSharedFolder выполнен успешно и добавляет общий почтовый ящик в список папок. Однако запрос на расширение общего почтового ящика перенаправлен на сервер почтовых ящиков для пользователя. Это активирует сообщение WrongServerVersionException и состояние HTTP 500. Http-ответ может включать в себя следующее:
{"Body":{"ErrorCode":500,"ExceptionName":"WrongServerVersionException","FaultMessage":"The Client Access server version doesn't match the Mailbox server version of the resource that was being accessed. To determine the correct URL to use to access the resource, use Autodiscover with the address of the resource.", "IsTransient":false,"StackTrace":"Microsoft.Exchange.Services.Core.Types.WrongServerVersionException: The Client Access server version doesn't match the Mailbox server version of the resource that was being accessed. To determine the correct URL to use to access the resource, use Autodiscover with the address of the resource. \u000d\u000a at Microsoft.Exchange.Services.Core.Types.StoreSessionCacheBase.ConnectOnce(ExchangePrincipal mailboxToAccess, CallContext callContext, Boolean unifiedLogon)\u000d\u000a at
Обходной путь
Чтобы обойти эту проблему, используйте параметр "Открыть другой почтовый ящик" в Outlook в Интернете, чтобы открыть общий почтовый ящик с разрешением на полный доступ. Примечание: Это приведет к появлению ссылки перенаправления и запроса учетных данных, прежде чем вы сможете получить доступ к почтовому ящику. Дополнительные сведения см. в разделе о разрешениях почтовых ящиков, поддерживаемых в гибридных средах , в этой статье.