Не удается открыть общую папку в Outlook в Интернете в Exchange Server

Симптомы

Рассмотрим следующие сценарии.

Сценарий 1

  • У вас есть Microsoft Exchange Server 2016 или Exchange Server 2013 годах, которые существуют в среде Exchange Server 2010 года.
  • У пользователя 1 есть почтовый ящик Exchange Server 2016 или Exchange Server 2013.
  • У пользователя 2 есть почтовый ящик Exchange Server 2010 г.
  • Пользователь User1 имеет полные разрешения на доступ к почтовому ящику для User2.

Сценарий 2

  • У вас есть гибридная среда Microsoft 365.
  • У Пользователя1 есть почтовый ящик в облаке.
  • У Пользователя 2 есть локальный почтовый ящик.
  • Пользователь User1 имеет полные разрешения на доступ к почтовому ящику для User2.

В этих сценариях User1 не может развернуть почтовый ящик для User2 после добавления почтового ящика User1 с помощью параметра Добавить общую папку . Кроме того, User1 получает следующее сообщение об ошибке:

Не удается выполнить запрос.
Возможно, у вас нет разрешения на выполнение этого действия.

Примечание В сценарии 2, если у Пользователя 1 есть локальный почтовый ящик, а у Пользователя 2 — почтовый ящик в облаке (т. е. независимо от того, в какой среде размещен какой почтовый ящик), пользователь User1 не сможет развернуть почтовый ящик для User2.

Причина

Запрос AddSharedFolder выполнен успешно и добавляет общий почтовый ящик в список папок. Однако запрос на расширение общего почтового ящика передается через прокси-сервер почтового ящика для пользователя. Это активирует сообщение "WrongServerVersionException" и состояние HTTP 500 . HTTP-ответ может включать следующее:

 {"Body":{"ErrorCode":500,"ExceptionName":"WrongServerVersionException","FaultMessage":"The Client Access server version doesn't match the Mailbox server version of the resource that was being accessed. To determine the correct URL to use to access the resource, use Autodiscover with the address of the resource.", "IsTransient":false,"StackTrace":"Microsoft.Exchange.Services.Core.Types.WrongServerVersionException: The Client Access server version doesn't match the Mailbox server version of the resource that was being accessed. To determine the correct URL to use to access the resource, use Autodiscover with the address of the resource. \u000d\u000a at Microsoft.Exchange.Services.Core.Types.StoreSessionCacheBase.ConnectOnce(ExchangePrincipal mailboxToAccess, CallContext callContext, Boolean unifiedLogon)\u000d\u000a at

Обходной путь

Чтобы обойти эту проблему, используйте параметр Открыть другой почтовый ящик в Outlook в Интернете, чтобы открыть общий почтовый ящик с разрешением на полный доступ. Примечание: Это создаст ссылку перенаправления и запрос учетных данных, прежде чем вы сможете получить доступ к почтовому ящику. Дополнительные сведения см. в разделе Разрешения почтовых ящиков, поддерживаемые в гибридных средах этой статьи.