GeneralIncomingEmailServerError при попытке установить Microsoft Dynamics 365 App для Outlook
В этой статье описывается решение проблемы, из-за чего при попытке установить Microsoft Dynamics 365 App для Outlook может возникнуть ошибка GeneralIncomingEmailServerError.
Область применения: Microsoft Dynamics CRM
Исходный номер базы знаний: 4019040
Симптомы
При попытке установить Microsoft Dynamics 365 App для Outlook возникает следующая ошибка:
При попытке добавить приложение в Outlook возникла проблема.
SoapException: GeneralIncomingEmailServerError
Если щелкнуть ссылку Сведения , появятся следующие дополнительные сведения:
Ошибка: System.Web.Services.Protocols.SoapException: указанная версия сервера недопустима. в system.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) в System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult asyncResult) в Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndInstallApp(IAsyncResult asyncResult) в Microsoft.Crm.Асинхрон.EmailConnector.OfficeAppsDeploymentStep.EndCall() в Microsoft.Crm.Asynchronous.EmailConnector.ExchangeIncomingEmailProviderStep.EndOperation()
Причина
Эта ошибка может возникнуть, если вы используете локальную версию Exchange и версия не соответствует требованиям.
Решение
Убедитесь, что используемая версия локальной версии Exchange соответствует требованиям, описанным в статье Поддерживаемые конфигурации с Microsoft Exchange.
Примечание.
Если почтовый ящик пользователя находится в поддерживаемой версии Microsoft Exchange, но ваша организация перенесена из более ранней версии Exchange, например Exchange Server 2010, эта ошибка может возникнуть, если вы не перенесли системные почтовые ящики. Дополнительные сведения о перемещении системных почтовых ящиков см. в статье Перемещение системного почтового ящика Exchange 2010 в Exchange 2013.