office 2010 медленно работает диалог открытия и сохранения фалов

Анонимные
2012-11-29T09:30:33+00:00

Столкнулись с проблемой медленной работы диалога открытия/сохранения фалов. Диалоговое окно "задумывается" на 10-40сек.

Диалог выдает задержки при листинге директории в которой находится более текстовых 10000 фалов (расширения в основном rtf и txt). Понимаю что желательно не делать таких директорий, но в данном случае вопрос не только в производительности, но и в сочетании продуктов. Симптомы проявляются только в связке Windows Xp + Office 2010. Если использовать XP совместно с Office 2003 или Win7 c Office 2010, то проблемы не возникает. Проблема наблюдается в продуктах Word, Excel и Powerpoint. Другие продукты не тестировались.

Что можете посоветовать для диагностики или решения проблемы?

Microsoft 365 и Office | Word | Для дома | Windows
Microsoft 365 и Office | Word | Для дома | Windows

Семейство программных продуктов Microsoft для обработки текстов, позволяющее создавать документы для интернета, электронной почты и печати.

Заблокированный вопрос. Этот вопрос был перенесен из сообщества службы поддержки Майкрософт. Вы можете проголосовать о его полезности, но не можете добавлять комментарии или ответы, а также подписаться на этот вопрос.

Комментариев: 0 Без комментариев

Ответы: 7

Сортировать по: Наиболее полезные
  1. Анонимные
    2013-02-19T20:04:20+00:00

    К сожалению совет не помог. Если воссоздать папку с большим количеством файлов на локальном диске и запустить программу в безопасном режиме проблема остается.

    Какие еще данные необходимы для диагностики и куда еще можно обратиться по данному вопросу?

    Назначьте другой принтер по умолчанию.

    Попробуйте на время сменить принтер по умолчанию, затем открыть саму программу Microsoft Word или Microsoft Excel и проверить.

    Удалите файлы с тильдой ~ в папках, где сохраняются по умолчанию файлы Word и Excel.

    Отобразите скрытые файлы и папки, а также системные, для этого – откройте Мой компьютер, выберите меню Сервис – Свойства папки… (или нажмите Пуск –> Настройка – Панель управления – Свойства папки) – в открывшемся диалоговом окне Свойства папки откройте вкладку Вид – в прокручиваемом списке Дополнительные параметры установите флажок Отображать содержимое системных папок, снимите флажок Скрывать защищенные системные файлы, установите переключатель Показывать скрытые файлы и папки – нажмите OK, затем удалите файлы со знаками тильда ~ в папке, куда по умолчанию сохраняются файлы Microsoft Word и Microsoft Excel и проверьте после этого.

    Откройте саму программы Microsoft Word 2010 или Microsoft Excel 2010 от имени администратора.

    Войдите в меню Пуск, Все программы, Microsoft Office, нажмите на клавиатуре клавишу SHIFT и удерживайте ее нажатой затем нажмите правой кнопкой мыши на Microsoft Word 2010 или Microsoft Excel 2010, выберите Запуск от имени администратора, отпустите клавишу SHIFT, при необходимости введите пароль и разрешите программе внести изменения на компьютере, попробуйте сохранить новый документ.

    Приостановите временно антивирусную программу и проверьте сохранение. Также попробуйте добавить саму программу Microsoft Word 2010 и Microsoft Excel 2010 в исключение антивирусной программы.

    Обычно директория данных файлов:

    Для 32-разрядной Windows

    C:\Program files\Microsoft Office\Office 14\winword.exe

    C:\Program files\Microsoft Office\Office 14\excel.exe

    Для 32-разрядной Windows

    C:\Program files (x86)\Microsoft Office\Office 14\winword.exe

    C:\Program files (x86)\Microsoft Office\Office 14\excel.exe

    Затем проверьте сохранение документа.

    Отключите все надстройки Microsoft Excel 2010.

    a).Открйоте Microsoft Word 2010, нажмите меню «Файл», нажмите «Параметры», нажмите «Надстройки», посмотрите есть ли активные надстройки приложений.

    b).Внизу есть надпись «Управление:»

    Выберите Надстройки COM, нажмите кнопку «Перейти…», откроется диалоговое окно «Надстройки для модели компонентных объектов (COM)», снимите все флажки в списке надстроек, нажмите кнопку «OK».

    c).Повторите пункт a), нажмите на надпись «Надстройки COM», выберете «Надстройки Excel», нажмите кнопку «Перейти…», откроется диалоговое окно «Надстройки», снимите все флажки, нажмите кнопку «OK».

    d).Нажмите сочетание клавиш Alt+F8, откроется диалоговое окно «Макрос», посмотрите, есть ли, какие либо компоненты, если да, удалите их, поля должны быть пустые.

    e).Перезапустите прложение Microsoft Excel 2010, проверьте, сохранение документа.

    Отключите все надстройки Microsoft Word 2010.

    a).В Microsoft Word 2010 нажмите меню «Файл», нажмите «Параметры», нажмите «Надстройки», посмотрите есть ли активные надстройки приложений.

    b).Внизу есть надпись «Управление:»

    Надстройки COM, нажмите кнопку «Перейти…», откроется диалоговое окно «Надстройки для модели компонентных объектов (COM)», снимите все флажки в списке надстроек, нажмите кнопку «OK».

    c).Повторите пункт a), нажмите на надпись «Надстройки COM», выберете «Надстройки Word», нажмите кнопку «Перейти…», откроется диалоговое окно «Шаблоны и надстройки», на вкладке «Шаблоны», снимите все флажки в поле «Общие шаблоны и надстройки», перейдите на вкладку «XML-схема», снимите все флажки в поле «Доступные XML-схемы», перейдите на вкладку «Пакеты расширения XML», снимите все флажки в поле «Доступные пакеты расширения XML», перейдите на вкладку «Связанные CSS», снимите все флажки в поле «Связанные таблицы стилей», нажмите кнопку «OK».

    d).Нажмите сочетание клавиш Alt+F8, откроется диалоговое окно «Макрос», посмотрите, есть ли, какие либо компоненты, если да, удалите их, поля должны быть пустые.

    e).Закройте приложение Microsoft Word 2010, проверьте, сохранение документа.

    Настройте запуск системы на чистую загрузку.

    Для устранения неполадок и других проблем, можно запустить Windows с минимальным набором драйверов и программ. Такой тип запуска называется «чистой загрузки». Чистый запуск поможет исключить конфликты программного обеспечения.

    Для того, чтобы выполнить "чистую загрузку" Windows, выполните следующие действия:

    Войдите в меню Пуск, в поле Найти программы и файлы введите:

    msconfig

    В верхней части отобразится программа msconfig, нажмите на ней правой кнопкой мыши и выберите Запуск от имени администратора, разрешите программе внести изменения на компьютере, откроется окно Конфигурация системы.

    Переведите отметку Выборочный запуск, снимите флажок Загружать элементы автозагрузки, перейдите на вкладку Службы, отметьте флажком Не отображать службы Майкрософт, нажмите кнопку Отключить все, нажмите кнопку Применить, OK, перезагрузите компьютер.

    Выполните восстановление Microsoft Office 2010.

    Пуск, Панель управления, Установка или удаление программ, найдите в списке Microsoft Office 2010 и выделите его, нажмите на нем правой кнопкой мыши, выберите Изменить или Удалить/Изменить, в открывшимся окне отметьте Восстановить, нажмите кнопку Продолжить, далее следуйте мастеру восстановления.

    Внимание! Восстановление Microsoft Office не требует наличия диска, а также повторной активации. Приложения восстанавливаются из резервной копии расположенной на жестком диске.

    Проблема может быть в учетной записи пользователя, создайте новую учетную запись пользователя и войдите под ней в систему, затем проверьте, сохранение документа.

    Этот ответ помог вам?

    Один пользователь счел этот ответ полезным.
    Комментариев: 0 Без комментариев
  2. Анонимные
    2012-12-07T15:59:43+00:00

    К сожалению такие варианты решения были опробованы при первой же возможности. Проблема точно связана с большим объемом файлов в директории и с железом не связана.

    Директория, где расположено такое количество файлов сетевая?

    Обновления для Winodws XP SP3 все установлены, в том числе и для MS Office 2010 SP1?

    Попробуйте отключить сеть и открыть или сохранить документ офиса.

    Откройте Microsoft Outlook в безопасном режиме и проверьте.

    Нажмите сочетание клавиш Win+R в поле Открыть введите:

    outlook /safe

    Нажмите кнопку OK, приложение откроется в безопасном режиме, о чем будет свидетельствовать надпись в заголовке.

    Этот ответ помог вам?

    Комментариев: 0 Без комментариев
  3. Deleted

    Этот ответ был удален из-за нарушения правил поведения. Ответ был отправлен вручную или идентифицирован с помощью автоматического обнаружения до выполнения действия. Дополнительные сведения см. в разделе правила поведения.


    Комментарии отключены. Подробнее

  4. Анонимные
    2012-12-04T06:19:28+00:00

    К сожалению такие варианты решения были опробованы при первой же возможности. Проблема точно связана с большим объемом файлов в директории и с железом не связана.

    Этот ответ помог вам?

    Комментариев: 0 Без комментариев
  5. Анонимные
    2012-12-03T19:33:44+00:00

    Здравствуйте.

    Работает у меня Office 2010 на Windows XP, таких затруднений не испытываю. Могу посоветовать проверить в другой уч. записи пользователя, временно удалить все антивирусные средства защиты, извлечь все модули оперативной памяти - оставить только один, и возможно пришло время переустановить систему.

    Этот ответ помог вам?

    Комментариев: 0 Без комментариев