Семейство программных продуктов Microsoft для обработки текстов, позволяющее создавать документы для интернета, электронной почты и печати.
Здравствуйте,
Вообще-то эта задача штатно решается с помощью слияния... ;)
===
… http://office.microsoft.com/client/&app=ZWD&ver=14Слияние применяется, когда нужно создать набор документов, таких как письма на бланках, которые отправляются большому количеству клиентов. Каждый документ содержит как стандартные, так и уникальные сведения. Например, письма клиентам можно персонализировать, обращаясь к клиенту по имени. Уникальная информация для каждого письма поступает из записей в источнике данных. ...
===
Боюсь, что для автора не подойдёт метод слияния, который более трудоёмкий и требует множественного заполнения специальных форм. И то, что для вас просто, для неопытных пользователей достаточно сложно, так как им ещё предстоит осваивать навыки работы с Майкрософт Оффисе. Метод с колонтитулами и сменой нумерации страниц намного проще. Ведь нужно учитывать, что большинство спрашивающих не относятся к Ай-Ти специалистам, и не умеют использовать более сложные операции с документами. Курсы обучения, ссылки на которые предсчтавлены ниже, помогут освоить им их, хотя и не сразу.
http://office.microsoft.com/ru-ru/word-help/HA010081976.aspx?CTT=1
Добавление в документ текстовых заполнителей (полей слияния)
После подключения основного документа к файлу данных можно вводить текст документа и добавлять текстовые заполнители, указывающие места, где в каждой копии документа должны появляться уникальные данные.
Текстовые заполнители, такие как адрес или приветствие, называются полями слияния. Поля в приложении Word соответствуют выделенным заголовкам столбцов в файле данных.

Столбцы файла данных представляют собой категории данных. Поля, добавляемые к основному документу, являются текстовыми заполнителями для этих категорий.
Строки файла данных представляют собой записи данных. При выполнении слияния приложение Word создает копию основного документа для каждой записи.
При помещении поля в основной документ подразумевается, что в месте его расположения должна появиться определенная категория данных, например фамилия или адрес.

Примечание. При вставке поля слияния в основной документ имя поля всегда заключается в двойные угловые скобки (« »). В составных документах эти скобки служат не для выделения. Они лишь позволяют отличать поля в основном документе от нормального текста.
Что происходит при слиянии
При слиянии данные первой строки файла данных замещают поля в основном документе, тем самым, образуя первый составной документ. Данные второй строки файла данных замещают поля, образуя второй составной документ, и т. д.

Примеры работы с полями
Из файла данных в основной документ в качестве поля можно добавить любой заголовок столбца. Это дает определенную гибкость при составлении бланков писем, наклеек, сообщений электронной почты и других составных документов. Ниже перечислены примеры.
- Подготовка письма, уведомляющего местные предприятия о том, что они выбраны для включения в ежегодный выпуск городского путеводителя. Если файл данных содержит столбец «Компания» с названием каждого предприятия бизнеса, с которым нужно войти в контакт, вместо того, чтобы вводить имя каждой компании в отдельности, можно вставить в документ поле «Компания».
- Рассылка ежеквартальных сообщений электронной почты заказчикам, оповещающих о появившихся новых продуктах и скидках. Чтобы персонализировать эти сообщения для лучших заказчиков, в файл данных можно добавить столбец «Строка приветствия», где можно ввести такое обращение, как «Уважаемая г-жа Ильина, это новое украшение, как раз то, что Вы искали». Поместив поле «Строка приветствия» в основной документ, можно таким образом включать эти обращения в конце определенных сообщений.
- Список рассылки для подписчиков информационного бюллетеня. Если файл данных включает столбец с названием «Срок истечения», содержащий даты истечения срока каждой подписки, то поместив, поле «Срок истечения» в основной документ наклейки перед выполнением слияния, можно с помощью информации на почтовой наклейке показать каждому из подписчиков дату окончания срока действия его подписки.
Можно комбинировать поля и разделять их с помощью знаков препинания. Например, чтобы сформировать точный адрес, необходимо в основной документ вставить следующие поля:
«Имя» «Фамилия»
«Дом и улица»
«Город», «Область», «Почтовый индекс»
Для часто встречающихся случаев, таких как блоки адреса или строки приветствия, приложение Word предоставляет сложные поля — сочетание из нескольких полей. Ниже перечислены примеры.
- Поле «Блок адреса» комбинируется из нескольких полей, включающих имя, фамилию, дом и улицу, город и почтовый индекс.

- Поле «Строка приветствия» может включать в себя одно или более полей имен, в зависимости от используемых слов приветствия.
Содержимое каждого из сложных полей можно соответствующим образом настроить. Например, для адреса можно выбрать формальное имя (г-н Александр Туманов младший), а в обращении использовать «Для» вместо «Уважаемый».
Установление соответствия полей слияния файлу данных
Чтобы не было сомнений, что приложение Word найдет в файле данных столбец, соответствующий каждому адресу или элементу приветствия, необходимо установить соответствие полей слияния в Word столбцам в файле данных.
Для установления соответствия полей выберите пункт Подбор полей в группе Составление документа и вставка полей на вкладке Рассылки.

Откроется диалоговое окно Подбор полей.

Элементы адреса и приветствия приводятся слева. Заголовки столбцов из файла данных приводятся справа.
Word подыскивает соответствующий столбец для каждого элемента. На иллюстрации показано, что Word автоматически нашел соответствие столбца Фамилия файла данных полю Фамилия. Но он не смог противопоставить друг другу другие элементы. В частности, из этого файла данных Word не нашел соответствия полю Имя.
В списке справа можно выделить столбец файла данных, соответствующий элементу слева. Теперь на иллюстрации видно, что столбец Имя соответствует полю Имя. Нет ничего страшного в том, что для полей Обращение, Уникальный идентификатор и Отчество не нашлось соответствия. Составной документ не нуждается в использовании каждого поля. Если добавить поле, для которого нет данных в файле данных, оно будет фигурировать в составном документе как пустой текстовый заполнитель — обычно это пустая строка или скрытое поле.

Ввод содержимого и добавление полей
- В основном документе щелкните место, где необходимо вставить поле.
- Пользуйтесь группой Составление документа и вставка полей на вкладке Рассылки.

- Добавьте любые из следующих элементов.
Блок адреса с именем, почтовым адресом и прочими сведениями
- Выберите пункт Блок адреса.
- В диалоговом окне Вставка блока адреса выберите требуемые элементы адреса и форматы отображения, а затем нажмите кнопку ОК.
- Если появится диалоговое окно Подбор полей, значит, приложение Word не смогло найти некоторые сведения, необходимые для блока адреса. Щелкните стрелку рядом с пунктом (нет соответствия), а затем выделите соответствующее поле в источнике данных, требуемое для слияния.
Строка приветствия
- Выберите пункт Строка приветствия.
- Выберите формат строки приветствия, которая включает обращение, имя и знак пунктуации, следующий за именем.
- Выберите текст строки приветствия для случаев, когда имя получателя недоступно, например, когда источник данных не содержит имени или фамилии получателя, а содержит только название компании.
- Нажмите кнопку ОК.
- Если появится диалоговое окно Подбор полей, значит, приложение Word не смогло найти некоторые сведения, необходимые для строки приветствия. Щелкните стрелку рядом с пунктом (нет соответствия), а затем выделите соответствующее поле в источнике данных, требуемое для слияния.
Отдельные поля
Сведения можно вставлять из отдельных полей, таких как фамилия, номер телефона или сумма вклада спонсоров. Чтобы быстро добавить поле из файла данных в основной документ, щелкните стрелку рядом со списком Вставка поля данных, а затем выберите имя поля.
Чтобы использовать большее количество параметров при вставке отдельных полей в документ, выполните следующие действия.
- На вкладке Почта в группе Запись и добавление полей выберите команду Вставить поле слияния.
- В диалоговом окне Вставка поля данныхвыполните одно из следующих действий.
- Чтобы выделить поля адреса, которые будут автоматически соответствовать полям источника данных, даже если поля источника данных имеют другие названия, выберите пункт Поля адреса.
- Чтобы выделить поля, которые всегда используют данные напрямую из столбца файла данных, выберите пункт Поля базы данных.
- В списке Поля щелкните необходимое поле.
- Нажмите кнопку Вставить, а затем Закрыть.
- Если появится диалоговое окно Подбор полей, значит, приложение Word не смогло найти некоторые сведения, необходимые для вставки поля. Щелкните стрелку рядом с пунктом (нет соответствия), а затем выделите соответствующее поле в источнике данных, требуемое для слияния.
Примечание. Если первоначально поле было вставлено из списка Поля базы данных, а затем документ был переключен на другой источник данных, не имеющий столбца с тем же, что и поле, именем, приложение Word не сможет вставить сведения в это поле в составном документе.
Настраиваемые поля из списка контактов приложения Outlook
Единственный способ включить настраиваемые поля списка контактов в основной документ — это начать слияние из приложения Outlook. Предварительно нужно настроить отображение списка контактов с применением именно тех полей, которые должны быть использованы при слиянии. После этого можно начинать слияние. Как только будут установлены все необходимые параметры настройки, автоматически откроется приложение Word, и можно будет завершить слияние. Настройка отображения списка контактов, включающего настраиваемые поля
- В разделе Контакты Outlook в меню Вид выберите пункт Текущее представление, а затем пункт Список телефонов.
- Правой кнопкой мыши щелкните заголовок столбца и выберите пункт Выбрать поля.
- В раскрывающемся списке, находящемся в верхней части диалогового окна Выбрать поля, выделите пункт Поля пользователя в папке.
- Перетащите добавляемое поле из диалогового окна к заголовкам столбцов. Маленькая красная стрелка поможет поместить его там, где нужно.

Примечание. В диалоговое окно Выбрать поля можно добавить новое поле, щелкнув внизу кнопку Создать.
- После того, как в представление добавлены все настраиваемые поля, закройте диалоговое окно Выбрать поля.
- Чтобы удалить поле, которое не должно использоваться при слиянии, поместите указатель мыши на имя поля в заголовке столбца представления «Список телефонов» и стащите поле из заголовка.
Запуск слияния из приложения Outlook
- В представлении «Контакты» приложения Outlook выберите отдельные контакты путем выделения мышью диапазона контактов при нажатой клавише SHIFT или путем выделения мышью отдельных контактов при нажатой клавише CTRL. Если нужно использовать при слиянии все контакты, которые отображаются в данный момент, никакого выделения не требуется.
- В меню Сервис выберите пункт Слияние.
- Если для включения в составной документ выделены только отдельные контакты, выберите пункт Только выбранные контакты. Если в составной документ нужно включить все отображаемые в представлении контакты, выберите пункт Все контакты в текущем представлении.
- Если представление «Список телефонов» настроено таким образом, что оно отображает как раз те самые поля, которые нужно использовать при слиянии, выберите пункт Поля контактов в текущем представлении. Если же выбрать пункт Все поля контактов, то все поля списка контактов будут доступны для слияния.
- Если для слияния нужно создать новый основной документ, выберите пункт Новый документ. В противном случае выберите пункт Существующий документ и, чтобы найти необходимый основной документ, нажмите кнопку Обзор.
- Если нужно сохранить выделенные контакты и поля для использования в дальнейшем, установите флажок Постоянный файл и для сохранения файла нажмите кнопку Обзор. Разделенные запятыми данные будут сохранены в документе Word.
- Выберите параметр слияния.
- Документы на бланке Подготовка партии писем для массовой рассылки.
- Наклейки Подготовка адресных наклеек для массовой рассылки.
- Конверты Подготовка конвертов для массовой рассылки.
- Каталог Создание единого документа, содержащего каталог или список адресов.
- Новый документ Создание составных документов, которые можно отдельно редактировать в приложении Word.
- Принтер Отправка составных документов непосредственно на установленный по умолчанию принтер.
- Электронная почта Создание составных документов в виде, удобном для их рассылки в качестве сообщений электронной почты. Когда все готово к завершению слияния в приложении Word, на вкладке Рассылки в группе Готово выберите команду Найти и объединить, а затем Отправить электронные сообщения. Строка Тема содержит текст, введенный в диалоговом окне Контакты для слияния приложения Outlook.
- Нажмите ОК. Когда документ откроется в приложении Word, то на вкладке Рассылки, в группе Составление документа и вставка полей нажмите стрелку рядом с Вставить поле слияния, а затем щелкните те поля, которые нужно вставить в документ.
Примечания
- Нельзя вводить знаки поля слияния («« »») вручную или использовать для этого команду Символ в меню Вставка. Необходимо использовать процедуру слияния.
- Если поля слияния появляются внутри фигурных скобок, например { MERGEFIELD Город }, приложение Microsoft Word вместо значений полей (Значения полей. Текст или графические объекты, вставленные в документ в результате выполнения программой Microsoft Word инструкций, содержащихся в полях. Когда выполняется печать документа или скрыты коды полей, вместо кодов полей в документе отображаются значения полей.) отображает коды полей (Код поля. Текстовый заполнитель, показывающий место, где будут отображаться указанные сведения из источника данных; элементы, генерирующие результат поля. Коды поля включают знаки поля, тип поля и инструкции.). Это никак не влияет на слияние, но, если требуется отобразить именно значения полей, щелкните код поля правой кнопкой мыши и выберите в контекстном меню пункт Коды/значения полей.
Форматирование результатов слияния
Приложения для работы с базами данных и электронными таблицами, такие как Microsoft Office Access и Microsoft Office Excel, хранят в своих ячейках лишь введенные исходные данные. Параметры форматирования, применяемые в Access и Excel, например шрифты и цвета, не хранятся совместно с исходными данными. При слиянии информации из файлов данных в документ Word попадают только исходные данные без учета того, как они форматировались ранее.
Чтобы отформатировать данные, содержащиеся в документе, выделите поле слияния и отформатируйте его точно так же, как форматируется любой другой текст. Выделение обязательно должно включать двойные кавычки-шевроны (« »), окружающие поле.
 К началу страницы
Предварительный просмотр и завершение слияния
После того, как все поля добавлены в основной документ, можно просмотреть предварительные результаты слияния. Если эти результаты соответствуют ожиданиям, можно завершить слияние.
Предварительный просмотр результатов слияния
Перед фактическим завершением слияния можно просмотреть составные документы и, если нужно, внести соответствующие изменения.
Для просмотра выполните одно из следующих действий в группе Просмотреть результаты вкладки Рассылки :

- Щелкните Просмотреть результаты.
- Просмотрите постранично каждый составной документ с помощью кнопок Следующая запись и Предыдущая запись в группе Просмотр результатов.
- Просмотрите конкретный документ с помощью команды Найти получателя.
Примечание. Чтобы открыть диалоговое окно Адресаты слияния, позволяющее отфильтровать список или исключить получателей, если в список попали нежелательные записи, на вкладке Рассылки в группе Начать слияние выберите пункт Изменить список получателей.

Завершение слияния
Составные документы можно печатать или видоизменять по отдельности. Это может быть сделано как для всех документов, так и для подмножества документов. Печать составных документов
- На вкладке Почта в группе Завершение выберите пункт Завершить и объединить, а затем щелкните Печать документов.

- Выберите, следует ли печатать весь набор документов, только копию, отображаемую в настоящий момент, или подмножество документов, определяемое по указанному номеру записи.
Изменение отдельных копий документа
- На вкладке Почта в группе Завершение выберите пункт Завершить и объединить, а затем щелкните Изменить отдельные документы.

- Выберите, следует ли редактировать весь набор документов, только копию, отображаемую в настоящий момент, или подмножество документов, определяемое по указанному номеру записи. Приложение Word сохраняет копии, которые требуется отредактировать, в виде единого файла, где они отделены друг от друга с помощью разрывов страницы.
Сохранение основного документа
Помните, что составные документы сохраняются отдельно от основного. Основной документ удобно хранить отдельно, поскольку он может оказаться полезен при выполнении последующих слияний.
При сохранении основного документа сохраняется и его подключение к файлу данных. В следующий раз, когда документ будет открыт, приложением будет задан вопрос, нужны ли сведения из этого файла данных для нового слияния в основной документ.
- В случае ответа Да документ открывается с данными из первой записи, полученными в результате слияния.
- В случае ответа Нет подключение между основным документом и файлом данных разрывается. Основной документ становится стандартным документом Word. Поля замещаются на уникальные данные из первой записи
http://office.microsoft.com/ru-ru/training/RZ010279824.aspx?CTT=1
Слияние, часть II. Сложное слияние с помощью ленты
Научитесь выполнять более сложные операции слияния и создавать персонализированные документы на бланках или сообщения электронной почты, пронумерованные купоны и другие документы.
| Сведения об этом курсе<br><br>Данный курс включает следующие разделы: <br><ul><br><li>Два урока для самостоятельного изучения и два практических занятия для получения опыта. Для практических занятий необходимы приложения Microsoft Office Word 2007 и Microsoft Office Excel 2007.</li><li>Краткий тест в конце каждого урока; тесты не оцениваются. </li></ul><ul><br><li>Краткий справочник, который можно использовать отдельно от данного курса. </li></ul> | Цели<br><br>После завершения данного курса вы сможете: <br><ul><br><li>выполнять слияние с помощью вкладки <b>Рассылки</b>;</li><li>использовать поля Word для персонализации документов на бланках и сообщений электронной почты, а также для нумерации купонов;</li><li>выполнять сложное слияние, в результате которого в набор одинаковых документов добавляются несколько уникальных элементов.</li></ul> |
|---|
Тем, кто незнаком с процессом слияния, рекомендуется изучить первый курс, Слияние, часть I. Использование слияния для массовых рассылок, где описано, как выполнить слияние с помощью мастера
