Руководство по переносу SAP ASE в Базу данных SQL Azure

Область применения: База данных SQL Azure

Из этого руководства вы узнаете, как перенести базы данных SAP Adapter Server Enterprise (ASE) в Базу данных SQL Azure, используя Помощник по миграции SQL Server для SAP Adapter Server Enterprise.

Другие рекомендации по миграции см. в руководстве по переносу баз данных в Azure.

Предварительные требования

Прежде чем приступить к переносу базы данных SAP SE в базу данных SQL, выполните следующие действия.

Подготовка к миграции

После выполнения необходимых условий можно приступать к обнаружению топологии среды и оценке возможности вашей миграции в облако Azure.

Оценка

Используй помощник по миграции SQL Server (SSMA) для SAP Adaptive Server Enterprise (прежнее название — SAP Sybase ASE), можно изучить объекты и информацию в базах данных, оценить возможность их переноса, перенести объекты БД Sybase в БД SQL, а затем перенести информацию в БД SQL. Дополнительные сведения см. в статье Помощник по миграции SQL Server для Sybase (SybaseToSQL).

Чтобы провести оценку, выполните следующие действия:

  1. Откройте SSMA для Sybase.

  2. Выберите Файл и Создать проект.

  3. В панели Создать проект введите имя и расположение проекта, а затем в раскрывающемся списке Переместить в выберите База данных SQL Azure.

  4. Щелкните ОК.

  5. В панели Подключение к Sybase введите сведения о подключении к SAP.

  6. Щелкните правой кнопкой мыши базу данных SAP, которую хотите перенести, и выберите команду Создать отчет. Будет создан отчет в формате HTML. Можно также выбрать вкладку Создать отчет в правом верхнем углу.

  7. Просмотрите отчет в формате HTML, чтобы получить сведения о статистике преобразований, увидеть ошибки и предупреждения. Также можно открыть отчет в Excel, чтобы получить список объектов SAP ASE и посмотреть действия по преобразованию схемы. Расположение отчета по умолчанию находится в папке "report" в каталоге SSMAProjects. Пример:

    drive:\<username>\Documents\SSMAProjects\MySAPMigration\report\report_<date>

Проверка сопоставлений типов

Перед преобразованием схемы проверьте сопоставления типов с данными по умолчанию и измените их с учетом ваших требований. Можно перейти к меню Сервис>Параметры проекта или изменить сопоставление типов для каждой таблицы, выбрав таблицу в обозревателе метаданных SAP ASE.

Преобразование схемы

Чтобы преобразовать схему, сделайте следующее:

  1. Чтобы преобразовать динамические или специализированные запросы, щелкните нужный узел правой кнопкой мыши и выберите пункт Добавить инструкцию (необязательно).

  2. Выберите вкладку Соединение с Базой данных SQL Azure, а затем введите сведения о базе. Можно выбрать подключение к существующей базе данных или указать новое имя. В этом случае база данных будет создана на целевом сервере.

  3. В области Обозреватель метаданных Sybase щелкните правой кнопкой мыши схему SAP ASE, с которой работаете, и выберите действие Преобразовать схему.

  4. После преобразования схемы сравните преобразованную структуру с исходной, чтобы выявить потенциальные проблемы.

    После преобразования схемы проект можно сохранить локально для исправления схемы в автономном режиме. Для этого выберите Файл>Сохранить проект. Это дает возможность оценить исходную и целевую схемы в автономном режиме и внести исправления перед публикацией схемы в базе данных SQL.

  5. В области Выходные данные выберите Просмотр результатов и проверьте ошибки в области Список ошибок.

  6. Сохраните проект локально для исправления схемы в автономном режиме. Для этого выберите Файл>Сохранить проект. Это дает возможность оценить исходную и целевую схемы в автономном режиме и внести исправления перед публикацией схемы в базе данных SQL.

Перенос баз данных

Выполнив необходимые условия и задачи, связанные с этапом подготовки к миграции, можно приступить к переносу схемы и данных.

Чтобы опубликовать схему и перенести данные, выполните следующие действия.

  1. Опубликуйте схему. В обозревателе метаданных Базы данных SQL Azure щелкните базу данных правой кнопкой мыши и выберите Синхронизировать с Базой данных. В результате схема SAP ASE будет опубликована в базе данных SQL.

  2. Перенесите данные. В области Обозреватель метаданных SAP ASE щелкните правой кнопкой мыши базу данных или объект SAP ASE, которые требуется перенести, и выберите Миграция данных. Также можно выбрать вкладку Миграция данных в правом верхнем углу.

    Чтобы перенести данные всей базы данных, установите флажок рядом с ее именем. Чтобы перенести данные из отдельных таблиц, разверните базу данных, разверните Таблицы и установите флажок рядом с нужной таблицей. Чтобы не переносить данные из определенной таблицы, снимите флажок.

  3. После завершения миграции изучите отчет о переносе данных.

  4. Проверьте миграцию, просмотрев данные и схему. Подключитесь к базе данных SQL, используя SQL Server Management Studio.

После миграции

После успешного завершения этапа миграции необходимо выполнить ряд дополнительных задач, чтобы обеспечить бесперебойную и эффективную работу всех компонентов.

Исправление приложений

После переноса данных в целевую среду все приложения, которые раньше использовали источник, должны приступить к приему целевого объекта. Для этого в некоторых случаях потребуется внести изменения в приложения.

Выполнение тестов

Тестирование переноса базы данных проводится следующим образом.

  1. Разработка проверочных тестов. Чтобы протестировать перенос базы данных, необходимо использовать SQL-запросы. Следует создать проверочные запросы, которые будут выполняться в исходной и в целевой базах данных. Проверочные запросы должны охватывать всю определенную ранее область.

  2. Настройка тестовой среды. Тестовая среда должна содержать копию исходной и целевой баз данных. Не забудьте изолировать тестовую среду.

  3. Выполнение проверочных тестов. Выполните проверочные тесты в исходной и целевой базах данных, а затем проанализируйте результаты.

  4. Выполнение тестов производительности. Запустите тесты производительности для исходной и целевой баз данных, а затем проанализируйте и сравните результаты.

Оптимизация

Проверка после миграции — очень важный шаг, позволяющий добиться точности и полноты данных и устранить проблемы с производительностью рабочей нагрузки.

Дополнительную информацию об этих проблемах и мерах по их устранению см. в руководстве по проверке и оптимизации после миграции.

Дальнейшие действия