Прочитать на английском

Поделиться через


Сценарий: ошибка пользовательского интерфейса Apache Ambari 502 в Azure HDInsight

В этой статье описаны действия по устранению неполадок и возможные способы решения проблем при взаимодействии с кластерами Azure HDInsight.

Проблема

При попытке доступа к пользовательскому интерфейсу Apache Ambari для кластера HDInsight вы получаете примерно следующее сообщение: "502 — веб-сервер получил недопустимый ответ при работе в качестве шлюза или прокси-сервера".

Причина

В общем случае код состояния HTTP 502 означает, что сервер Ambari работает неправильно на активном головном узле. Этому может быть несколько причин.

Разрешение

В большинстве случаев для устранения проблемы можно перезапустить активный головной узел. Также можно увеличить размер виртуальной машины для головного узла.

Не удалось запустить сервер Ambari

Вы можете проверить журналы ambari-server, чтобы узнать, почему не удалось запустить сервер Ambari. Одна из распространенных причин — ошибка при проверке согласованности базы данных. Найти ее можно в следующем файле журнала: /var/log/ambari-server/ambari-server-check-database.log.

Если вы внесли какие-либо изменения в узел кластера, отмените их. Для изменения настроек, связанных с Hadoop/Spark, всегда используйте пользовательский интерфейс Ambari.

Сервер Ambari занимает 100 % ресурсов ЦП

В редких случаях мы наблюдали у процесса ambari-server загрузку ЦП в районе 100 %. В качестве решения можно подключиться по протоколу SSH к активному головному узлу, завершить процесс сервера Ambari и запустить его снова.

Bash
ps -ef | grep AmbariServer
top -p <ambari-server-pid>
kill -9 <ambari-server-pid>
service ambari-server start

Процесс сервера Ambari был завершен процессом oom-killer

В некоторых сценариях на головном узле не хватает памяти, и в Linux запускается процесс oom-killer, который выбирает процессы для остановки. Чтобы понять, так ли это, выполните поиск по идентификатору процесса AmbariServer (он должен отсутствовать). Затем попытайтесь найти в журнале /var/log/syslog что-то подобное:

Jul 27 15:29:30 xxx-xxxxxx kernel: [874192.703153] java invoked oom-killer: gfp_mask=0x23201ca, order=0, oom_score_adj=0

Выясните, какие процессы занимают память, и попробуйте определить первопричину.

Другие проблемы с сервером Ambari

В редких ситуациях сервер Ambari не может обработать входящий запрос. Дополнительные сведения см. в журналах ambari-server (ищите там ошибки). Вот один из примеров ошибок:

Error Processing URI: /api/v1/clusters/xxxxxx/host_components - (java.lang.OutOfMemoryError) Java heap space

Следующие шаги

Если вы не видите своего варианта проблемы или вам не удается ее устранить, дополнительные сведения можно получить, посетив один из следующих каналов.

  • Получите ответы специалистов Azure на сайте поддержки сообщества пользователей Azure.

  • Подпишитесь на @AzureSupport — официальный канал Microsoft Azure для улучшения качества взаимодействия с клиентами. Вступайте в сообщество Azure для получения нужных ресурсов: ответов, поддержки и советов экспертов.

  • Если вам нужна дополнительная помощь, отправьте запрос в службу поддержки на портале Azure. Выберите Поддержка в строке меню или откройте центр Справка и поддержка. Дополнительные сведения см. в статье Создание запроса на поддержку Azure. Доступ к управлению подписками и поддержкой выставления счетов уже включен в вашу подписку Microsoft Azure, а техническая поддержка предоставляется в рамках одного из планов Службы поддержки Azure.