Прочитать на английском

Поделиться через


Проблемы с пульсом Apache Ambari в Azure HDInsight

В этой статье описаны действия по устранению неполадок и возможные способы решения проблем при взаимодействии с кластерами Azure HDInsight.

Сценарий: высокая загрузка ЦП

Проблема

Агент Ambari интенсивно использует ресурсы ЦП, что приводит к выводу в пользовательском интерфейсе Ambari предупреждений о том, что для некоторых узлов был потерян пульс агента Ambari. Предупреждение о потере пульса Ambari обычно является временным.

Причина

В редких случаях из-за различных ошибок процесса ambari-agent процент потребления им ресурсов ЦП может быть очень высоким (приближаться к 100 %).

Разрешение

  1. Определите идентификатор PID процесса ambari-agent:

    Bash
    ps -ef | grep ambari_agent
    
  2. Чтобы просмотреть сведения об использовании ЦП, выполните следующую команду:

    Bash
    top -p <ambari-agent-pid>
    
  3. Перезапустите процесс ambari-agent, чтобы устранить проблему.

    Bash
    service ambari-agent restart
    
  4. Если перезапуск не помог, завершите процесс ambari-agent, а затем запустите его снова.

    Bash
    kill -9 <ambari-agent-pid>
    service ambari-agent start
    

Сценарий: агент Ambari не запущен

Проблема

Агент Ambari не запущен, что приводит к выводу в пользовательском интерфейсе Ambari предупреждений о том, что для некоторых узлов был потерян пульс агента Ambari.

Причина

Появление предупреждений вызвано тем, что агент Ambari не работает.

Разрешение

  1. Проверьте состояние процесса ambari-agent:

    Bash
    service ambari-agent status
    
  2. Проверьте, работают ли службы контроллера отработки отказа:

    Bash
    ps -ef | grep failover
    

    Если службы контроллера отработки отказа не работают, скорее всего, это связано с наличием проблемы, которая не позволяет службе hdinsight-agent запустить контроллер отработки отказа. Проверьте журнал hdinsight-agent в файле /var/log/hdinsight-agent/hdinsight-agent.out.

Сценарий: потеря пульса для Ambari

Проблема

Связь с агентом пульса Ambari потеряна.

Причина

Журналы OMS вызывают высокую загрузку ЦП.

Разрешение

  • Отключите ведение журнала Azure Monitor с помощью командлета PowerShell Disable-AzHDInsightMonitoring.
  • Удалите файл журнала mdsd.warn.

Следующие шаги

Если вы не видите своего варианта проблемы или вам не удается ее устранить, дополнительные сведения можно получить, посетив один из следующих каналов.

  • Получите ответы специалистов Azure на сайте поддержки сообщества пользователей Azure.

  • Подпишитесь на @AzureSupport — официальный канал Microsoft Azure для улучшения качества взаимодействия с клиентами. Вступайте в сообщество Azure для получения нужных ресурсов: ответов, поддержки и советов экспертов.

  • Если вам нужна дополнительная помощь, отправьте запрос в службу поддержки на портале Azure. Выберите Поддержка в строке меню или откройте центр Справка и поддержка. Дополнительные сведения см. в статье Создание запроса на поддержку Azure. Доступ к управлению подписками и поддержкой выставления счетов уже включен в вашу подписку Microsoft Azure, а техническая поддержка предоставляется в рамках одного из планов Службы поддержки Azure.