Прочитать на английском

Поделиться через


Преобразование содержимого сертификата субъекта-службы в формат строки с кодировкой Base64 (HDInsight)

В этой статье описаны действия по устранению неполадок и возможные способы решения проблем при взаимодействии с кластерами Azure HDInsight.

Проблема

Вы получаете сообщение об ошибке, указывающее, что входные данные не являются допустимой строкой Base-64, так как она содержит небазовый 64 символ, более двух символов заполнения или нечеткого пробела среди символов заполнения.

Причина

При использовании Развертывания шаблонов PowerShell или Azure для создания кластеров с Data Lake в качестве основного или большего хранилища содержимое сертификата субъекта-службы, предоставленное для доступа к учетной записи хранения Data Lake, находится в формате base-64. Неправильное преобразование содержимого PFX-сертификата в строку Base-64 может привести к появлению такой ошибки.

Разрешение

Получив сертификат субъекта-службы в формате PFX (шаги по созданию примера субъекта-службы см. здесь), выполните следующую команду PowerShell или фрагмент кода C#, чтобы преобразовать содержимое сертификата в формат Base-64.

PowerShell
$servicePrincipalCertificateBase64 = [System.Convert]::ToBase64String([System.IO.File]::ReadAllBytes(path-to-servicePrincipalCertificatePfxFile))
C#
using System;
using System.IO;

namespace ConsoleApplication
{
    class Program
    {
        static void Main(string[] args)
        {
            var certContents = File.ReadAllBytes(@"<path to pfx file>");
            string certificateData = Convert.ToBase64String(certContents);
            System.Diagnostics.Debug.WriteLine(certificateData);
        }
    }
}

Следующие шаги

Если вы не видите своего варианта проблемы или вам не удается ее устранить, дополнительные сведения можно получить, посетив один из следующих каналов.

  • Получите ответы специалистов Azure на сайте поддержки сообщества пользователей Azure.

  • Подпишитесь на @AzureSupport — официальный канал Microsoft Azure для улучшения качества взаимодействия с клиентами. Вступайте в сообщество Azure для получения нужных ресурсов: ответов, поддержки и советов экспертов.

  • Если вам нужна дополнительная помощь, отправьте запрос в службу поддержки на портале Azure. Выберите Поддержка в строке меню или откройте центр Справка и поддержка. Дополнительные сведения см. в статье Создание запроса на поддержку Azure. Доступ к управлению подписками и поддержкой выставления счетов уже включен в вашу подписку Microsoft Azure, а техническая поддержка предоставляется в рамках одного из планов Службы поддержки Azure.