Пустая страница отображается в Приложении Microsoft Dynamics для Outlook
В этой статье описывается решение проблемы, из-за которой при использовании приложения Dynamics 365 для Outlook на рабочем столе Outlook отображается пустая страница.
Область применения: Microsoft Dynamics CRM
Исходный номер базы знаний: 4091345
Симптомы
При попытке использовать приложение Dynamics 365 для Outlook на рабочем столе Outlook вы увидите пустую страницу вместо загрузки приложения должным образом.
Причина
Причина 1. Это может произойти, если не все URL-адреса, используемые для проверки подлинности и доступа к Dynamics 365, находятся в одной зоне безопасности Internet Explorer.
Причина 2. Это может произойти, если папка LocalLow имеет неправильный уровень целостности. Правильный параметр — иметь уровень целостности, равный низкому значению имени папки.
Причина 3. Эта проблема может возникнуть, если проблема кэшируется в Internet Explorer или Edge. Если это ранее работало, но ушло работать в последнее время, это, скорее всего, причина.
Причина 4. Корпорация Майкрософт знает о проблеме, которая может возникнуть в следующих условиях:
- Вы используете Windows 10 с обновлением 1903 или более поздней версии.
- Ваша организация настроена на использование Dynamics 365 Online с локальной средой Exchange.
- Вы используете Office 365 профессиональный плюс с версией до 1910 года.
Решение
Решение 1.
Выполните действия, описанные в разделе "Что-то пошло не так во время входа" с помощью приложения Dynamics 365 для Outlook , чтобы убедиться, что каждый из необходимых URL-адресов находятся в одной зоне безопасности Internet Explorer.
Решение 2.
- Откройте командную строку.
- Выполните следующую команду:
icacls %userprofile%\Appdata\LocalLow /t /setintegritylevel (OI)(CI)L
Решение 3.
Если вы используете Office 365 версии 16.0.11629 и Windows 10 версии 1903 или более поздней, выполните следующие действия, так как надстройки Office теперь используют Microsoft Edge WebView для надстроек Office:
- Установите предварительную версию Microsoft Edge DevTools.
- В Outlook запустите приложение Dynamics 365 для Outlook.
- Запустите предварительную версию Microsoft Edge DevTools.
- Вы должны увидеть Dynamics 365 (EXP) в качестве целевого объекта отладки.
- Выберите его, чтобы запустить средства F12 .
- Перейдите на вкладку Консоль.
- Запуск: window.localStorage.clear().
- Снова откройте приложение в Outlook.
Если вы используете ранние версии Office 365 и Windows, выполните действия по устранению ошибок при попытке открыть приложение Dynamics 365 для Outlook для очистки кэша Internet Explorer.
Если вы используете Mac, ознакомьтесь с разделом очистки кэша Приложение Office lication на Компьютере Mac.
Решение 4.
Если условия, упомянутые в причине 4, верны, установите версию 1910: 30 октября или более поздней, которая включает исправление для этого типа проблемы.