Ошибка InternetSetCookie при настройке Microsoft Dynamics CRM для Microsoft Office Outlook
В этой статье описывается решение ошибки, возникающей при настройке Microsoft Dynamics CRM для Microsoft Office Outlook.
Область применения: Microsoft Dynamics CRM 2015 г., Microsoft Dynamics CRM 2013 г.
Исходный номер базы знаний: 3092666
Симптомы
При попытке настроить Microsoft Dynamics CRM для Microsoft Office Outlook появляется следующее сообщение об ошибке:
"Существует проблема при обмене данными с сервером Microsoft Dynamics CRM. Сервер может быть недоступен. Повторите попытку позже. Если проблема не исчезнет, обратитесь к системному администратору".
При выборе сведений отображаются следующие дополнительные сведения:
Сбой InternetSetCookie с кодом ошибки: 87 в Microsoft.Crm.CookieManager.SetCookies(Uri webApplicationUri, CookieCollection cookies, CookieDataFlags cookieFlags, String p3pHeader)
в Microsoft.Crm.CookieManager.SetCookies(Uri webApplicationUri, CookieCollection cookies)
в Microsoft.Crm.Outlook.ClientAuth.ClientAuthProviderBase'1.SetWebAppCookies()
Причина
Имя сервера в URL-адресе содержит символ подчеркивания ("_"). Пример: https://crm_server
.
Microsoft Dynamics CRM для Microsoft Office Outlook использует функцию InternetSetCookieExA (wininet.h), которая не работает, если URL-адрес содержит символ подчеркивания.
Решение
Для устранения данной проблемы выполните следующие действия.
- Создайте псевдоним DNS для сервера, который не использует символ подчеркивания ("_"). Пример:
https://crmserver
. - В диспетчере развертывания на сервере Microsoft Dynamics CRM выберите Microsoft Dynamics CRM в левом верхнем углу, а затем выберите Свойства.
- Перейдите на вкладку Веб-адрес и обновите все URL-адреса, чтобы использовать псевдоним DNS.
- Нажмите ОК.
- Попробуйте настроить Microsoft Dynamics CRM для Microsoft Office Outlook с помощью нового URL-адреса, который не содержит символ подчеркивания.