Поделиться через


Ошибка "ROI.EXE перестала работать" в Microsoft Dynamics SL

В этой статье описывается решение ошибки, возникающей при попытке распечатать любой отчет в Microsoft Dynamics SL 2011.

Применимо к: Microsoft Dynamics SL 2011, Microsoft Dynamics SL 2011 с пакетом обновления 1 (SP1)
Исходный номер базы знаний: 2721084

Симптомы

При попытке распечатать любой отчет в Microsoft Dynamics SL 2011 появляется следующее сообщение об ошибке:

ROI.EXE перестала работать

Причина

Значение RI_ID в таблице RPTRUNTIME превысило ограничение в 32 767.

Решение

Очистите записи в таблице RPTRUNTIME, чтобы сбросить значение RI_ID обратно в значение 1. Для этого выполните следующие действия:

  1. Убедитесь, что все пользователи вышли из Microsoft Dynamics SL.

  2. Запустите Microsoft SQL Server Management Studio.

  3. Выполните следующую инструкцию для базы данных SL System и баз данных приложений SL.

    delete from rptruntime
    

Дополнительная информация

Таблица RPTRUNTIME содержит временные сведения, относящиеся к активному процессу печати. Как правило, эта таблица пуста, если нет пользователей, выполняющих отчет. Иногда запись может быть застряла в этой таблице, что может увеличить вероятность максимального увеличения RI_ID значений .