Поделиться через


При развертывании почтового ящика или общедоступной папки в Outlook возникают ошибки нехватки памяти

Исходный номер базы знаний: 2968387

Симптомы

При развертывании почтового ящика или общедоступной папки (за исключением папки "Входящие") в Microsoft Outlook или выборе адресной книги на панели инструментов может возникнуть одна из следующих ошибок:

Не удается отобразить папку. Для запуска этой программы недостаточно свободной памяти. Закройте одну или несколько программ и повторите попытку.

Не удается развернуть папку. Недостаточно памяти для выполнения операции.

Не удалось получить доступ к списку адресов. Требуется больше памяти или системных ресурсов. Закройте некоторые окна и повторите попытку.

При получении одной из этих ошибок исходящая почта может застрять в папке Исходящие и не отправляться до перезапуска Outlook.

Причина

Эта проблема возникает, если профиль обмена сообщениями Outlook включает учетную запись Microsoft Exchange, настроенную для использования режима кэширования Exchange, включен параметр Скачать избранное общедоступных папок и имеется много кэшированных общедоступных папок. Обычно эта проблема возникает при наличии более чем 1000 общедоступных папок или когда кэшированные общедоступные папки потребляют один гигабайт места.

Разрешение

Чтобы избежать этой проблемы, отключите параметр Скачать избранное общедоступных папок или сохраните количество кэшированных общедоступных папок избранного менее 1000. Если проблема по-прежнему возникает с менее чем 1000 общедоступных папок избранного, уменьшите количество папок, пока не перестанете получать ошибки. Как правило, вы можете уменьшить количество общедоступных папок избранного, удалив их с помощью клиента Outlook. Однако в некоторых случаях, когда у вас слишком много общедоступных папок избранного, возможно, вам не удастся удалить папки с помощью клиента Outlook, так как при выборе общедоступной папки Избранное возникает ошибка. В этом случае можно удалить общедоступную папку избранного с помощью MFCMapi.

Чтобы устранить эту проблему, отключив параметр Скачать избранное общедоступных папок , выполните следующие действия.

  1. В Outlook выберите Файл, Параметры учетной записи, а затем — Параметры учетной записи.

  2. Выберите учетную запись Microsoft Exchange и нажмите кнопку Изменить.

  3. Выберите Другие параметры.

  4. На вкладке Дополнительно снимите флажок Скачать общедоступную папку Избранное проверка.

  5. Нажмите ОК.

  6. Вам будет предложено перезапустить Outlook, чтобы эти изменения вступили в силу. Нажмите ОК.

  7. Нажмите кнопку Далее, нажмите кнопку Готово, а затем нажмите кнопку Закрыть.

  8. Закройте Outlook, а затем перезапустите Outlook.

Чтобы удалить общедоступную папку избранного с помощью MFCMapi, выполните следующие действия.

  1. Скачайте MFCMAPI.

  2. Выполните MFCMAPI.exe.

  3. В меню Сеанс выберите пункт Вход.

  4. Выберите имя профиля Outlook и нажмите кнопку ОК.

  5. В верхней панели найдите строку, соответствующую вашему почтовому ящику, а затем дважды щелкните по ней.

  6. В области навигации (слева) разверните узел Корневой почтовый ящик, а затем выберите папку Ярлыки.

  7. В области сведений (справа) найдите свойства PR_FOLDER_CHILD_COUNT. Столбец Значение содержит количество общедоступных папок избранного.

  8. Если вы хотите удалить все общедоступные папки избранного, выполните следующие действия.

    1. В области навигации. Щелкните правой кнопкой мыши папку Ярлыки, выберите Дополнительно, а затем — Пустые элементы и вложенные папки из папки.

      Снимок экрана: параметр Пустые элементы и вложенные папки из папки в контекстном меню.

    2. Оставьте параметры по умолчанию и нажмите кнопку ОК.

  9. Если вы хотите удалить определенные общедоступные папки избранного, выполните следующие действия.

    1. В области навигации разверните папку Ярлыки, щелкните правой кнопкой мыши избранное общедоступной папки, которое нужно удалить, и выберите Удалить папку.

      Снимок экрана: параметр

    2. Оставьте параметры по умолчанию и нажмите кнопку ОК.