Примечание.
Для доступа к этой странице требуется авторизация. Вы можете попробовать войти или изменить каталоги.
Для доступа к этой странице требуется авторизация. Вы можете попробовать изменить каталоги.
Симптомы
При выполнении пакета миграции общедоступных папок из Microsoft Exchange Server в Exchange Online возникает ошибка EndpointNotFoundTransientException и получают следующие сообщения об ошибках:
- Не было конечной точки, прослушивающей
https://mail.<Domain Name>.com/EWS/mrsproxy.svc, которая могла бы принять сообщение. - Удаленный сервер вернул ошибку: (404) Не найден.
Ниже приведен пример сообщения об ошибке EndpointNotFoundTransientException.
Однако при тестировании доступности сервера миграции для конечной точки общедоступной папки с помощью выполнения следующего командлета, результат является успешным.
Test-MigrationServerAvailability -Endpoint <PublicFolderMigrationEndPoint>
Ниже приведен пример командлета и выходных данных.
Причина
Эта проблема возникает при создании пакета миграции, когда вы задаете параметр SourcePFPrimaryMailboxGuid Exchange Online вместо Exchange Server.
Чтобы убедиться, что пакет миграции использует неверный SourcePFPrimaryMailboxGuid, можно выполнить командлеты, выполнив следующие действия:
Определите значение параметра, указанного
SourcePFPrimaryMailboxGuidв пакете миграции, выполнив следующий командлет:(Get-MigrationBatch | ?{$_.MigrationType.ToString() -eq "PublicFolder"}).SourcePFPrimaryMailboxGuidНиже приведен пример командлета и выходных данных.
Убедитесь, что предоставленный GUID относится к Exchange Online, выполнив командлет:
Get-Mailbox -PublicFolder <GUID>Заметка: Замените <GUID> значением, полученным из командлета на шаге 2.
Если почтовый ящик общедоступной папки успешно указан в Exchange Online, можно убедиться, что пакет миграции неправильно создан. Ниже приведен пример командлета и выходных данных.
Резолюция
Чтобы устранить эту проблему, повторно создайте пакет миграции, указав SourcePFPrimaryMailboxGuid почтовый ящик общедоступной папки на локальном сервере Exchange. Вот что нужно сделать, чтобы повторно создать пакет миграции:
Откройте оболочку управления Exchange на локальном сервере Exchange.
Получите GUID почтового ящика общедоступной папки из Exchange Server, выполнив следующий командлет:
(Get-OrganizationConfig).RootPublicFolderMailbox.HierarchyMailboxGuid.GUIDНиже приведен пример командлета и выходных данных.
Повторно создайте пакет миграции в Exchange Online, выполнив следующие действия.
Удалите существующий пакет миграции общедоступных папок, выполнив следующий командлет:
Get-MigrationBatch | ?{$_.MigrationType.ToString() -eq "PublicFolder"} | Remove-MigrationBatchЗаметка: Для удаления пакета миграции может потребоваться от 10 до 15 минут.
Убедитесь, что пакет миграции удален, выполнив следующий командлет:
Get-MigrationBatch | ?{$_.MigrationType.ToString() -eq "PublicFolder"}Создайте пакет миграции общедоступных папок, выполнив следующий командлет:
[byte[]]$bytes = Get-Content -Encoding Byte <folder_mapping.csv> New-MigrationBatch -Name PublicFolderMigration -CSVData $bytes -SourceEndpoint <PublicFolderMigrationEndPoint> -SourcePfPrimaryMailboxGuid <GUID from step 2> -AutoStart -NotificationEmails <email addresses for migration notifications>
Дополнительные сведения о миграции общедоступных папок см. в разделе "Использование пакетной миграции" для переноса общедоступных папок Exchange Server в Exchange Online.