This email is saved in another mailbox. Please select the right sender mailbox using the "From" field to view related information
This article helps you resolve the problem that occurs when you use Dynamics 365 App for Outlook.
Applies to: Microsoft Dynamics 365 Customer Engagement Online
Original KB number: 4563668
Symptoms
When using Dynamics 365 App for Outlook, you see the following message:
This email is saved in another mailbox. Please select the right sender mailbox using the "From" field to view related information
Cause
This message appears in the following scenario:
- You are composing an email while within one mailbox (Mailbox A).
- You change the From field in Outlook to another mailbox (Mailbox B).
- You then open Dynamics 365 App for Outlook.
Resolution
Open Dynamics 365 App for Outlook while within the mailbox you want to use to send the email. For example: In the scenario listed in the Cause section where you want to send the email from Mailbox B, compose the email while within Mailbox B.