Scenario: Apache Tez-programmet låser sig i Azure HDInsight
I den här artikeln beskrivs felsökningssteg och möjliga lösningar på problem när du interagerar med Azure HDInsight-kluster.
Problem
När du har skickat Apache Hive-jobbet från Tez visar du att jobbstatusen är "Körs", men verkar inte göra några framsteg
Orsak
För många jobb har skickats. lång Yarn-kö.
Lösning
Skala upp klustret eller vänta bara tills Yarn-kön har tömts.
Som standard yarn.scheduler.capacity.maximum-applications
styr det maximala antalet program som körs eller väntar, och standardvärdet 10000
är .
Nästa steg
Om du inte ser problemet eller inte kan lösa problemet kan du besöka någon av följande kanaler för mer support:
Få svar från Azure-experter via Azure Community Support.
Anslut med @AzureSupport – det officiella Microsoft Azure-kontot för att förbättra kundupplevelsen. Ansluta Azure-communityn till rätt resurser: svar, support och experter.
Om du behöver mer hjälp kan du skicka en supportbegäran från Azure Portal. Välj Support på menyraden eller öppna hubben Hjälp + support . Mer detaljerad information finns i Skapa en Azure Support begäran. Åtkomst till prenumerationshantering och faktureringssupport ingår i din Microsoft Azure-prenumeration och teknisk support tillhandahålls via någon av Azures supportplaner.