InternetSetCookie misslyckades när du konfigurerade Microsoft Dynamics CRM för Microsoft Office Outlook
Den här artikeln innehåller en lösning på ett fel som uppstår när du konfigurerar Microsoft Dynamics CRM för Microsoft Office Outlook.
Gäller för: Microsoft Dynamics CRM 2015, Microsoft Dynamics CRM 2013
Ursprungligt KB-nummer: 3092666
Symptom
När du försöker konfigurera Microsoft Dynamics CRM för Microsoft Office Outlook får du följande felmeddelande:
"Det är problem med att kommunicera med Microsoft Dynamics CRM-servern. Servern kan vara otillgänglig. Försök igen senare. Kontakta systemadministratören om problemet kvarstår."
När du väljer information visas följande ytterligare information:
InternetSetCookie misslyckades med felkoden: 87 på Microsoft.Crm.CookieManager.SetCookies(Uri webApplicationUri, CookieCollection cookies, CookieDataFlags cookieFlags, String p3pHeader)
på Microsoft.Crm.CookieManager.SetCookies(Uri webApplicationUri, CookieCollection cookies)
på Microsoft.Crm.Outlook.ClientAuth.ClientAuthProviderBase'1.SetWebAppCookies()
Orsak
Servernamnet i URL:en innehåller ett understreckstecken ("_"). Exempel: https://crm_server
.
Microsoft Dynamics CRM för Microsoft Office Outlook använder Funktionen InternetSetCookieExA (wininet.h) som inte fungerar om URL:en innehåller ett understreckstecken.
Åtgärd
Följ nedanstående steg för att lösa problemet:
- Skapa ett DNS-alias för servern som inte använder ett understreckstecken ("_"). Exempel:
https://crmserver
. - I Distributionshanteraren på Microsoft Dynamics CRM-servern väljer du Microsoft Dynamics CRM i det övre vänstra hörnet och väljer sedan Egenskaper.
- Välj fliken Webbadress och uppdatera alla URL:er för att använda DNS-aliaset.
- Välj OK.
- Försök att konfigurera Microsoft Dynamics CRM för Microsoft Office Outlook med hjälp av den nya URL:en som inte innehåller ett understreckstecken.