En eller flera duplicerade poster hittades i Microsoft Dynamics 365 när objekt sparades från Exchange till Microsoft Dynamics 365
Den här artikeln innehåller en lösning på felet En eller flera dubblettposter hittades i Microsoft Dynamics 365 när du sparade objekt från Exchange till Microsoft Dynamics 365 som kan inträffa när du spårar en kontakt i Microsoft Outlook.
Gäller för: Microsoft Dynamics CRM
Ursprungligt KB-nummer: 4053811
Symptom
När du spårar en kontakt i Microsoft Outlook skapas inte kontakten i Microsoft Dynamics 365, men följande avisering loggas i postlådeposten:
En eller flera dubblettposter hittades i Microsoft Dynamics 365 när objektet "<Kontaktnamn>" sparades från Exchange till Microsoft Dynamics 365. Vill du fortsätta och skapa en duplicerad post ändå?
Felkod för e-postserver: ExchangeSyncDuplicateRecordsError
Om du väljer Information visas följande mer information:
T:420
ActivityId: <GUID>
Undantag: Ohanterat undantag: Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncException: Det gick inte att synkronisera objektet till CRM-servern, felkod: 102 på Microsoft.Crm.Asynchronous.EmailConnector.CrmItem.PerformActionBasedOnUserDecision(Int32 errorCode,
SyncItemChangeType changeType) på Microsoft.Crm.Asynchronous.EmailConnector.CrmItem.UpdateItem() på
Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncSteps.WriteToCrmStep.UpdateInCrm(IEnumerable'1 syncItems)
Orsak
Detta inträffar om dubblettidentifiering är aktiverat i Microsoft Dynamics 365 och kontakten du spårade i Outlook matchar en befintlig post i Microsoft Dynamics 365.
Till exempel: Anta att du har en regel för duplicerad identifiering som konfigurerats endast baserat på förnamn och efternamn och att det finns en befintlig kontaktpost i Microsoft Dynamics 365 med namnet Nancy Anderson. Om du har en kontakt i Outlook med samma namn och väljer att spåra kontakten i Microsoft Dynamics 365 identifierar regeln för dubblettidentifiering en matchning och skapar inte posten utan bekräftelse.
Åtgärd
Kontrollera om kontakten som du spårade i Outlook ska skapas i Microsoft Dynamics 365 eller om den är en dubblett av en befintlig post. Om posten ska skapas i Microsoft Dynamics 365 väljer du alternativet Ja i aviseringen.
- Få åtkomst till din Microsoft Dynamics 365-organisation i en webbläsare.
- Gå till Inställningar och välj sedan E-postkonfiguration.
- Välj Postlådor.
- Öppna postlådeposten och välj sedan avsnittet Aviseringar till vänster på sidan.
- Leta upp aviseringen för kontaktposten som inte skapades eftersom en potentiell dubblett hittades.
- När du hovrar musen över aviseringen bör du se alternativet Ja och Nej i det övre högra hörnet. Om du vill skapa kontakten i Microsoft Dynamics 365 väljer du Ja.