Felet "<DOMÄNNAMN<> kunde inte autentiseras" i Microsoft Dynamics SL
Den här artikeln innehåller en lösning på problemet att det inte gick att autentisera < domänen\<ANVÄNDARNAMNet> när du använder Microsoft Dynamics SL.
Gäller för: Microsoft Dynamics SL 2011 Service Pack 1, Microsoft Dynamics SL 2011
Ursprungligt KB-nummer: 2770709
Symptom
Du får följande felmeddelande i Microsoft Dynamics SL:
<DOMAIN\<USER NAME> kunde inte autentiseras. Ange ett giltigt Windows-användarnamn med behörighet till domänen SQL Server körs.
Det här meddelandet kan inträffa av något av följande är sant:
- Du uppgraderar Microsoft Dynamics SL och väljer Windows-autentisering som autentiseringstyp.
- Du ändrar autentiseringstypen från SQL Server-autentisering till Windows-autentisering.
Orsak
SQL Server Service-användaren har inte LÄS-behörighet till domänanvändarkontoobjekten i Active Directory.
Åtgärd
Bevilja SQL Server Service-användaren LÄS-behörigheter till användarkontoobjekten eller ändra SQL Server Service-användaren till ett domänkonto som har LÄS-behörighet. Följ dessa steg för att verifiera SQL Server-tjänstanvändaren:
Steg | Details |
---|---|
1. | Logga in på Windows på datorn där SQL Server är installerat. |
2. | Öppna Kontrollpanelen. |
3. | Välj Administrationsverktyg och sedan Tjänster. |
4. | Högerklicka på SQL Server (MSSQLSERVER) och välj sedan Egenskaper. |
5. | På fliken Logga in noterar du kontot. |
Kommentar
Kontot måste ha LÄS-behörighet till domänanvändarkontoobjekten i Active Directory. Om det lokala systemkontot har valts måste datorobjektet i Active Directory för den dator som kör SQL Server ha LÄS-behörighet till objekten domänanvändarkonto i Active Directory.