Ett fel uppstod vid sändning av e-post för postlådefel vid testning och aktivering av en postlåda i Microsoft Dynamics 365
Den här artikeln innehåller en lösning på ett fel som uppstår när du försöker testa och aktivera en postlåda i Microsoft Dynamics 365.
Gäller för: Microsoft Dynamics 365
Ursprungligt KB-nummer: 4092737
Symptom
När du försöker testa och aktivera en postlåda i Microsoft Dynamics 365 får du följande fel:
"Ett fel uppstod när e-postlådan "Din postlåda är nu ansluten till Dynamics 365" när du ansluter till e-postservern. Ägaren till den associerade e-postserverprofilen <Postlådenamn> har meddelats. Systemet försöker skicka e-post igen senare.
Email serverfelkod: Webbservern returnerade ConnectFailure-undantag."
Orsak
Det här felet kan inträffa om Dynamics 365 inte kan ansluta till e-postservern.
Om du använder Dynamics 365 Online med Exchange on-premises kan det inträffa om brandväggen inte tillåter kommunikation från Dynamics 365 online.
Om du använder en SMTP/POP3-provider som Gmail kan det inträffa om portvärdena i avsnittet Avancerat i e-postserverprofilen inte är korrekta.
Åtgärd
Dynamics 365 Online med Exchange on-premises
Kontrollera att brandväggen tillåter kommunikation från Dynamics 365 online. En lista över IP-adressintervall som kan användas av Dynamics 365 finns i Microsoft Dynamics CRM Online IP-adressintervall.
POP3/SMTP-leverantörer som Gmail
Kontrollera att rätt portar har angetts:
Gå till Inställningar, Email Konfiguration och välj sedan Email serverprofiler.
Öppna den Email serverprofil som används av postlådan som uppfyller det här felet.
Obs!
Du kan också välja namnet på Email serverprofilen i felmeddelandet. Den visas som en hyperlänk som öppnar rätt Email serverprofilpost.
Välj Avancerat.
Kontrollera värdena inkommande port och utgående port och välj sedan Spara.
Obs!
Se dokumentationen från din e-postleverantör för rätt portar som ska användas vid anslutning till SMTP-tjänsten. För Gmail är den inkommande POP3-porten 995 och den utgående SMTP-porten är 587.
Välj Postlådor och välj sedan den postlåda som tog emot felet.
Välj knappen Testa & Aktivera postlådor .
När testerna har slutförts öppnar du postlådeposten och visar avsnittet Aviseringar om resultatet inte visas som Lyckades.