Felet "Det finns en öppen tillämpad post eller så finns det en tillämpningspost utanför det valda intervallet" vid utskrift av rapporten Borttagning av kundfordringar för transaktionshistorik

Den här artikeln innehåller en lösning på problemet att du inte kan skriva ut rapporten Borttagning av kundfordringars transaktionshistorik i Microsoft Dynamics GP.

Gäller för: Microsoft Dynamics GP
Ursprungligt KB-nummer: 871985

Symptom

När du försöker skriva ut rapporten Borttagning av transaktionshistorik för kundfordringar i Microsoft Dynamics GP visas följande felmeddelande i rubriken och gäller för dokumentet om det har en asterisk bredvid sig:

Det går inte att ta bort den här transaktionen: det finns en öppen tillämpad post eller så finns det en tillämpad post utanför det valda intervallet.

Orsak

Om en asterisk inte visas bredvid ett specifikt dokument har historiken tagits bort. Meddelandet visas i rubriken i dokumentet och tillämpar det bara på att dokumentet har en asterisk bredvid sig. Det är avsiktligt att historiken inte tas bort om du har konfigurationen markerad för att behålla historiken.

Lösning

Följ de här stegen för att lösa problemet:

  1. Öppna dialogrutan Konfiguration av hantering av kundfordringar . Gör detta genom att följa lämpligt steg:

    • I Microsoft Dynamics GP 10.0 och senare versioner pekar du på VerktygMicrosoft Dynamics GP-menyn , pekar på Installation, pekar på Försäljning och väljer sedan Kundfordringar.
    • I Microsoft Dynamics GP 9.0 eller tidigare versioner pekar du på Installationverktygsmenyn , pekar på Försäljning och väljer sedan Kundfordringar.
  2. Avmarkera kryssrutan Skriv ut historiskt föråldrt utvärderingssaldo och välj sedan OK.

  3. Öppna dialogrutan Ta bort transaktionshistorik och ta sedan bort transaktionen i dialogrutan Ta bort transaktionshistorik för kundfordringar . Öppna dialogrutan Ta bort transaktionshistorik genom att följa lämpligt steg:

    • I Microsoft Dynamics GP 10.0 och senare versioner pekar du på VerktygMicrosoft Dynamics GP-menyn , pekar på Verktyg, pekar på Försäljning och väljer sedan Ta bort transaktionshistorik.
    • I Microsoft Dynamics GP 9.0 eller tidigare versioner pekar du på Verktygpå verktygsmenyn , pekar på Försäljning och väljer sedan Ta bort transaktionshistorik.

    Obs!

    För att upprätthålla dataintegriteten tar du bort både debetdokumentet och det tillämpade kreditdokumentet.

  4. Öppna dialogrutan Konfiguration av hantering av kundfordringar , markera kryssrutan Skriv ut historiskt föråldrt utvärderingssaldo och välj sedan OK.