Microsoft Dynamics 365'te posta kutusu test edildiğinde ve etkinleştirilirken e-posta iletisi gönderilirken bilinmeyen bir hata oluştu

Bu makalede, Microsoft Dynamics 365'te bir posta kutusunu test etmeye ve etkinleştirmeye çalıştığınızda oluşan bir hataya çözüm sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics 365
Özgün KB numarası: 4092733

Belirtiler

Microsoft Dynamics 365'te bir posta kutusunu test etmeye ve etkinleştirmeye çalıştığınızda aşağıdaki hatayı alırsınız:

"Posta kutunuz artık Dynamics 365'e bağlı" e-posta iletisi gönderilirken bilinmeyen bir hata oluştu. Posta Kutusu Posta Kutusu <Adı> eşitlenmedi. İlişkili e-posta sunucusu profili Profil <Adı> sahibine bildirimde bulunuldu."

Ayrıntılar bölümünü seçerseniz, aşağıdaki metin gibi diğer ayrıntıları da görebilirsiniz:

"Hata: System.Net.Mail.SmtpException: Sözdizimi hatası, komut tanınmadı. Sunucu yanıtı:
at System.Net.Mail.SmtpConnection.ConnectAndHandshakeAsyncResult.End(IAsyncResult result)
at System.Net.Mail.SmtpTransport.EndGetConnection(IAsyncResult result)
at System.Net.Mail.SmtpClient.ConnectCallback(IAsyncResult result)"

Neden

Bu hata, e-posta sunucusu profilinin Gelişmiş bölümündeki Giden Bağlantı Noktası değeri doğru değilse oluşabilir.

Çözüm

Bu sorunu gidermek için aşağıdaki adımları izleyin:

  1. Ayarlar'a gidin Email Yapılandırma'ya gidin ve sunucu profillerini Email seçin.

  2. Bu hatayı karşılayan posta kutusu tarafından kullanılan Email Sunucu Profilini açın.

    Not

    Hata iletisinde Email Sunucu Profilinin adını da seçebilirsiniz. Doğru Email Sunucu Profili kaydını açan bir köprü olarak görünür.

  3. Gelişmiş'i seçin.

  4. Giden Bağlantı Noktası değerini düzeltip Kaydet'i seçin.

    Not

    SMTP hizmetine bağlanırken kullanılacak doğru bağlantı noktaları için e-posta sağlayıcınızın belgelerine bakın. Gmail için bağlantı noktası 587'dir.

  5. Posta Kutuları'nı ve ardından hatayı alan posta kutusunu seçin.

  6. Posta Kutularını Etkinleştir & düğmesini seçin.

  7. Testler tamamlandıktan sonra, posta kutusu kaydını açın ve sonuçlar Başarılı olarak görünmüyorsa Uyarılar bölümünü görüntüleyin.