Microsoft Dynamics 365'teki Email Sunucu Profilinden Bağlantı Testi başarısız oluyor

Bu makalede, Microsoft Dynamics 365'teki Email Sunucu Profilinden Bağlantı Testi'nin başarısız olması sorununa yönelik bir çözüm sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics 365 Customer Engagement Online
Özgün KB numarası: 4493267

Belirtiler

Dynamics 365'te bir Email Sunucu Profilinden Bağlantıyı Test Et seçeneğini kullanırken test başarısız olur ve aşağıdaki örneğe benzer bir hata görebilirsiniz:

"Uzak sunucu hatası: (401) Yetkisiz. Girdiğiniz kullanıcı adı ve parolanın doğru olduğundan emin olun ve yeniden deneyin." veya

"System.Net.WebException: İşlem System.Net.HttpWebRequest.GetResponse() konumunda zaman aşımına uğradı
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeConnectivityDiscoverer.ValidateServerUrl(EmailDirectionCode emailDirection)"

Neden

  • Neden 1: Kullanıcı adı veya parola doğru değil.

  • Neden 2: Şirket içi Exchange'e bağlanmak için Dynamics 365 (çevrimiçi) kullanıyorsanız, güvenlik duvarınız Dynamics 365'ten Exchange sunucunuza bağlanmaya izin vermiyorsa bu hata oluşabilir.

  • Neden 3: Bazı durumlarda, kimlik bilgileri doğru olsa ve bağlantı sorun olmasa da test bağlantısı başarısız olabilir. Çözüm bölümündeki Çözüm 3'e bakın.

Çözüm

  • Çözüm 1: Kullanıcı adı ve parolanın doğru olduğunu doğrulayın.

    Not

    Kullanıcı Adı değerinin UPN (Kullanıcı Asıl Adı) biçiminde olması gerekir. Örn. username@contoso.com yerine contoso\username.

  • Çözüm 2: Şirket içi Exchange ile Dynamics 365 (çevrimiçi) kullanıyorsanız, güvenlik duvarınızın başvuruda bulunılan Azure IP aralıkları da dahil olmak üzere Microsoft Dynamics CRM Online IP Adresi Aralıkları'nda belgelenen IP aralıkları listesinden bağlantıya izin verdiğinden emin olun.

  • Çözünürlük 3: Test Bağlantısı sonuçları her zaman güvenilir değildir. Microsoft Uzak Bağlantı Çözümleyicisi'nden test bağlantısı yaparken aynı kullanıcı adı ve parola çalışıyorsa, Bağlantıyı Test & Et seçeneği yerine Dynamics 365'te Posta Kutularını Test Et seçeneğini kullanın. Test & Etkinleştirme posta kutularınız için başarılı olursa, Test Bağlantısı iletişim kutusundan sonuçları göz ardı edebilirsiniz.

    Not

    Posta Kutularını Etkinleştir & düğmesini kullanarak herhangi bir hata oluşursa, posta kutusu kaydının içindeki Uyarılar sekmesine bakın ve dahil edilen yardım bağlantılarını gözden geçirin.